í before e
August 8, 2008 3:18 PM   Subscribe

FirefoxFilter: On certain sites, Firefox (for Vista) displays an accented lowercase i instead of an apostrophe. The HTML for the sites in question calls for UTF-8 encoding, which is what Firefox says it's using. Why is this happening?

I've only noticed this recently and not on very many of the things I browse to, but it's still annoying and I don't understand why it happens.

Example here. This also happens on the Chyrp install I just set up on my own blog, which I won't link here. To explain what I mean, the first few words of this post show up as "Sure, itís been awhile" rather than "Sure, it's been awhile" like they should. I don't understand what's causing this, because Firefox is set to UTF-8 for this page, and it shows up fine in IE7. Anyone know what's going on?
posted by phaded to Computers & Internet (7 answers total) 1 user marked this as a favorite
 
Just because a page calls for UTF-8 in the meta tag doesn't mean it's actually UTF-8. Sometimes the meta tag is simply wrong. Wthen this happens, extended characters are going to look weird.

Also, your example page looks fine in Firefox 3 on XP and is correctly detected as UTF-8.
posted by kindall at 3:39 PM on August 8, 2008


Shows up fine in Firefox 3 (Vista 64).
posted by wongcorgi at 3:52 PM on August 8, 2008


The site actually isn't using an apostrophe at all. If we look in the source, they are using a Right Single Quotation Mark.

’ ’ Right Single Quotation Mark

What I don't know though, is why this is churning out the the 11th letter of the Faroese alphabet.

If you go to Tools > Options > Content > Languages > Choose ... what do you have in there?
posted by B(oYo)BIES at 3:54 PM on August 8, 2008


Response by poster: B(oYo)BIES: "If you go to Tools > Options > Content > Languages > Choose ... what do you have in there?"

en-us and en.
posted by phaded at 4:08 PM on August 8, 2008


Best answer: Your example page renders fine for me in Firefox 3, Vista 64, with default fonts in US English locale. Interesting mystery.

The page encoding shouldn't matter because the HTML encodes your broken character in ASCII via the HTML entity 8217;. That's U+2019, RIGHT SINGLE QUOTATION MARK, which shouldn't be used as an apostrophe but is close enough it should look OK. I can't imagine any reason why it ends up looking like í. My only guess is something's wrong with your fonts? What happens if you make Firefox use a different font for that page?
posted by Nelson at 4:39 PM on August 8, 2008


Response by poster: Nelson, thanks, I hadn't even considered that the font could be the issue. I had Helvetica Neue installed on here; I deleted that, and found that was the issue. Everything looks fine now. Thanks!
posted by phaded at 5:28 PM on August 8, 2008


Interesting! I was just reading a book earlier today in which the apostrophes were messed up in exactly the same way, but only in the preface. On closer inspection, it looks like the preface is a different font than the rest of the book.
posted by hades at 8:47 PM on August 8, 2008


« Older Help me dispose of this sad little corpse   |   My eyes, they burn. Newer »
This thread is closed to new comments.