XP and Vista laptops won't access net at same time :/
July 29, 2008 1:54 PM   Subscribe

I'm setting up a wireless network in my house and am having a problem getting my XP laptop and my roommates Vista laptop on at the same time. I can get one or the other accessing the internet (when right clicking on network and repairing). I'm assuming this is an IP conflict since when I get her Vista laptop accessing the net, a yellow triangle with an exclamtion mark pops up in my task bar and then my laptop won't access the net. My guess is I have to set up a static IP for both?
posted by debu to Computers & Internet (19 answers total) 1 user marked this as a favorite
 
So if I understand this correctly, you can get the first computer regardless of OS to connect at any given time?

Is it possible that the DHCP is set to only hand out one IP connection at any point in time?

Alternatively, you may have allocated more IP addresses but there are other services/machines in the area accessing your router which limits the number of available connections to only 1?


linkety-link for more info.
posted by fox_terrier_guy at 2:08 PM on July 29, 2008


Your router should have a setting allowing it to function as a DHCP server. This will assign a unique IP address to each connecting PC. There's probably a web interface to your router (often via http://192.168.0.1).
posted by le morte de bea arthur at 2:09 PM on July 29, 2008


I accessed the routers page and the settings are as follows for DHCP:

Use Router as DHCP Server (This is checked)
Starting IP Address 192.168.1.2
Ending IP Address 192.168.1.254

Do i need to change these settings? Or set static IP's for both laptops so they can access at the same time? thanks!
posted by debu at 2:29 PM on July 29, 2008


You don't have to setup static IP addresses for both. In fact, it's the opposite. They should both be set to DHCP.

My guess is that one of the laptops is set to use 192.168.1.2, creating a conflict when the other one comes online and the DHCP server gives it that address, not knowing that the address is already in use.
posted by cnc at 3:10 PM on July 29, 2008


"My guess is that one of the laptops is set to use 192.168.1.2, creating a conflict when the other one comes online and the DHCP server gives it that address"

Both laptops are set to "obtain IP address automatically" would the above apply? thanks
posted by debu at 3:20 PM on July 29, 2008


Go to the command prompt and run IPCONFIG. That should be your first step in troubleshooting.
posted by wongcorgi at 3:31 PM on July 29, 2008


I'm assuming this is an IP conflict since when I get her Vista laptop accessing the net, a yellow triangle with an exclamtion mark pops up in my task bar and then my laptop won't access the net.

Wait. Is the box saying "Detected IP conflict" or "Limited connection."

Limited connection is meaningless. It can mean everything from wrong WEP/WPA key to firewall issues.
posted by damn dirty ape at 3:46 PM on July 29, 2008


I did IPconfig earlier on my XP laptop and got the dns servers and all that to set up a static IP. DHCP "is" enabled on the router and my computer is logging on fine.

I just did Ipconfig on my roommates computer and bunch of info that looks much different than what I'm used to seeing on XP. DHCP comes up as NO on her computer... any clues?
posted by debu at 8:50 PM on July 29, 2008


I'm don't know how to translate this into the terms you are using but bear with me. You need to get the XP to connect through the Vista. Only Vista connects to the net and you hide the XP in the Vista.
I'll see if I can find someone to explain it... :)
posted by mu~ha~ha~ha~har at 10:45 PM on July 29, 2008


This might be it. I can't find the article (but when I showed it to SO he laughed and said 'yeah that's what I did'.) You have to go through Vista and not the other way around. And something about a folder. You make a folder for the XP on the Vista (although I can't tell you where that folder was to be made) and that's how the XP sneaks onto the net - either wearing a 'Vista hat' or just getting a piggy back (I can't remember which exactly).
posted by mu~ha~ha~ha~har at 11:12 PM on July 29, 2008


Obtain IP address automatically is what you want. Make sure that it's enabled for the wireless adapter and not just for the wired network connection on the laptops. Post the IP config information from your roommate's laptop here. (There won't be anything confidential in it.)
posted by cnc at 11:56 PM on July 29, 2008


The page mu~ha~ha~ha~har links to is for setting up a wireless connection without an access point, and then sharing the internet across that connection. Since you have an access point (your wireless router), do not follow these instructions.

You want to use DHCP to get an IP from your router. So your router is the DHCP server, and each laptop must be configured to obtain IP's automatically. It sounds like your roomates Vista laptop has DHCP off.

Let's check. In Vista, go to Control Panel, then Network Connections. Right click on the wireless adaptor. Click Status, then the Details button. A window with some details will appear. For "DHCP Enabled" you want it to say "Yes". If it says "No", you have to turn it on.

To turn it on, close the details page and then right click the wireless adaptor in the Network Connections window again and click Properties. The Properties window will appear. Select "Internet Protocol Version 4 (TCP/IPv4)", then click the Properties button just below and to the right. Yet another Properties window will appear. In this one, set it to "Obtain and IP address automatically" and "Obtain DNS server address automatically". Then click okay and then close the properties window. Now DHCP is enabled for the wireless adaptor. Try repairing the Vista network connection. Does it work?
posted by tracert at 1:22 AM on July 30, 2008


I'm sorry, I was thinking about XP. To get to the Network Connections page I was talking about in Vista, just click the start button, then type "ncpa.cpl" (without quotes) into the search bar and press enter. The network connections page will appear.

You can get to it just by clicking around, but this is just a little shortcut that will be sure to get you to the right place.
posted by tracert at 1:35 AM on July 30, 2008


Hey Tracert, I've had the obtain IP address and DNS servers set to obtain automatically for the "wireless adapters" on both computers since the beginning :/

Here's some settings from the ipconfig/all of the Vista laptop:

Host Name: Tannya-PC
Primary DNS suffix:
Node type: hybrid
Ip routing enabled: NO
Wins proxy enabled: NO


Wireless Lan adapter wireless connection:

connection specific DNS suffix:
Description broadcom 802.11b/G LAN
Physical address: Yes
DHCP enabled: Yes
Autoconfiguration enabled: Yes
Link-local IPv6 address : fe80::8cbb:bde1:9c6:ec4d%8(Preferred)
Autoconfiguration IPv4 address: 169.254.236.77(Tentative)
Subnet Mask: 255.255.0.0
Default Gateway:
DHCPv6 IAID: 201333363
DNS Servers: fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
Netbios over Tcpip: Enabled


IPconfig in Vista was about 3 pages long, let me know if you need any more settings?
I've also had an IP conflict message pop up on the Vista laptop and then a small yellow triangle with an exclamation point pops up in the taskbar of the XP laptop.
posted by debu at 1:51 PM on July 30, 2008


If you are sure both clients are configured correctly (so DHCP for everything), but you're still getting IP conflicts, then the problem must be either with the router or someone else we don't know about.

Try resetting your router and starting from scratch. Choose a different SSID than the one you have right now, and don't broadcast it. Assuming you can get both clients connected and working right, then turn on WPA or WPA2 if it wasn't on already.
posted by tracert at 8:21 PM on July 30, 2008


Somewhere in this setup on your router you should select clone MAC address, that way your ISP sees one computer no matter who is on. The rest of it should be pretty much automagically taken care of.
posted by ptm at 5:57 AM on July 31, 2008


Im suspecting a double-NAT issue here.

What device is plugged into your router?
posted by damn dirty ape at 7:08 AM on July 31, 2008


That is to say, a double-DHCP server issue.
posted by damn dirty ape at 7:08 AM on July 31, 2008


damn dirty ape may be right about the double-DHCP issue. Make sure Internet Connection Sharing is turned off on both PCs. Vista and XP.
posted by cnc at 6:50 PM on July 31, 2008


« Older Artist + biz = hope me   |   How to find the age of a page? Newer »
This thread is closed to new comments.