Network woes
July 28, 2008 7:57 PM   Subscribe

Why can't I access my network shares after I connect to the WiFi at work?

The wireless connection on my little laptop works great. I can access my printserver, my NAS, and my other computers. However when I go to the university and connect as a guest to their campus-wide WiFi network, everything gets messed up. Once I return home, I can access the internet through my router, but any attempt to connect to any network share gives me the error "X is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions. The network path was not found." Even clicking on the network SSID gives the message "The list of servers for this workgroup is not currently available." It has gotten so bad that I have been backing up the laptop using Acronis and then restoring the hard drive to working order when I get home from work. File and printer sharing is turned on. I use Windows Live OneCare for AntiVirus and Firewall. I'm pulling my hair out here. Any ideas before I leap from a bridge?
posted by Crotalus to Computers & Internet (4 answers total) 1 user marked this as a favorite
 
My MacBook Pro loses network shares when I come out of sleep mode. A reboot helps me, but seems unnecessary.

I am really eager to find out what you discover. Please post solutions if you find any that work!
posted by newfers at 9:41 PM on July 28, 2008


This sounds like a name resolution problem. Your machine is likely set to rely on Broadcasts to resolve the computer and device names on your local network. This is an inefficient and unreliable way to resolve computer names to IP addresses. There are a few ways to fix this.

Make sure you either reboot the PC or go to the CMD line and type ipconfig /flushdns after you change networks. Going in and out of sleep mode and changing networks will cause you problems. If you're rebooting your PC and things still don't work, keep reading.

One way to fix this is to use static (pre-assigned) IP addresses (for your non-laptops) and a hosts file. The hosts file will store name to IP address resolution information on your PC, so it doesn't have to broadcast to find the other hosts. The short, short version:
1. Assign your non-laptop devices a static IP address. (Don't assign laptops a static IP, or they won't work when you connect to wireless networks outside your home). Make sure to assign the router's IP address as DNS and as the Default Gateway. You'll need to look at your router configuration and assign the IP addresses outside your DHCP scope. DHCP Scope = the possible addresses your router might give to PCs and devices that request an address. This is usually something like 192.168.1.50 to 192.168.1.100. Meaning that anything less than 192.168.1.50 is an OK static IP address to assign to a device. Assign one IP and test it to make sure you still get Internet access.
2. On your laptop, open the directory where your hosts file is located: %SystemRoot%\system32\drivers\etc\
You can copy and paste that line into your Start menu's run dialog and it will take you to the directory.
3. Open the hosts file with Notepad. (You can drag the hosts file on to Notepad to open it).
4. Add lines for your devices. It should look something like this:
192.168.1.5 NAS
192.168.1.6 Printserver
192.168.1.7 DesktopPC1
192.168.1.8 DesktopPC2
5. Save the file, making sure Notepad doesn't call it hosts.txt. It should be called hosts , with no file extension.

Now, when you browse for \\NAS, the file share should pop right up. One thing to be aware of is that if you go to another network that has the same addresses as the ones on your home network, your computer will see them as having the names of your hosts. So if you go to another network with a computer using the address 192.168.1.5, your laptop will see it as NAS because that's what's in the hosts file.

You could run your own DNS, but that's more complicated.
posted by cnc at 10:03 PM on July 28, 2008


I had this problem recently, too.
First, in the command prompt, run IPCONFIG /ALL. Note the Node Type towards the top. If it isn't Broadcast, try the following:
Try pinging the IP address of one of the other computers on your network.
If you can ping the IP address, try pinging their NETBIOS name. (This will be in the form of "\\sharename")
If you can ping the IP address and can't ping the NETBIOS name, you probably had the same problem I had and need to set the Node type to Broadcast (Sorry cnc!).

You need to make the following change to your registry to change it - you can cut and paste what is below into any empty text file named whatever.reg and execute it to enter it automatically:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NetBT\Parameters]

"NodeType"=dword:00000001


Unfortunately, if this is a fix, then it won't help with the going back and forth, but at least it will be working.
posted by cimbrog at 6:50 AM on July 29, 2008


A reboot doesn't fix it?

Try mapping your shared drives using the ip address instead of the name. That often masks problems like this.
posted by gjc at 3:32 PM on July 29, 2008


« Older where can i sell my hair?   |   What's in a name? Newer »
This thread is closed to new comments.