Help with Wifi!
June 22, 2008 5:42 PM   Subscribe

How can I increase the range of my brand new Linksys WRT600N wireless router so that my wife's Dell Inspiron 1505 gets a better signal? My former router, a 3 year old Linksys model (WRT54G) seemed to send a much better signal, and I bought this new router thinking I'd see improvements a-plenty, but noooooo, and documentation is sorely lacking. Help! I really don't want to go back to the WRT54G, since surely this new router is more capable when set up properly, right?

I am pretty much a novice when it comes to a lot of wireless technology. The WRT600N is a dual-band router, I know, so it can supposedly support 802.11g and 802.1n signals simultaneously without simply running at the lower speed for both.

My wife's laptop has an 802.11g card, whereas my MacBook Pro is a 802.11n capable machine. When my wife is online, she gets a poor signal from only 30 feet away!! Sometimes the connection will even drop.

I could just blindly mess with settings, but I'd rather ask for some help from the kind people of AskMefi... Also, if I change the encryption settings, which settings are likely to improve or degrade the signal? I'm keeping it on WEP right now, until advised otherwise (yes yes, I know it is a weak encryption! Sorry!)

Thanks in advance for any help you wonderful gurus can provide!
posted by newfers to Technology (15 answers total) 2 users marked this as a favorite
 
Yes, you want WPA2, not WEP, but that won't affect the signal strength any.

30 feet is far enough for a bad signal, depending on the architecture and ambient radiation. Have you tried "aiming" the antennas in the router and/or laptop to determine if it's a directional weakness? If so, easy to fix with a repositioned router or add-on antenna.

If you still have the old WRT54G (love that one, I have two), why not use both, with the second one on the other side of the house?
posted by rokusan at 5:48 PM on June 22, 2008


You should also be able to use the WRT54G on a separate channel.
posted by delmoi at 5:53 PM on June 22, 2008


Presuming your wife is generally using the machine in (roughly) the same spot, you could try adding a simple reflector to make your WAP antennae a little more directional.

Alternatively, you my be able to set up your WRT54G (depending upon the particular model you have) as a repeater, presuming there's somewhere convenient to put it.
posted by pompomtom at 6:32 PM on June 22, 2008


s/my/may/
posted by pompomtom at 6:32 PM on June 22, 2008


Ooooh,a repeater, ehhhh? Gosh, how do I go about that?
posted by newfers at 6:46 PM on June 22, 2008


I don't quite remember where it was, but I read somewhere that those routers did not perform particularly well in mixed signal mode (both G and N). When you limited them to either G or N. It might be worth just to try it to see if that's really the case.

The other thing to try is to change the channel that the router is broadcasting on. Most sources will recommend trying channels 1, 6, and 11 to see which one has less interference, since other electronic devices in your house as well as other routers around you may be causing interference on one or more of those channels.
posted by tuxster at 6:49 PM on June 22, 2008


Before you spend the $$ on a repeater put one of these on your router. The directional capability will boost your signal and focus towards your target computer. These have worked well for me and several friends that wanted extended range in various environments. And the price , a little cardboard and tin foil is nearly nil. If it doesn't work , then go spend $$ on the repeater.
posted by Agamenticus at 7:37 PM on June 22, 2008


Also have your wife download the newest drivers for her wireless card. Sounds like a problem with her computer, not the router.
posted by k8t at 9:34 PM on June 22, 2008


If you still have the old WRT54G, and it's a candidate for the
Tomato Firmware, you could try putting that on there and turning up the power of the radio. Default power on those things is about 40% of what it's capable of transmitting at..
posted by barc0001 at 11:57 PM on June 22, 2008


Did you change your router's physical location?

Wireless signals are okay at travelling through walls at right angles, but if you're at a funny angle the signal will drop dramatically. You may wish to try simply moving it to somewhere more central in your house or more in line to places you commonly hang out with your laptops.
posted by Dillonlikescookies at 3:11 AM on June 23, 2008


I'd just spring for an n-card for the laptop. This is the easiest way to get a better signal. The rest require a bit more tech know-how and labor (repeaters, new antennas, setting up the old one as a transparent gateway). Personally, I think the some manufacturers half-ass G on N routers. They're expecting you to use N anyway, which has better range.

Also, you can try to move that wireless router to a more centralized location.
posted by damn dirty ape at 8:31 AM on June 23, 2008


Also, Ive found that having a N device nears a G device often hurts G. You could also make the router do G-only and skip buying an N card for the laptop.
posted by damn dirty ape at 8:32 AM on June 23, 2008


I would be curious what the throughput on the 802.11n connection is. The 802.11n frequency range is 2.4GHz but it uses a 40MHz wide band. I believe the n specification called for adaptive rate selection which would monitor interference on the channel, and then scale back the throughput if needed. This is important considering that with the 40MHz spectral mask it is likely to obliterate at least a couple of the standard 22MHz channels. I would suspect that your n router is essentially "shouting" and making it hard to "hear" the 802.11g signal. I would try to set up both routers at opposite ends of the spectrum. The problem is when, for example, the n router is set improperly. For instance, centered on channel 6 the 802.11n router will use bandwidth from 2417MHz to 2457MHz. This will obfuscate all channels it crosses from 2400MHz to 2483MHz. This means your only real solution is to use the lowest channel for 802.11n (2 or 3 at the highest) and then channel 10 or 11 for 802.11b/g. As an aside, 802.11a will provide the same throughput as 802.11b/g yet operates in a different frequency range so you wouldn't have any conflicts. This is all assuming, of course, that this addresses your problem in the first place.
Good luck!
posted by mcarthey at 10:41 AM on June 23, 2008 [1 favorite]


If you still have the old WRT54G, and it's a candidate for the
Tomato Firmware, you could try putting that on there and turning up the power of the radio. Default power on those things is about 40% of what it's capable of transmitting at..


You can also try dd-wrt if you're going to look into flashing the firmware. It will provide the same function mentioned above.
posted by mcarthey at 10:43 AM on June 23, 2008


Thanks for the info on dd-wrt.... I had checked it out last week, but at the time, there was a problem whereby the router would lose WIRED internet connectivity, which was not acceptable to me, as I have my XBOX360 and my PC Desktop plugged directly into it.

Now, however, there is a fix, and once I installed the fix along with the most recent dd-wrt firmware, all is well, or at least better. My wife's laptop is connecting with full strength now, and is staying at full strength, and I am on my MacBook Pro writing this response, and my connection has also been rock solid, so....yay!

And thank you so much for prompting me to check out the 3rd party firmware!

I also think I will get a wireless-n card for my wife's laptop, but for now, it's not urgent.
posted by newfers at 5:59 PM on June 23, 2008


« Older Help me learn to like coffee.   |   Birding Gurus: Was that really a Carolina Wren? Newer »
This thread is closed to new comments.