Is Microsoft's service pack messing with Firefox pop-up blocker?
August 12, 2004 4:08 PM   Subscribe

MS Conspiracy Filter: Just installed XP SP2--which adds "pop-up blocking" to IE--and all of a sudden the pop-up blocking feature built into Firefox turns off every time I restart the app. Is anyone else seeing this? [little bit more inside]

It's almost giving MS too much credit, so I'm not really thinking this was done on purpose, but it almost seems like too neat of a coincidence to just be chance. I wouldn't be surprised if they big-footed some kind of registry entry or something by making believe Firefox doesn't exist.

I'm certain of the timing...I use Firefox all day, every day, and I haven't seen pop-ups for months now. I installed SP2 two days ago, and all of a sudden, every time I start Firefox, the "Block Pop-ups" check box is off. This is really annoying, and I'm trying to figure out whether it's a weird bug with my specific system, or more widespread.
posted by LairBob to Computers & Internet (6 answers total)
Have you looked at the prefs.js and user.js files in your profile to determine if the setting is being changed? I can't imagine anything that an XP service pack would do that ought to make changes to these files, but that's where the setting is stored.
posted by majick at 4:19 PM on August 12, 2004

Response by poster: Good point--if I write it into the user.js, it should override the prefs.js, am I right? I'll look into that.

I couldn't imagine what a service pack could do to make that happen, either--the timing was just too strange, though.
posted by LairBob at 4:25 PM on August 12, 2004

Haven't seen anything like that myself, no.
posted by gramcracker at 5:47 PM on August 12, 2004

Do you happen to have TabBrowser Extensions installed on your copy of Firefox? I found that it seems to step on Firefox's pop-up settings for some reason.
posted by kindall at 8:20 PM on August 12, 2004

No effect here either. Pop up blocking remains, blocked. I wonder about the outrage of marketing departments everywhere.

Unfortunately sp2 didn't remove the hijack that is attached to my IE. I must use IE on occassion to test the web pages I build for clients.
posted by juiceCake at 8:47 AM on August 13, 2004


Try moving your profile directory so Firefox is forced to start with a clean profile. I guarantee that the problem is either with your profile or with that particular Firefox build.
posted by azazello at 1:30 PM on August 13, 2004

« Older Automate file saves with CDex   |   Emotionally-involving videogames? Newer »
This thread is closed to new comments.