Korean Keyboard
August 2, 2004 6:25 PM   Subscribe

I am designing a keyboard which needs to feature korean characters (hangul) on the keys. I installed a hangul font call batang but I still get english characters. How do I get hangul characters to appear on screen? more inside.

I am using Adobe Illustrator to create the artwork. When I choose the batang font, and type a character, it appears in english, not the hangul character I expect. Do I have to remap the keyboard in windows or something?
posted by alball to Computers & Internet (3 answers total)
You can start here, and then googling for 'windows,' 'korean,' and 'IME' should help you go further.
posted by hashashin at 6:36 PM on August 2, 2004

You appear to be mixing up the concepts of fonts and input methods (IMEs).

A font is a mapping between logical characters (e.g., "Latin capital A") to their vector visual representations. It may contain many scripts (Latin, Greek, Cyrillic, CJK) and therefore you can type in many languages in such a font. Not too many fonts contain the CJK scripts; Batang is one of them. Most other languages with simpler scripts are available by default in all modern fonts.

An input method is a way for the operating system (Windows in your case) to understand input in a certain language (usually from the keyboard). Except for the fact that you need a font which has the Korean script to display Korean characters, IMEs are totally separate from fonts. A font with the proper character set is not sufficient to enter text in any given language.

In Windows, the IMEs/keyboard layouts in use are shown in the Regional and Language Options control panel, under the language tab->Details. In order to use a Korean IME, you need to first add it to the "Installed Services" list, then enable the Language toolbar (it will probably pop up by itself) and select the input language for the current window (e.g., switch to the Illustrator window, select Korean, and type). You may also need to use extra keys to manipulate the IME; for instance the Japanese IME's input mode has to be activated via Alt+~ before you can start typing in Japanese. Use the Korean IME's help for this.
posted by azazello at 10:56 PM on August 2, 2004

Response by poster: Thanks for the help! I figured it out and got the project done. Thanks Azazello and Hashashin.
posted by alball at 10:48 AM on August 3, 2004

« Older How kosher is Younge Khachab Rinpoche?   |   Nero spitting out blank CDRs Newer »
This thread is closed to new comments.