How to make Twitterberry work on my Blackberry Curve?
May 9, 2008 11:28 AM   Subscribe

Twitterberry on my blackberry curve gives a network request failed error message when trying to update or access the public timeline. What's going on? Any help would be greatly appreciated.

I realise it's a firewall problem. All my permisisons are set to allow in the options menu for twitterberry. I have no problems accessing the internet with opera which is also installed.

Any ideas?
posted by quaisi to Technology (12 answers total)
 
I can try to help. My BB is a bit older than yours. Before we get into it though, when you first ran TwitterBerry -- the VERY FIRST TIME -- did you get a prompt to allow connections for the application? And did you allow those connections?

I cannot explain how to get to this next area other than tell you what I see on my BB. From the main screen, bring up Options, then Advanced Options, then Applications. Scroll down to TwitterBerry and click the ball or being up the sub-menu. You should get a menu with an option, "Edit Permissions." Click that option.

On the next screen, click the ball or bring up the menu. On my screen, I have the following menu items:

Help
Collapse
Change Options
Save
Set as Defaults
Apply Defaults
Edit Defaults
Reset Firewall Prompts

Try the Reset Firewall Prompts option. Click the ball or Enter to access it.

Go back into TwitterBerry and try to send an update. You should get a screen that says something like this:

The applcation TwitterBerry has requested a http connection to Twitter.com.

Put checks into BOTH boxes. (You could just choose the top. I am just telling you what I did.) Scroll down and choose Allow this Connection.

That should do it. Post your results.

m
posted by tcv at 7:21 PM on May 9, 2008


Thanks for the answer. However resetting the firewall prompts does nothing. I still get the network request failed mesage.

I don't remember what happened the very first time I used it.

I deleted the program and reinstalled it in the hope that I would get the prompt to allow connections but I didn't. The settings were still all saved even though I deleted it - password etc.
posted by quaisi at 5:13 AM on May 10, 2008


Ah, shoot. I hoped that was it. You might have to contact the developer.

Can you post your Permissions settings? Expand all the options for the Permissions and copy them here.
posted by tcv at 7:46 AM on May 10, 2008


I can't copy the settings here but I can tell you they are all set to allow. I just noticed there are 2 types of allow in there - one which is in bold type and another not bold. All the settings are at the moment not bold but set to allow.

I noticed I can't access the built in browser when I'm running opera. I'm wondering if any other programmes are interfering with twitterberry connecting to the internet- I have google maps, google mail, the mobipocket reader and opera installed. I have tried to close these all down, take out the battery and restart to no avail.
posted by quaisi at 9:46 AM on May 10, 2008


Can you write the exact error message you get? I am not sure from what you wrote about whether "network request failed" is the full error message or not.
posted by tcv at 7:11 PM on May 10, 2008


BTW, what's your Twitter name? I'm tcv
posted by tcv at 7:16 PM on May 10, 2008


Whoops. I found you. ;-)
posted by tcv at 7:19 PM on May 10, 2008


Thanks I'm following you too now.

Network request failed is the error message which pops up in a box when I try to update.

Do you know how to completely uninstall an application so I could try it again from scratch? If I delete the aplication as normal and reinstall, the settings are still saved in.

I sent a support note to the developer too. It's strange that I seem to be the only one on Google suffering this problem.
posted by quaisi at 3:25 AM on May 11, 2008


Actually, I found some dude in China who had the same problem. Unfortunately, I don't know of any other way to delete applications. As luck would have it, I bought a Curve this weekend. Unfortunately, the program works fine for me...
posted by tcv at 12:32 PM on May 12, 2008


I got this note from the developer:

Do you have BlackBerry Internet Service? Go to Options -> Advanced Options -> Service Book. Look for "IPPP for BIBS [IPPP]". It should be listed. If not, TwitterBerry will look for TCP connections, and you'll need to set your APN properly. (There are plenty of resources on the Internet for this)
posted by tcv at 7:49 AM on May 13, 2008


Hi. I have IPPP for 5 click but not for BIBS. I'm on t-mobile in the uk . I know my APN settings are fine as I had to edit them to get Opera to work.

I installed tintytwitter which works but only when after turning the phone on I use it before using Opera . If it's afterwards, it won't update. This is the same with the default browser - it will only work if it is used before Opera.
posted by quaisi at 11:04 AM on May 13, 2008


I have replied to the developer. I'll let you know.
posted by tcv at 8:08 AM on May 14, 2008


« Older Help for parents of gifted kid   |   A slightly larger, small used car for $15k or less Newer »
This thread is closed to new comments.