Why is my WordPress 404.php not working?
May 6, 2008 8:51 AM   Subscribe

Why is my WordPress 404.php not working? If I try to visit a non-existent page, instead of getting the 404 page it gives me a page with all my static pages concatenated.

The actual blog is at http://www.theatresmash.com.

If you try going to http://www.theatresmash.com/notarealpage, you'll see the incorrect result.

I have a 404.php file defined in my theme. Deleting the 404.php file makes no difference (i.e. no default server 404 error message).

I'm running WordPress 2.51, hosted on DreamHost. I have another blog on the same host with the same WP version, and its 404 page works just fine.
posted by krunk to Computers & Internet (5 answers total) 1 user marked this as a favorite
 
Do the .htaccess files in each blog look the same?
posted by mkb at 9:50 AM on May 6, 2008


Best answer: Check your Front Page Display (under Settings, Reading). It looks like you're not using Posts, only Pages - I had the same problem on a Wordpress.com blog and the way I "resolved" it was by making up a fake Post and setting that as the Posts page. I have no idea why that worked or what causes the problem though.
posted by estherbester at 10:05 AM on May 6, 2008


Oops - to clarify, this is if you've selected "Static" pages for Front Page Displays.
posted by estherbester at 10:06 AM on May 6, 2008


Response by poster: estherbester, you are a savior! many thanks.
posted by krunk at 10:12 AM on May 6, 2008


It looks like this has been solved, but you probably could "fix" this by setting up a missing.html page in your root. That is how Dreamhost hands 404s.
posted by terrapin at 1:18 PM on May 6, 2008


« Older A comfortable & storable reading chair?   |   Muy delicioso Newer »
This thread is closed to new comments.