Why is my computer taking me where I don't want to go?
May 2, 2008 6:44 AM   Subscribe

Why does my Windows XP machine keep trying to route my computer names to capiqcorp.net

On my work PC, I am running Windows XP through Nortel VPN. Even when logged into VPN, my machine keeps trying to route me to another address. For example, if I type in "ping machinename" in the command line, it then routes to "ping machinename.capiqcorp.net", and when entered into the web browser, routes me to one of those catch-all spam link pages.

I have temporarily worked around this by using my corporate DNS server's IP addresses into the network adapter, which then requires me to connect to VPN using an IP address instead of the server name, and also prevents me from accessing anything on the Internet when not logged into VPN.

I have run several different spyware packages, and have been unable to find anything that might be causing this problem. I also checks my hosts file in the winnt folder, but nothing looks to be amiss there.

A did suspect it might be ISP issue, but I also plugged my personal mac into my home office router, and I have no such issues.
posted by benjh to Computers & Internet (6 answers total)
Run a search for capiqcorp.net in your registry.
posted by PowerCat at 7:12 AM on May 2, 2008

Oh lordy, I know the fix for this, but it's loooong and I'll probably screw it up.

Control Panel | Networking | (Whatever connection you're using) | TCP/IP | Properties | Advanced | DNS tab.

Okay, so at the bottom of this will be a big list of DNS suffixes that the machine will be trying. Highlight capiqcorp and remove it.

Reboot (I know, I know), reconnect, and see if it comes back. It shouldn't, but if it does you'll have to go back and turn off the ability for that connection to use other suffixes.
posted by unixrat at 7:40 AM on May 2, 2008

...and the above doesn't account for viruses, malware, trojans, or what ever you may have on your system. If it keeps coming back, you may have larger problems.
posted by unixrat at 7:43 AM on May 2, 2008

You can also just delete your network adapter from the hardware manager and reboot and have windows reinstall it. That usually knocks out any goofy configs, but if this is a spyware infection you need to address it on a deeper level with anti-malware software. Windows Defender is still free.
posted by damn dirty ape at 7:58 AM on May 2, 2008

Possible that your corporate network is using already reserved IP addresses, so your DNS server (rightly) goes to the correct address rather then your internal one.

Open up a command prompt (start > run > cmd > okay) on a corporate computer

type ipconfig and hit enter, if it's not in the range of: to to to

Then your corporate network is incorrectly set up (unless your company has it's own reserved public ip range, which I doubt, since you're resolving to something else). Get your system admin to change your the corporate network ranges to the ranges that were created for that very reason. It's just sloppy not to use them.

Talking from experience here, had to change a good sized network because of the previous network admin's ranges. Very frustrating, networking 101.
posted by Static Vagabond at 10:13 AM on May 2, 2008

You could try talking to your tech-people at work. As a higher-up support guy, I'd love to have a conversation with someone about this. What I'm trying to say is, don't assume that they won't understand or have a clue.
posted by pete0r at 11:21 AM on May 2, 2008

« Older "Britpop" sound - female singers?   |   Mesh-back ergonomic office chairs in Canada on a... Newer »
This thread is closed to new comments.