My XP takes too long to shut down & boot up. What could be causing it?
February 21, 2008 2:29 PM   Subscribe

My XP takes too long to shut down & boot up. What could be causing it?

In the past 2-3 months I've noticed that whenever I shutdown or reboot, the computer needs at least 5 minutes to do so. It keeps getting stuck on 'saving your settings' window for at least 5 minutes. This wasn't an issue before so I am wondering what I can do to fix it.

My Specs:

OS: WinXP Professional 5.1 SP2 (Build #2600)
CPU: Intel Pentium D , 2.99 GHz

Thanks!
posted by cheero to Computers & Internet (14 answers total) 7 users marked this as a favorite
 
Run 'msconfig' and try to limit the number of programs that run on startup. More often than not your computer will run much smoother when you get rid of some programs that shouldn't be wasting CPU power.

It also could be spyware or something else which should also be checked but start with the running programs.
posted by JJ86 at 2:38 PM on February 21, 2008


I figure we can safely assume that you already defragged, emptied the various caches and ran virus and spyware scans, right?

Have you changed anything about the way your computer's set up (software or hardware installations, for example) in the past few months?
posted by box at 2:39 PM on February 21, 2008


Response by poster: I have not changed anything, I've ran virus scans a few times. No threats thankfully.

And yes, I have defragged.
posted by cheero at 2:41 PM on February 21, 2008


Slow shutdowns usually mean programs that misbehave. My experience in the past has been that nearly always a slow shutdown was because of some weird USB-based background job.

One time I figured out exactly what it was. My DVD player program had installed an auto-run background job intended to access a USB IR receiver for its remote control. I didn't have that device attached, but the problem was that the job was stuck inside of the driver, in a timeout-retry loop, and the shutdown "die right now, you bastard" signal won't kill a job which is in system state. Because of that, shutdown never completed automatically. I always had to manually hold the power button to make the machine stop running.

Once I found that job and made it not auto-start, my shutdowns worked fine.
posted by Class Goat at 3:05 PM on February 21, 2008


If it's a home machine I would assume the answer to this question is no, but is the machine a member of an NT doman?
posted by mragreeable at 3:10 PM on February 21, 2008


If you have external hard drives, try turning them off. Also, if that fixes it - back up that hard drive because it's getting ready to fail.
posted by bigmusic at 3:20 PM on February 21, 2008


Did you once have the machine connected to a LAN, but no more? A while ago my XP machine started exhibiting the same symptoms as yours and I eventually discovered that it was looking for a network I once had it connected to for a short period of time. Once I deleted the LAN settings the machine acted fine again.
posted by Effigy2000 at 3:38 PM on February 21, 2008


UPH Clean.
posted by everichon at 4:06 PM on February 21, 2008


Also, make sure that at some point when windows disk cleanup was trying to be "helpful" it didn't compress your c drive to save space.
posted by JonnyRotten at 5:37 PM on February 21, 2008


AutoRuns
posted by hortense at 5:55 PM on February 21, 2008


I had long (> 10 minute) boots of XP. This fixed my problem, by changing \SYSTEM\CurrentControlSet\Services\Spooler:
http://support.microsoft.com/kb/137399

Also, check the event manager after a boot. If it's a service failing/timing out, it should pretty clear which one it is.
posted by turbodog at 7:03 PM on February 21, 2008


Seconding checking the event viewer.

Start > Settings > Control Panel > Administrative Tools > Event Viewer. Go to System and look to see if there are any errors that occur around the time of start up or shut down.
posted by jasper411 at 7:39 PM on February 21, 2008


Having thousands of files in your Recycle Bin can do this.
posted by flabdablet at 2:28 AM on February 22, 2008


The other thing I've seen do this is an out-of-date Norton Antivirus. If you have Norton, uninstall it and get AVG instead.
posted by flabdablet at 2:49 AM on February 22, 2008


« Older Good news: I've got US$100,000! Bad news: for one...   |   dentista necesitado Newer »
This thread is closed to new comments.