Firefox font foo
July 2, 2004 2:09 PM   Subscribe

I love Firefox. But I've had a problem since firebird and it's still present in .9.1. I like the free Bitstream Vera font family when I'm on the laptop because the fonts smooth nicely. However, at some point they become aliased. Screen shots inside. How do I prevent this from happening?

Good:
bitstream vera sans anti-aliased, firefox

Bad:
bitstream vera sans a few minutes later in firefox

This effects all the context menus and the drop down menues as well. It's really annoying.
posted by Grod to Computers & Internet (11 answers total)
 
Is your theme somehow overriding the fonts? Have you tried using other themes?
posted by falconred at 3:43 PM on July 2, 2004


I'm overriding the fonts with userchrome.css, because I like Vera.
posted by Grod at 3:52 PM on July 2, 2004


Maybe it's because excessively small antialiased fonts would be an unreadable blur on many displays? Just a guess.
posted by Eamon at 7:11 PM on July 2, 2004


I can't see a damn hair of difference between the two and I've good eyes for this sort of thing. Therre are things that look aliased in the second, the slashes particularly, but there aren't any in the first to compare to. What am I looking for?

FWIW, Firefox's font handling is shite. IF you choose standard-ish ones it works fine, but unusual, type 1, or large families make it wet itself. I filed a bug, but someone said "oh, this is like " and then it was forgotten.
posted by bonaldi at 7:16 PM on July 2, 2004


er, must not use angle bracket
"oh this is like [completely unrelated bug]"
posted by bonaldi at 8:06 PM on July 2, 2004


bonaldi: check out the 'o' and 'W' in the titlebar. I can see why Grod would complain.

I'm pretty happy with the fonts in Firefox, but I'm also sticking to TrueType fonts.
posted by Eamon at 8:58 PM on July 2, 2004


With Windows, antialiasing of fonts is taken care of by the operating system's font renderer. While an application may have some level of control over that, nearly all applications that aren't used for typographical purposes leave well enough alone. So what you're staring at is most likely some kind of Windows bug. It's known for having several.

For what it's worth, I've never seen it happen on other platforms.
posted by majick at 10:09 PM on July 2, 2004


Hm OK. Well, Bitstream Vera fonts are true type. They also come first in a lot of stylesheets, the w3c validator uses it, for example. The family was made for the Gnome desktop but works fine in windows. It's a really legible font on an LCD. Anyway, thanks for the info. The problem comes and goes. but it is annoying.
posted by Grod at 11:03 PM on July 2, 2004


Did you turn on ClearType?
posted by signal at 11:09 PM on July 2, 2004


Display properties/Appearance/Effects/Use the following method..../ClearType
posted by signal at 11:13 PM on July 2, 2004


There is some good info here http://www.richleader.com/cleartype.htm.

After quickly reading the article, the two main things I came away with are that a) turning on ClearType will anti-alias even tiny fonts, and b) if you don't use ClearType, screen resolution determines the minimum font size that will get anti-aliased.

So, make sure your screen resolution is as high as you are comfortable with.

Once you have ClearType active, you can use this Microsoft utility to tune how it looks on your particular screen. This can make quite a difference.
posted by SNACKeR at 7:53 AM on July 3, 2004


« Older When a plane crashes, what do the airlines put on...   |   Tobacco Pouches Newer »
This thread is closed to new comments.