Firefox and Unicode
June 27, 2004 6:57 PM   Subscribe

Why does Firefox insist on loading pages with Unicode character coding, when I prefer Western character coding? The former turns high-ASCII characters like § into question marks; the latter displays these normally. Does this happen to anyone else, and can I fix it?
posted by PrinceValium to Computers & Internet (14 answers total)
 
Which version? I'm using firefox and saw your § just fine.
posted by 4easypayments at 7:28 PM on June 27, 2004


Worked on firefox here, too. Check your preferences, PrinceValium. There should be an option to change character encoding under General:Language. At least, there is in OS X.
posted by jbrjake at 7:37 PM on June 27, 2004


0.8/XP. I don't see a language option in the preferences.
posted by PrinceValium at 7:55 PM on June 27, 2004


Time to upgrade to 0.9. Trust me, it's worth it.
posted by TungstenChef at 8:19 PM on June 27, 2004


Ironic. I just posted a similar question (assuming I'm understanding you) to another forum this morning, but didn't get any helpful advice:

"I haven't been using Firefox 0.9 long enough to notice too many issues, but do any of you notice weird character substitutions? For example, I was reading this page (cred points: +1) and every character that was supposed to be a quotation mark (“) is converted instead to a question mark (?). Is there any way to change that? I just checked it in Internet Explorer and it displayed fine."
posted by dhoyt at 8:28 PM on June 27, 2004


I think I found the culprit. The default Movable Type template includes this meta tag:

<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

I'm going to cut this from my own template, but it would be nice if I could override the defaults.
posted by PrinceValium at 8:43 PM on June 27, 2004


Don't know what's going on - I'm Firefox 0.9 on XP and I see the special characters fine.

I just checked and my default character set is indeed set to Western: Tools > Options > General > Languges
posted by falconred at 8:44 PM on June 27, 2004


The former turns high-ASCII characters like § into question marks

There's no such thing as "high-ASCII." If it has a code above 127, it's not ASCII.

People should be using Unicode anyway; it makes redundant most encodings except perhaps some of the Asian ones. If you won't use Unicode, use named HTML entities for things like §.
posted by kindall at 10:28 PM on June 27, 2004


So can someone summarize what's happening on pages like Gawker? My default character encoding is set to Western, so ... it's their fault and there's nothing I can do because Firefox's behavior is "correct"?

(sorry if I sound grumpy)
posted by lbergstr at 11:29 PM on June 27, 2004


lbergstr; I get ?'s all over that page too. My browser is Mozilla 1.7, and character set is western iso 8859-1 (on Win98):
You 're a lame and a ?pussy, Doug. And you should know better than to try and wage war on me. ?I'm better, stronger and smarter than you, you little Nancy. If I wanted to take your girl out, I would. You have nothing I can't take?away from?you, you non-man. ?Doug, you little tiny fairy, you arrested boy,
What's weird is that if removed, there seems to be no natural replacement for those ?'s.
posted by dash_slot- at 4:01 AM on June 28, 2004


People should be using Unicode anyway; it makes redundant most encodings except perhaps some of the Asian ones

I use Unicode in my oft-neglected Chinese blog exactly because it makes the different Asian encodings redundant. Using Unicode, it's possible to write traditional Chinese and simplified Chinese (and whatever other language) all in the same post.
posted by alidarbac at 4:17 AM on June 28, 2004


The Gawker page is not a good page to judge by, as there are artifacts in the quoted letter left over from a copy-and-paste job from email.

The Chunklet page looks fine in Firefox 0.9 with Western encoding on Windows 2000 Pro.
posted by Mo Nickels at 6:23 AM on June 28, 2004


I'm using Firefox on Win 2k with Unicode (UTF-8) encoding and the § in the question shows up fine. Weird.
posted by smackfu at 7:19 AM on June 28, 2004


I don't think Firefox comes with auto-detect encoding on by default. Try View>Character Encoding>Auto-Detect>Universal
posted by Hackworth at 11:44 AM on June 28, 2004


« Older PC Freeware to access Mac CDs?   |   How to fix weedwacker? Newer »
This thread is closed to new comments.