Connecting a Mac Powerbook to a Windows 98 computer
June 25, 2004 1:13 PM   Subscribe

Connecting a Mac Powerbook (Panther) to a Windows 98 box. Help, please. -->

First off, sorry for like my third question in about a week. :(

I have done google searches and searches on macmentor.org and other places but I can't find a step-by-step guide to connecting my Powerbook to my Win98 box via ethernet. I also searched at Apple and thought I found something and then when I followed the instructions, they didn't work (the Apple site mentions clicking things that simply aren't there--then I noticed it was 10.2 so maybe that's the diff).

I simply want to get my mp3 files off of my windows 98 box so I can then throw the thing in the trash. I've had the PB for close to a year and haven't been able to figure this out yet.

I have: one powerbook, one win 98 box with 50 gb of mp3s on it, two ethernet cables (I believe one is "normal" and one is "crossover" though I don't know what the hell that means).

Can anyone explain this to me or provide a link that tells me what I have to do on each of the computers so I can listen to my wonderful mp3s?
posted by dobbs to Computers & Internet (43 answers total)
 
Oh, and anyone who's sweet enough to assist, please assume I have the IQ of a peanut butter sandwich when it comes to this stuff. It can only help to state the obvious. Thanks!
posted by dobbs at 1:27 PM on June 25, 2004


A crossover cable will allow you to connect two computers without using a hub/switch/router/etc.

The ordering of the wires within the cable is slightly different.

This should help, too, though I'm not sure it's the easiest way.
posted by Coffeemate at 1:39 PM on June 25, 2004


Connect them via the crossover cable.

Then open up your Mac's "System Preferences" (it's under the Apple).

Click the "Sharing" pref.

Check the box next to "Windows Sharing." This will start up file sharing services that a Windows computer can connect to.

Look near the top of the Sharing panel for an "address" where your Win computer can connect to your Mac.

Then go over to your PC, open up a Windows Explorer window, and enter that on the address line. You should then be able to browse your Mac's disk from the Win98 machine.

Several things can go wrong with this, of course. If you have problems, lemme know.
posted by scarabic at 1:58 PM on June 25, 2004


scarabic, I followed your instructions and windows says: "Windows cannot find [the ip address i typed]'

On the apple it says simply \\seriesofnums\dobbs

I punched that is exactly. Then, I tried changing the \s to /s, no go. Then I tried putting an http: in front of it. Still no go.

Also, just fyi, I am wanting to access my windows files from my mac, not the other way around (not sure if that makes a diff).

Coffeemate, that semed a bit complex to me. I'll try it if no one else is able to come up with a simpler solution.

Thanks!
posted by dobbs at 2:11 PM on June 25, 2004


Also--and this is incredibly geeky, but as long as it came up--you don't need crossover cables with recent Powerbooks. They can detect whether there's a hub or another computer at the other end of the line, and reconfigure themselves to suit. The crossover cable won't screw you up, AFAIK, it's just not needed.
posted by adamrice at 2:19 PM on June 25, 2004


I'm not an expert, but this is what I do, and it works for me. Some of it's super-obvious, but peanut butter sandwiches usually don't have a lot of experience.

Hitting Command-K in the mac's finder brings up the Connect to Server dialog.

Hit browse to see if it's easy.

If not, find the IP address of your windows machine (by going to the windows menu > run > cmd > ping [name of machine]).

Enter this as your server address in the dialog box:

smb://[ip address]

If that doesn't work, try:

cifs://[ip address]

If that doesn't work, I'm afraid I can't help you.
posted by o2b at 2:30 PM on June 25, 2004


Thanks, adam. I tried both cables and got the same result (I don't know how to tell the diff between the two by looking at them. One's blue and one's grey, but that's it.)

o2b, I tried that and it tells me:

The finder could not complete the operation because some data in [ip address] could not be read or written. [Error code -36]
posted by dobbs at 2:41 PM on June 25, 2004


o2b, did you mean for me to leave the square brackets there? If I do, I get the error above. If I take them out, it just keeps searching--not finding or giving me an error.
posted by dobbs at 2:55 PM on June 25, 2004


also, I'm sure this will reveal my ignorance more than anything else: my internet connection (pb) is wireless. Do I have to tell the computer that I'm not supposed to be searching for this computer wirelessly? Like, do I have to tell it to go to the ethernet cable?
posted by dobbs at 2:57 PM on June 25, 2004


Okay, so now I tried the other cable again and tried o2b's suggestion and the smb and cifs thing doesn't work but when I click browse, I now see other stuff in the finder window: folders that say LOCAL, @ROGERS, and WORKGROUP. However, each of them says "No Items" under it.

My Windows machine indeed used to be connected to Rogers as an ISP.
posted by dobbs at 3:19 PM on June 25, 2004


Quite possibly not helpful, but when you click on the @ROGERS and WORKGROUP folders, what happens if you wait a couple seconds before clicking on another folder? I have a Powerbook too, and mine takes a couple seconds to look up all the computers on the network before it displays them.

(Of course, I failed at getting my Powerbook to talk to a WinME computer this week, so don't listen to me — although that was because the PC is totally borked.)
posted by katieinshoes at 3:42 PM on June 25, 2004


Dobbs, you're getting close! Make sure you have the Mac's firewall turned off for this just to make sure ports aren't getting blocked.

First, does your wireless access point have a few ethernet ports so you can plug both the powerbook and the windows box into it [and there's still the ethernet connector that goes to your cable modem?]. If you do, plug both computers into the accesspoint and reboot the windows box to get an IP address. Once you do that scarabic's instructions will work.

If you don't have the access point dealy, try this based on where you were when you saw the local group in the network neighborhood....

From the windows machine, right click on the "network neighborhood" [or "network places" or whatever they called it in 98] and select "map network drive" type in \\local\ and whatever your powerbook's name is [I called mine powerbook so for me it is \\local\powerbook].

In the dialog box it you can select a drive letter, use the default which should be one letter past your hard drives/cdroms/whatever.

Windows should then ask for your username and password [Login using your username/pw from your powerbook where you want to put the files]. Then you should be able to see your home folder in windows explorer and be able to navigate to where you want to put the mp3s. Then you can copy them from c:\mp3s [or wherever they are] to e [or whatever drive letter you gave the powerbook] and you're set.

If that doesn't work, you could try enabling FTP on you powerbook [in the sharing] section. Then you should be able to do ftp://ip.address.of.powerbook/ and it should ask for a username/password. Then navigate to where you want to put the MP3s on the powerbook and then copy drag mp3 folder(s) on you windows machine over to the window with the ftp session. If that doesn't work I dunno. I'm fuzzy on more windows troubleshooting except maybe trying macwindows.com but it seems to be more toward big networks.
posted by birdherder at 3:47 PM on June 25, 2004


katieinshoes, yeah I clicked in all the folders and then left those windows open and they're all empty.

When I go into Network Neighbourhood on my windows machine, I indeed see that the first thing under "entire network" is @Rogers.

Do I have to do something on the PC to tell it to share the files, maybe?

on preview: birdherder: I have a an IP address for both computers. I couldn't get scarabic's suggestion to work.

I tried mapping the drive the way you suggest and it says the computer or sharename could not be found. (My PB is called dobbs).

When I go into system prefs (on pb) it tells me "other computers on your local subnet can access your computer at local.dobbs". I tried punching local.dobbs into the mapping thing and that didn't work. Either did //local.dobbs.

I am loathe to try the FTP thing because right now the PC isn't internet ready (I'd have to call my ISP and get them to do something to switch from mac to pc, which I did when getting the mac in the first place). I suppose I will eventually have to resort to that though as nothing else seems to be working.

I can't believe how hard this is. Nor that I can see the windows machine (@ROGERS) but that it's telling me it's empty. Wtf?
posted by dobbs at 4:02 PM on June 25, 2004


Oh, and birdherder... not sure I have a firewall on my mac, actually. Does it have a built in one? If so, how do I disable it?
posted by dobbs at 4:11 PM on June 25, 2004


Never mind that last comment. I found it. It's disabled.
posted by dobbs at 4:12 PM on June 25, 2004


Just an observation:

If tcp/ip is configured as DHCP, as soon as you switch the ethernet cable with the crossover cable, you lose the ip address. So, for example, if you try to connect to the PC by typing in smb://192.168.0.115/c$, you'll never see it. Instead, you have to find out what the self-assigned ip address is. Most likely it will be of the 169.xxx.xxx.xxx variety. You can always check that by typing winipcfg in the command prompt. Once winipcfg is open, select the appropriate adapter and you should see what the self assigned ip address is. Now, from your powerbook, type in smb://self.assigned.ip.address/. Hopefully that will work.
posted by inviolable at 4:27 PM on June 25, 2004


Sorry, that's "If tcp/ip is configured as DHCP on your Win98 box..."
posted by inviolable at 4:29 PM on June 25, 2004


invioble, I don't understand most of you comment but my i.p. address on the pc (from winipcfg) is indeed of the 192.168.0.100 (but there is no slash and no variable after that).

That is the number I was punching into smb:// in the box.

Am I following your instructions or are you offering up something I'm missing?

Sorry, that's "If tcp/ip is configured as DHCP on your Win98 box..."

Not sure I know how to check that.
posted by dobbs at 4:33 PM on June 25, 2004


Okay, so, for a reason I don't understand, this time when I did the smb thing, it popped up a window and said "SMB to mount" and I chose "dobbs" from the drop down menu and then it went away and my finder came up.

But I still can't see any files in the rogers folder.
posted by dobbs at 4:39 PM on June 25, 2004


Do I have to tell the computer that I'm not supposed to be searching for this computer wirelessly? Like, do I have to tell it to go to the ethernet cable?

Yes, I've never made this work wirelessly. Try turning Airport off. And naturally, your PC has to be using ethernet as well.
posted by scarabic at 4:43 PM on June 25, 2004


If you were able to mount "dobbs", you're close! You may need to double check that sharing is turned on for the correct directory. Here's a nice set of instructions.

Using the above directions, share the folder that holds your MP3s. Now, let's say the folder that holds your mp3s is named MP3. You would now do the following from your powerbook:

Click on the Finder icon on your dock.
Go to Go and select connect to server.
Type in smb://192.168.0.100 and hit return.
You should now see the share "MP3". If so select it and begin your copying.

If not:
connect to server again, but this time type:
smb://192.168.0.100/MP3 (note: use the same capitalization)

Let us know if it works.
posted by inviolable at 4:57 PM on June 25, 2004


Okay, so, for a reason I don't understand, this time when I did the smb thing, it popped up a window and said "SMB to mount" and I chose "dobbs" from the drop down menu and then it went away and my finder came up.

Okay, I no understand why it worked this time. It's because of that peanut butter IQ I mentioned. This time when I punched in the SMB thingy, I punched in the wrong number--I punched in the IP of the mac, which of course it found as I was looking for it from the mac.

When I punch in the PC number, it can't find it. However, when I hit browse I still see the empty folder labeled @ROGERS. (to me, this is the most frustrating thing. Why can it see the computer but nothing on it?)

inviolable, I followed the instructions on that page and they worked perfectly but obviously though my fuckup gave the impression I was having progress, in fact I don't think that's the case.

Neither computer seems to want to acknowledge the others' existence.
posted by dobbs at 5:16 PM on June 25, 2004


dobbs: the SMB to mount window was on your powerbook so telling it to mount dobbs is telling it to mount itself [which it already is, so it just goes back to the finder]. You can type in the name of your windows 98 machine [right click the 'my computer' on the windows desktop and select properties, the second tab [computer name?] should have your computer name [in xp it is called full computer name, in 98 it might have been something else, either way it is a name without spaces and is kind of short]. Take that name to the powerbook and do the smb thing with that name. If your PC is named dobbs, change it to something else since you can't have two identical names on the same net.

Now if that works, you're connected and can let the copying begin if not try this...

I was going to say that inviolable. I think that might be the problem. If the PC is directly connected to the Mac, then it probably isn't getting an IP directly from the Mac. So that should work.

That 192.168.x.x address was assigned by your router/switch/access point. If that device isn't connected, then it won't work. If you can plug that device, the windows box and the powerbook together, you can.

If it is just the PB and the Windows box then you'll need to release that IP address [i think in winipcfg there's a release DHCP lease button] You'll have to configure the IP address manually of have a self-assigned one, but that is beyond my level.
posted by birdherder at 5:27 PM on June 25, 2004


Take that name to the powerbook and do the smb thing with that name.

yeah, I tried that one a while ago. the PB can't find it, same as when I punch in the IP.

I don't understand the rest of your message.

The PC is not actually connected to the internet. Is that something that's a problem?

Next question: I should just pay someone to come in here and do this for me as it's just ruining my week and fruatrating the hell out of me. How much would I expect to pay and, in these situations, if the person can't do it, do I still have to pay him or her?
posted by dobbs at 5:36 PM on June 25, 2004


Oh and one other question. What If i buy a firewire card for my PC. Would I then be able to plug my Mac formatted Lacie external into the PC and then dump the mp3s to it or is it not gonna be able to see the Apple drive?

Am I missing any other solution? (I have an external firewire enclosure which I've stuck the PC drive into (it's IDE) but, though it appears on the mac desktop, the apple tells me i have to format it before I can use it. Something to do with NTFS or some such thing, apparently.)
posted by dobbs at 5:42 PM on June 25, 2004


Okay, let's take this step by step. We'll go over what needs to be done on the PC side and then what needs to be done on the Mac side.

On the PC:
Using the instructions from above, set up file sharing for the directory you wish to share (e.g. the directory MP3).

Check your ip address by opening the command prompt and typing winipcfg. Select the correct adapter of your ethernet card and write down the ip address of your machine. Also note the subnet mask (this is new). It should be something like 255.255.255.0. Write down the subnet mask as well.

On the Mac:
Go to the blue Apple icon located at the top left corner of your screen and select System Preferences....

Click on the "Network" icon. Change the "Show" pull down menu to "Built In Ethernet".

Change the configuration from "Using DHCP" to "Manually".

Type in an IP address similar to the one you noted on the PC, changing only the last set of digits. If the PC showed "169.254.167.233" make the ip address of the Mac "169.254.167.200".

Type in the subnet mask EXACTLY like that of the PC.

Click the "Apply Now" button.

Close System Preferences.

From the finder, go to Go and select connect to server.

Type: smb://ipaddress.of.win98.machine and hit return.

If that doesn't work, type
smb://ipaddress.of.win98.machine/thenameoftheshare

Hope.
posted by inviolable at 5:44 PM on June 25, 2004


Invioble, thanks very much. I tried everything and the mac still couldn't find the PC. I get the same error I posted above after trying SMB the fist time. I appreciate you (and everyone) taking the time.

It's very frustrating to see that damn @Rogers thing sitting on my mac. Ugh. I think I'm just gonna get drunk and go see Mum. :)
posted by dobbs at 6:07 PM on June 25, 2004


Do you have access to a removable hard drive? Networking is doable, and you'll probably solve it after a lot of hair pulling, but at this point it would probably be way easier for you to plug a hard drive into the PC, copy over whatever files you want, plug the hard drive into the Mac, and copy over whatever files you want.
posted by willnot at 8:01 PM on June 25, 2004


Question: why is it that my Panther PowerBook can see the Windows PC on my network if the PowerBook is connected to the hub by Ethernet but not if it's connected to the network by Airport?
posted by skylar at 12:02 AM on June 26, 2004


willnot, I've tried that (sort of)--I took the hard drive out of the PC, stuck it in an enclosure, and plugged it into the Mac which says it can't read it and must format it. Apparently it has something to do with the file format. So now I have a useless $100 enclosure.

Another question: I also have a D-Link Wireless router which has multiple ethernet ports on the back. However, I only have two cables so that means I can't hook up both computers to it and still be online (I don't know if this matters).

The PC is not wireless, only the PB.

So, is this router thing of any use with my problem, here?

I just blindly plugged both computers into it and tried some of the above suggestions and they didn't work but maybe something has to be done differently.

Thanks again, all, for your help so far.
posted by dobbs at 8:57 AM on June 26, 2004


Hey dobbs, if you've got a router, go ahead and use that instead of connecting the two machines together. When you said that you have two cables, I'm assuming you meant the regular ethernet cable and the cross over cable, right? Connect the PC to the Router with the ethernet cable and connect the Powerbook to the router with the cross over cable.

Here is a tutorial on how to configure your Win98 machine for DHCP: http://support.earthlink.net/mu/1/psc/img/walkthroughs/hardware/home_network/windows/2928.psc.html

NOTE: when you look at the properties of your machine's TCP/IP connection using the above tutorial, and you see that your machine is set to manually configure TCP/IP, you should DEFINATELY writed down EVERYTHING you see in your TCP/IP settings before continuing with the tutorial. You'll eventually need those settings to reconnect your PC to the internet.

So, after connecting both machines to the router, and setting up your PC for DHCP, it's now time to set your Powerbook to use DHCP.

First, turn off the airport card. If you've got the airport status on your menubar, click on it and select "Turn Airport Off". Otherwise, to turn off the airport, go to your Applications folder, double click "Internet Connect" and click on the Airport tab. Now click the Turn Airport off button.

Second, go to the Blue Apple Icon at the top left of your screen and open System Preferences. Click on Network. Create a new location by clicking on the pulldown menu for location and selecting New Location. The window changes and you should now see a pulldown menu for "Show". Click on it and select "Network Port Configurations". Here you'll see a box with Airport, Internal modem and Built In Ethernet. Click and drag built in ethernet so that it is on top. With that done, click on the "Show" pulldown menu again and this time select Built-In Ethernet. In the TCP/IP section, you will see a drop down menu for "Configure IPv4". Select "Using DHCP". Click Apply now. If you are connected to your router, after a few seconds you will get an ip address of 192.168.something.something. Your Powerbook is now set up to use DHCP on your ethernet cable. Note the IP Address you get.

From your PC, try and ping your Powerbook. to do this, open the command prompt then type: ping the.ip.of.powerbook you should receive replies. If you get replies, sweet! if not, go back and repeat the steps above for both the PC and the mac. Let's assume you can ping.

Third, turn on file sharing on your Mac. From System Prefs, open up the sharing tab. Turn on Windows file sharing.

Fourth, from your PC, right click on Network Neighborhood and select "Map Network drive..."

enter in \\ip.address.of.powerbook\dobbs (or whatever the short name of your user account is). Click OK or connect or whatever.

Hope with one hand and pour a stiff drink with the other.
posted by inviolable at 10:15 AM on June 26, 2004


[on preview: invioble beat me to it. his instructions are clearer than mine]

good luck!
posted by birdherder at 10:35 AM on June 26, 2004


invioble and bh, thanks!

I am just about to try this except I have one question: I was once told that one cable was regular and one was crossover. However, I don't know which is which. I've been trying everything so far with both cables but it's very time intensive. Is there a way to look at the cables and tell? Or something I can run to check the cable once it's plugged in?

One is blue and says "der an utp cat .5 100mhz cm (ul) c (ul) cmg -ft4 e154 292 24awg 4pr - etl verified t1a/e1a 568-A" on it and the other is grey and says "type cm 24awg 75 degrees c (ul) e188630 csa ll01295 ft4 etl verified eia/tia-568a cat .5 utp evernew 3g8gg0015".

thanks.
posted by dobbs at 10:45 AM on June 26, 2004


Okay, so I did everything above and everything worked until the last step!

When I pinged the machine, a little black window opened and three or four sentences raced by two quickly to read. I did catch the phrase 32ms and the IP was there. Then the window automatically closes on its own so I can't read the rest of the sentence. I assume the pinging worked fine.

However, when I map the drive, it tells me it can't find the "computer or sharename".

I then swapped the cables and the same thing happened (the ping did the same thing and the drive wouldn't map).

I went into my sharing section on my pb and confirmed that I was typing in the right thing for the mapping. (it says, "other uses can see your computer at \\ipaddress\dobbs" which is exactly what I typed in.

Any ideas what could be happening?
posted by dobbs at 11:25 AM on June 26, 2004


two=too. doh! :)
posted by dobbs at 11:26 AM on June 26, 2004


worst comes to worst, you can email the mp3s to yourself, from the pc to the mac, or, set up an online storage space or something like that, upload everything you want from the pc, then download it all to the mac.
posted by amberglow at 11:31 AM on June 26, 2004


amberglow, yeah, except it's 50 GIGs which is a hell of a lot. Also, I only have one internet connection and I have to call my ISP each time I want to switch from apple to mac.
posted by dobbs at 11:46 AM on June 26, 2004


well, i'd stuffit or zip it, and send a segment a day...not an ideal solution, but eventually you'd have them all.....or....

maybe buying a cheap external drive is the best way? you'd always have the extra drive to use.
posted by amberglow at 12:12 PM on June 26, 2004


I think the command prompt window is closing so quickly is because your PC can see your Mac! Ping would stay open long enough to read several "request timed out" if it didn't see it. Win98 might not like attaching via tcp/ip. Win2K and XP can do it, but I do remember older versions of Windows had issues with using anything aside from windows networking.

try this.

We can try connecting the Mac to the PC.

First, on your PC:
make a note of the PC's IP address as outlined above.

when you see the MP3 folder on win98 windows explorer, right click on it to make sure the sharing is turned on.

Now on the Mac:
from Finder, select "Go" from the menu bar. In the address space type in smb://192.168.xxx.xxx where the x's are your win98's IP address. If it says it can't find it, try repeating it with the smb:://192.168.xxx.xxx/mp3foldername.

cross fingers.

What should happen next is you'll see an icon appear on the desktop [and in the navigation pane on the left of the finder window that is open]. the icon looks like a globe inside of a cube. Clicking on that should reveal either the MP3 folder, or the contents of the MP3 folder from the PC.

Drag the folder onto you Mac where you want to. Pour a drink in celebration. It will take a long time to move the 50GBs but you'll see progress on the little blue progress indicator.
posted by birdherder at 1:45 PM on June 26, 2004


And if that doesn't work I have one last thing to try:

On the Mac: In system preferences, click on sharing. Start the FTP service. Note the information in about the IP address other people can use to access your Mac.

Create a folder on the Mac where you want to put your MP3s. [i.e. in finder create a new folder called mp3 on your desktop [doesn't need to be permanent, just so you can get the files there]

Over on the Windows PC it should be pretty easy. In Internet explorer, type in FTP://192.168.xxx.xxx

You should get a popup asking for the username and password. Put in your mac's username and password you use where that mp3 folder is on the desktop.

Explore should then reveal several folders that look familiar to you since they are on your mac. Click on the Desktop folder and you should see that mp3 folder you made.

next, open windows exlorer [start->applications->windows explorer] and navigate to the folder(s) where your MP3 files are. Drag the filers/folders into the Internet Explorer window that is open to the mp3 folder on your Mac.

The "copying files..." popup on Win98 will show up with the animation of the letters flying from folder to folder. At this time you can have that drink.

Good luck. This can be done!
posted by birdherder at 2:04 PM on June 26, 2004


birdherder, thanks. I'm gonna disconnect everything and try your steps (can't be online the same time as I don't have the extra cable) so in advance, one question: my mp3s are not on my C drive on my PC, but my D drive. the folder mp3s is set to share as is the root d drive, but what do I put here: smb:://192.168.xxx.xxx/mp3foldername to specify the drive? (I can't move them to my C drive as it's tiny.)
posted by dobbs at 2:06 PM on June 26, 2004


being on the D: drive is not a problem as long as you're enabled sharing. You should be presented with all of the folders you are sharing. the hard drive letter doesn't matter to the powerbook.
posted by birdherder at 5:06 PM on June 26, 2004


I am back! With files transferred! The regular manner didn't work but your followup FTP one did. (Actually, for some reason IE couldn't see the computer so just on a whim I decided to try and find it with an actual FTP program and it worked.)

So, thanks very much to everyone for their suggestions, especially birdherder, invioble, and scarabic. It was a combination of the things you suggested that finally made it work.
posted by dobbs at 9:04 AM on June 27, 2004


« Older Pros and cons of oil or natural gas heating   |   Are there any good sites that provide subtitle... Newer »
This thread is closed to new comments.