Stop Gmail from downloading All Mail folder
January 27, 2008 1:22 PM   Subscribe

I've been using Mail.app with OS X Leopard as a front end to my Gmail account. And it works great, for the most part. Unfortunately it seems to download both my "Inbox" and also the "All Mail" folder from Gmail. This has the effect of increasing the amount of messages in Mail.app significantly, and I want it to stop.

Is there a way to unsubscribe to the "All Mail" folder with out effecting the "Inbox"? There is a grayed out subscribe/unsubscribe preference when performing a "Get Info" on the account in Mail.app, so it seems like there is at least a potential to do this. Or am I alone in being the only one bothered by this?

I just don't need to see the "All Mail" folder and it makes searches for emails through Spotlight come up twice. Annoying.
posted by qwip to Computers & Internet (10 answers total) 4 users marked this as a favorite
 
How are you accessing your gmail -- via POP, or via IMAP? I think setting up your account in Mail.app to check via IMAP might solve this problem.
posted by buriedpaul at 1:57 PM on January 27, 2008


I can confirm that this still happens with IMAP enabled. That's how my Gmail account is set up, and I get doubles in Spotlight.
posted by Kosh at 2:10 PM on January 27, 2008


This is definitely an IMAP problem. It gets worse if you use labels. Then the message shows up in the Inbox, All Mail, and the label's folder. Search is frustrating when you get three hits for each message. It drove us back to POP.
posted by droob at 2:40 PM on January 27, 2008


I'm pretty sure that the 'All Mail' folder is the Gmail archive. I'm not a Gmail wizard but I did notice that anything in that folder can be found by searching for it when using Gmail via a web browser. I usually drag the emails from my inbox (in mail.app) to the 'all mail' folder when I want to archive them and get them out of the way. They don't duplicate in that folder, and then they only show once in spotlight. You can do the same with the 'sent' folder. They won't be seperated anymore, but you can see who sent it anyway under the 'from' column.
posted by sero_venientibus_ossa at 3:06 PM on January 27, 2008


I had to switch back to POP with Gmail because of this. I hope they "fix" it sometime.
posted by themadjuggler at 3:32 PM on January 27, 2008


No idea if this will still work, but somehow you need to unsubscribe from the "folders" (labels, etc.) you don't want to see.
posted by cdmwebs at 4:29 PM on January 27, 2008


Ok, disregard. I just tried setting it up myself and it doesn't work. See here. Sorry.
posted by cdmwebs at 4:41 PM on January 27, 2008


Yeah, I am using IMAP, of course.

I don't want to move gmail mail out of my Inbox, as that's how I manage all of my email together. Very annoying. Also don't want to lose the features of IMAP, so a move back to POP is a no go. Not sure why Google thinks this approach is more desirable.

Thanks for the replies, everyone.
posted by qwip at 8:29 PM on January 27, 2008


Another "I have the same issues, couldn't find a solution, and am confounded by G's delay in addressing it" nod. Please let us know if you discover a non-destructive, IMAP workaround.
posted by prophetsearcher at 12:31 AM on January 28, 2008


An additional related problem is if you delete an email out of your inbox via IMAP, it only deletes the label, leaving the message intact in 'all mail'. That's fine if you plan on storing every mail ever received, but it you process a few hundred MB of email a day (long story) you'll run out of space real quick.
posted by ArkhanJG at 10:21 AM on January 28, 2008


« Older Did Ferraro cry?   |   Snow Removal Newer »
This thread is closed to new comments.