MS Excel going slow on me - Is my document too big?
December 11, 2007 3:32 PM   Subscribe

Very average PC user here. The MS Excel document I use everyday has become huge over time. One sheet with 6 columns going down more than 4000 lines. It weighs 7,6 Mbyte. Too much?

It's just line after line with coordinates and text (no formulas). Recently the program has begun to behave weirdly when I'm using this document.

Inserting or deleting a line takes a full minute. Copying a line or a group of lines can take even longer. Even a simple save seems to take forever.

What's wrong?

I would like to keep using this single-sheet .xls document and have it work quickly on all fronts. I find it very useful to have all my information in the same sheet.


Thank you.
posted by amusem to Computers & Internet (9 answers total)
There's something wrong with the file it if is only 4000 lines and that fat. The strange time lags is also something to worry about.

If I were you, I'd select the cells with the data and then copy them into a brand new sheet. If you see problems with the new file, then perhaps your normal.xls [the default template for new docs in excel] is corrupted or has been infected with something.
posted by birdherder at 3:40 PM on December 11, 2007

To add to birdherder..

Copy the cells with data, paste SPECIAL them into a new workbook, and choose data only. That way if there are hidden formulas, it will drop them.
posted by Jonsnews at 3:48 PM on December 11, 2007

I think birdherder made a great suggestion. There's a chance that Excel might copy whatever hidden crud is slowing down your spreadsheet when you copy the data. To get around this, you could copy all of the data to a text document (via something like notepad) and then paste it from there to a new sheet. It's a bit hacky, but laundering the data in this way has helped me in the past.

ps - If you want a reference document regarding size, I just glanced at the file size of a spreadsheet of mine with 56,000 rows and 13 columns. It weighs in at just over 8 megs. Your 7.6 megabyte document is full of things you don't want.
posted by eisenkr at 3:51 PM on December 11, 2007

I just made a representative document filled with junk data in OpenOffice, which should behave about the same as Excel. Total file size is about 900K, and there is no delay when inserting or anything like that. The delay could be caused by some kind of hidden macro virus in the file, so it is a good idea to try to create a clean document like others suggest.

Out of curiosity, are there any other problems with the computer, or is it just this one Excel file? Is the computer normally responsive when performing other tasks?
posted by PercussivePaul at 3:52 PM on December 11, 2007

I don't have an answer, but I did want to ask, just to be sure: You do have this behemoth document backed up somewhere, right?
posted by limeonaire at 3:53 PM on December 11, 2007

Probably not the answer you're looking for, however when I've seen this behavior in the past, it was on a "shared workbook". Unsharing it and re-sharing it fixed the issue.
posted by TuxHeDoh at 4:46 PM on December 11, 2007

Something odd is going on -- that's nothing in terms of size for an Excel spreadsheet. Back in the day, I used to work regularly with .xls files literally orders of magnitude larger.

I'd copy the data over to a new file as a start, definitely, and keep regular backups.
posted by stavrosthewonderchicken at 5:32 PM on December 11, 2007

You might want to try using 'Save As', per, since I believe the Office programs just tack the changes onto the end of the file (I think in Word, this is the 'fast save' option, maybe excel has a similar option) when you do a regular 'Save'.
posted by MikeKD at 5:59 PM on December 11, 2007

Specifically, try "save as comma-delimited text (.csv)", then reopen it and save it as an Excel file. See what difference that makes.
posted by aeschenkarnos at 6:07 PM on December 11, 2007

« Older What's the real mystery here?   |   How to force a MacBook Pro to re-detect video? Newer »
This thread is closed to new comments.