My Documents files in Internet Explorer favorites
December 5, 2007 10:24 PM   Subscribe

How do I keep the contents of the My Documents folder from showing up in Internet Explorer favorites?

Most of my coworkers use Internet Explorer 7 on Windows XP, and today one of them told me that when she clicks on Favorites in IE, every file from her My Documents folder is displayed there. At first I thought she'd accidentally copied and pasted a bunch of shortcuts somehow. But then I had her make a new Word doc and save it to My Documents as Fake.doc, and sure enough, it showed up in the IE favorites right away.

I looked through her IE settings, but I didn't find anything related to My Documents. Then I opened the My Documents folder and checked the settings in Folder Options just in case, but I didn't see anything there, either. Is this some kind of Internet Explorer/Windows Explorer conflation?

I suppose I could have her remove Fake.doc from her IE favorites and see if the document itself is deleted from My Documents. But even if the document isn't deleted and she's safe to remove all those documents from her favorites, I'd still like to know how it happened.

(I'm not really a tech support person; I've just been labeled as The Girl Down The Hall Who Knows About Computers.)
posted by bluishorange to Computers & Internet (4 answers total)
What is this reg key (Favorites) set to?

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
posted by B(oYo)BIES at 12:15 AM on December 6, 2007

If this is Vista, go to your user folder and right click on Favorites, select Properties, then Location and you can change from here.
posted by B(oYo)BIES at 12:17 AM on December 6, 2007

Best answer: Most likely the Favorites folder has been somehow redirected to My Documents as Mr. Boobs suggests above.

IE7 includes a "reset all to defaults" button. I don't remember if it resets this or not, but I suspect it does. To try it, Open IE and open the Tools menu ("Tools" on the menu bar, or the gear icon on the command bar), select Internet Options->Advanced->Reset... (near the bottom).

This will reset EVERYTHING to what it looks like out of the box. It won't delete favorites, but it will delete history, cookies, etc, and it will re-create the default Links folder in favorites if you have deleted it.
posted by jeffamaphone at 10:48 AM on December 6, 2007

By "it won't delete favorites" I meant it won't delete the individual favorite links that have been made. It will reset the folder location and you might have to move stuff in the My Docs folder to the Favorites folder by hand.
posted by jeffamaphone at 10:49 AM on December 6, 2007

« Older Do you like your Dalselv bedframe from Ikea?   |   Looking for help programming a flash game to do a... Newer »
This thread is closed to new comments.