Help me get my new Airport to play nice with my old Linksys router
November 26, 2007 10:10 PM   Subscribe

I just picked up an Apple Airport Extreme and am attempting to integrate it into my home network, and my old router is jealous. My intent is to use the Airport to serve IP addresses to all my devices via DHCP, and use its wireless capabilities for my 802.11g computers (looking forward to 802.11n). I've pressed my old Linksys WRT54G into use providing wireless access to my 802.11b devices (2 wifi Internet radios), to isolate them from dragging down the .g devices' wireless access speeds.

I've got the Linksys plugged into one of the LAN ports on the Airport, and the Linksys is getting its IP address (10.0.1.200) from the Airport's DHCP server. I've still got the DHCP server on the Linksys on, serving IP addresses in the 192.168.1.x range to my .b devices on the same subnet as the Airport. All that is working fine: all devices have internet access on their respective wireless networks.

The final step is for the .b devices to get their IP addresses from the Airport. That's what's not working. When I turn off the Linksys's DHCP server, the devices connected to its wireless network are getting IPs in the 169.254.x.y automatic private IP space. I've set the Linksys's config to both 'Gateway' (which is what it was when it was the only router on my network), and I've tried setting it to 'Router', with no further success.

Again, the Linksys' WAN address is getting 10.0.1.200 from the Airport's DHCP server, and I'm setting the Linksys LAN address to 10.0.1.201 (outside the Airport's DHCP range of addresses).

What am I missing here?
posted by DandyRandy to Computers & Internet (9 answers total) 1 user marked this as a favorite
 
Put the Linksys into "passthrough" mode and set it to an "opposing" wireless channel (e.g., set your Airport Extreme to channel 1 and your Linksys to 11).

This will:

1. Use the Airport Extreme base station as your DHCP server.

2. Reduce signal interference.

That way, you don't have to worry about address space, and signal interference issues from running multiple APs is reduced.

I'm not really familiar too much with Linksys because it has a bad reputation (sorry), but I know the WRT54G model is popular because you can install an open-source firmware on it. You should be able to find a third-party firmware that will provide you passthrough mode, if the factory firmware doesn't.
posted by Blazecock Pileon at 10:17 PM on November 26, 2007


You're double natting and you don't need to (in fact, devices on the two networks may have trouble seeing each other properly). Leave the Linksys' WAN port totally unused and its DHCP disabled. Plug one of the switch ports into one of your Apple product's switch ports. I actually do this because the wireless half of my SMC Barricade is busted -- my WRT provides all the wireless access in my house.

You should also be aware, however, that most modern 11g access points offer "Mixed b/g mode" which allows g devices to run at full speed while still supporting 11b devices. The WRT is one such access point, and I'd be surprised if Apple provided an access point that didn't include this feature which has been common for several years.

Unless you're using two WAPs to cover two different areas, there's really no need to run them both. You could very easily pick one and stick with it.
posted by majick at 10:37 PM on November 26, 2007


If you flash the sucker using an X-wrt image you'll have a lot more flexibility and a lot more stable device.

BP and majick are correct, the linksys just needs to bridge the networks. You can get around this by unplugging the linksys connection from the wan port on it and just using one of the lan ports for the connection to the airport.
posted by iamabot at 11:03 PM on November 26, 2007


You need to set the WRT54G to do DHCP forwarding. It should be on the same page as all of the other DHCP settings. I know the dd-WRT firmware does this, and I think the stock firmware does too.
posted by philomathoholic at 12:05 AM on November 27, 2007


After looking at the linksys' user's guide, I see that the stock firmware can't do dhcp forwarding (and it doesn't look like there's a "WAN passthrough" setting either). So, then I recommend: disable the WAN connection (this isn't strictly necessary), disable the DHCP server, use a cable connected to the LAN sides on both routers - that way everything can see everything else.

If you stick with the running-two-radios-right-next-to-each-other thing, definitely put them on non-contiguous channels (like BP says).
posted by philomathoholic at 12:21 AM on November 27, 2007


Everyone else has got it right... If you plug the Airport LAN into the Linksys LAN and turn off DHCP on the linksys, you are basically using the Linksys as an 802.11b access point, which should work fine...

Can I also suggest setting a static IP on the Linksys that is on the same subnet as the Airport is handing out DHCP addresses for? This will allow you to find the Linksys if you need to configure it, without having to work out what IP it got assigned this time! :)
posted by ranglin at 1:04 AM on November 27, 2007


Just a security note: presumably, the .b is WEP, and you're using WPA on the Airport? In this case, an attacker can break the WEP (it's about as effective as a "Keep Out" sign) to get into the rest of your network.

You may consider setting up a DMZ, with the Linksys out the WAN side of the Airport, and then doing some forwarding to get access to specific services for your .b devices. That way, an attacker who breaks WEP will still be outside the Airport's network.
posted by chengjih at 2:23 AM on November 27, 2007


Thanks for your many responses - I'll try out the suggestions when I get home tonight.
posted by DandyRandy at 8:54 AM on November 27, 2007


Just to tie this up - running an Airport LAN port to one of the Linksys's LAN ports (rather than its WAN port) did the trick. And setting a static IP on the Linksys was a great idea as well.

Many thanks again to all!
posted by DandyRandy at 5:04 PM on November 28, 2007


« Older Drug interactions while taking Mobic (meloxicam)?   |   Ridiculous publicity stunts Newer »
This thread is closed to new comments.