Vista wireless access point config
November 5, 2007 6:27 AM   Subscribe

I am running Windows Vista Home Premium and am having problems configuring a new wireless access point. Windows is unable to connect to it and I simply receive an "HTTP 400 Bad Request" error in my browser.

My Netgear A/B access point just died after years of service so I needed to replace it and found very limited choices. I am trying to configure the D-Link AG700AP (access point). By default the IP is set to 192.168.0.50. My current network runs in the 192.168.1.0 range. After plugging the access point into the laptop, Vista's Network and Sharing Center shows the network exists (Private Network) and it shows up. I have attempted to 'hardcode' the IPv4 setting for the adapter as:
IP address: 192.168.0.51
Subnet mask: 255.255.255.0
Default gateway: 192.168.0.50
Preferred DNS server: 192.168.0.50

The web browser reports the following error when attempting to connect to http://192.168.0.50.

This error (HTTP 400 Bad Request) means that Internet Explorer was able to connect to the web server, but the webpage could not be found because of a problem with the address.

In order to attach to a router/access point outside of my current network I was always able to do this (hardcode the settings) in XP, but for some reason this isn't working in Vista. Is it because of Vista using IPv6 and IPv4? I admit I'm confused on this.

If I leave the Integrated Controller settings to auto grab the IP (instead of hardcoding as above), then it doesn't acquire an IPv4 gateway. The autoconfig IP is set to 169.254.56.168.

Thanks for any help!
posted by mcarthey to Computers & Internet (9 answers total)
 
I'm a bodger rather than an IP pro, but:

I think you have the wrong subnet mask. IIRC, with a subnet mask of 255.255.255.0, your router would have to be at 192.168.1.50 before your network would see and talk to it.

Also, is your firewall allowing the packages through?

Finally, on every router I've ever configured, the IP number on the internet facing side tends to be the one that's allocated by your ISPs DHPC server and so will be your 'real world' IP number.

However, if you're using this to join two private networks, or possibly if you're using it to talk to another router, you'd use adjacent IP numbers.
posted by PeterMcDermott at 8:41 AM on November 5, 2007


If I leave the Integrated Controller settings to auto grab the IP (instead of hardcoding as above), then it doesn't acquire an IPv4 gateway. The autoconfig IP is set to 169.254.56.168.

Actually, this is as it should be if the router is talking to the internet. Your IP gateway (the one that you enter into your TCP control panel) should be the routers IP number, which you've allocated as 50.
posted by PeterMcDermott at 8:44 AM on November 5, 2007


If you are getting a 169.x.x.x IP address, that sounds like DHCP isn't turn on for your router.

Why not turn DHCP on and let your router assign 192.168.0.x addresses to all your network devices?
posted by mphuie at 9:18 AM on November 5, 2007


Thanks for the responses all. I am simply trying to connect to the access point in order to configure it. This is an access point, so it will not be providing DHCP (my primary router handles that), but either way I cannot access the configuration for it due to these issues mentioned. Yes, the subnet mask of 255.255.255.0 will provide 254 different possible hosts but only the one subnet. In this case, I am not trying to connect the two networks via subnetting, so that's fine. For the purposes of configuration I simply want to connect to the access point which has the default IP of 192.168.0.50. Therefore we can ignore the 192.168.1.0 network. It is not intended to be active during this configuration process. I want to change the new access point to use the same subnet instead of its default. I also understand the difference between the WAN and LAN IPs. My difficulty is that I am unable to connect to the 192.168.0.0 network.
Thanks for any help!
posted by mcarthey at 9:44 AM on November 5, 2007


The fact that you are getting an HTTP error response means that you have managed to talk to your AP, so the routing must be working properly.

I'm guessing your AP is refusing to be configured by someone outside its own subnet, for security reasons.

The obvious thing to do would be to (temporarily) assign a static address in 192.168.0.0/24 to your PC, talk to the AP and move it over to 192.168.1.0/24 or wherever. Then restore your initial PC configuration and proceed.
posted by the number 17 at 11:08 AM on November 5, 2007


Gah you have already done this - my bad

The next obvious thing to do would be to use another computer, one not running Vista. Also what browser are you using ? Maybe it's doing some funny stuff with the headers.
posted by the number 17 at 11:15 AM on November 5, 2007


did you try hitting it up with SSL? https instead of http? sometimes the error messages get confused with the less-capable https stacks in dedicated appliance gear.
posted by jenkinsEar at 11:23 AM on November 5, 2007


Your DNS is incorrect - it cannot be in the 192.168.x.x range. That's why you can't load any web pages. Find out what it should be from your ISP.
posted by kenchie at 11:52 AM on November 5, 2007


the number 17, thanks. I finally just hooked it to a Win2K machine and it worked fine to configure. Doing as I had tried (and as you suggested by setting the static address) worked fine. I don't get why it doesn't work in Vista. This is definiately a problem and something I'm going to have to look into. I suspect it's something about IPv6, but I don't know enough about it (yet) to say if it's true or not. Either way, I can't get it to work as expected in Vista.
Thanks for the suggestions all.
posted by mcarthey at 11:56 AM on November 5, 2007


« Older News for Canadians. Stuff that Matters.   |   It's not you it's me Newer »
This thread is closed to new comments.