Windows background issues
May 23, 2004 6:57 PM   Subscribe

Win2K - I had a risque pictue set as my desktop background. My in-laws are coming to stay for a week, and my machine is in the guest room. Since I already don't rate very highly with then, I swapped the background image to something very tame. However, during the startup process, the original image appears for a couple of seconds before being replaced by the new. Why does this happen, and how can I fix it?
posted by Irontom to Computers & Internet (15 answers total)
 
Just an idea: do you have any wallpaper rotation program currently active (proggie that randomly rotates wallpapers) ?

Another idea: if you can't located and delete the offending pic (or just rename it) you may as well add a guest user to the users list and make your account password protected (as last resorts, if everything else fails).
posted by elpapacito at 7:03 PM on May 23, 2004


Right-click on your desktop and turn off 'Active Desktop' or 'View as web page'. Then change the wallpaper there.
posted by Space Coyote at 7:08 PM on May 23, 2004


yeah, you need to reset your normal desktop background, not just the active desktop background.

just turn off active desktop, then load the jpg you want (assuming it's a jpg) in ie, the right click and set as desktop.
posted by Hackworth at 7:25 PM on May 23, 2004


In ME (maybe Win2K too), if you use a JPG, you have to use active desktop. Use a tame BMP or GIF instead, or no picture at all.
posted by ALongDecember at 8:01 PM on May 23, 2004


Actually, I believe you can leave your active desktop settings alone. Just change your desktop background again...the last background (i.e. the one you changed to get rid of the dirty image) should now be the one that briefly appears during startup, while the second one is your currently active desktop background.
posted by filmgoerjuan at 8:19 PM on May 23, 2004


Yeah but active desktop is the devil and should be killed anyway :)
posted by Space Coyote at 9:03 PM on May 23, 2004


I never understood what everyone's problem with active desktop was.
posted by Yelling At Nothing at 11:11 PM on May 23, 2004


I also had that problem. It seemed to be because I had taken an image from the internet i.e right clicked and set as wallpaper. The solution is to right click on a new cleaner image and that will be the one that appears briefly at start up [even if you set you wallpaper as something else].
posted by meech at 11:22 PM on May 23, 2004


Do consider make that guest account for them anyway. Who knows what else on your computer is potentially offensive to them, or how tempted they could get to peek into the status of your (finances|relationship|job). Besides, giving them an account that they can setup as they like while checking mail/web is a nice hospitable little gesture that might score you any extra point or two (and if they happen to munge any settings it's only on a low-privs throwaway account, instead of the superuser account capable of hosing an entire system).
posted by nakedcodemonkey at 11:59 PM on May 23, 2004


Side note: the problem with active desktop is really rather simple. Take something like windows 2000 or even XP, that used a process model that prevents a failing program from taking down the whole system. That is, a program crash should be much more handle-able on winxp or 2000. Then, add windows desktop, a program that, when it crashes (and for some people it does with alarming frequency) takes down the whole computer. Time for a reboot. Also, if you run active desktop, if I'm not mistaken, an IE crash will also crash your computer.
posted by RustyBrooks at 8:05 AM on May 24, 2004


Then, add windows desktop, a program that, when it crashes (and for some people it does with alarming frequency) takes down the whole computer. Time for a reboot. Also, if you run active desktop, if I'm not mistaken, an IE crash will also crash your computer.

nonsense. both windows 2000 and windows xp will simply restart explorer.exe and/or internet explorer should they crash. (on the rare occasion explorer.exe does not come back on its own, you can restart it yourself by loading task manager with ctrl+alt+del.)
posted by kjh at 8:35 AM on May 24, 2004


The other complaint about active desktop was that it was the half-assed Microsoft solution to using JPG's as a desktop background. Try choosing a JPG as your background, click apply, and it tells you to enable Active Desktop. That's crazy overkill.
posted by smackfu at 8:38 AM on May 24, 2004


The issue isn't whether or not Windows is annoying/evil/not OS X/not Linux. The issue is that something didn't work for a mefi user, and we put together some steps to try and resolve it.

Huzzah.
posted by jragon at 9:38 AM on May 24, 2004


Okay - got it fixed with the 2nd comment. Thanks for the help.
posted by Irontom at 10:19 AM on May 24, 2004


Well, I guess it bears repeating (or clarifying), but if you open a jpg in IE and then set it as you background from there (by right-click > set as background [NOT desktop item]), then it will automatically make it a bitmap and put it on the regular desktop, no "active" needed.
posted by Hackworth at 10:12 AM on May 25, 2004


« Older Trip to Bretagne and Normandy   |   Purchasing a Digital Camcorder Newer »
This thread is closed to new comments.