How to make Fallout 2 run fullscreen?
October 4, 2007 3:20 PM   Subscribe

Why is Fallout 2 displaying so.. small? [laptop, Windows XP]

I'm trying to play Fallout 2 (newest patch) on a Dell Inspiron 1100 laptop running Windows XP SP2. The graphics controller is an Intel 82845G of some flavour with the newest drivers. The trouble is, it only takes up a postcard-sized portion of the screen! About half of the screen's width and height, centred in the middle. The whole game displays, just small. The mouse cursor travels only as far as the edge of the display.

I've tried running the program in various compatibility modes, but no dice. I seem only to be able to set the screen resolution (of Windows) to 1024x768 or 800x600; but if I choose the latter, it shrinks the desktop instead of actually changing the resolution, and Fallout runs at the same size. I know that the game's graphics are at 640x480 resolution. I've tried plugging the laptop into a (flatscreen LCD) monitor and it doesn't fix it.

The crazy thing is, I *did* actually get it to run using the full screen once. I had hooked the laptop up to my TV using an S-video out, and when I unplugged it, switched back to the laptop's screen, and started up Fallout, it was at the full size. After I restarted the laptop, the problem was back, and I didn't have any sucess replicating it. So how do I rebiggen it?

Thanks in advance.
posted by Drexen to Computers & Internet (11 answers total) 2 users marked this as a favorite
I actually had almost the exact same problem you describe, albeit on an Inspiron 4150, and about four years ago. Try pushing the "Fn" and "Font" combination (or maybe "Fn" and "CRT" keys, or something like that; I don't have my laptop with me right now so I don't remember the exact key names). Anyway, I think that tells it to scale the display instead of just doing a one-to-one pixel map (and leaving all the black space).
posted by homer2k1 at 3:30 PM on October 4, 2007

Alt-Enter was the keyboard shortcut to make a bunch of those games play in full screen. I also faintly remember a full screen tick box option in the preferences for Fallout2. Could one of those help?
posted by ShootTheMoon at 3:31 PM on October 4, 2007

Check your BIOS settings. On some Dell laptops, you have to tell it to fill the full screen at lower resolutions. Just boot your computer, if the Dell logo, is near the center of the screen instead of out by the edge, this is what's going on.
posted by Eddie Mars at 3:42 PM on October 4, 2007

What you need is 'scaling', where it magnifies lower resolutions to the much larger number of pixels on modern displays.

Most laptops have two ways to do this; it can either be done by the graphic card or the actual physical LCD. I'm not familiar with the Intel drivers, but I'm sure I saw someone mention that they have full scaling options in the Windows control panels.

That will generally work fine, but if you can't find it or it's not working how you want, you can usually set your LCD screen to do it as well. That's generally done in your BIOS setings. I'd try that second... look first in your video control panels (it may be rather deeply buried), and then try the BIOS if you can't find anything.
posted by Malor at 4:00 PM on October 4, 2007

there used to be a directx loader floating around that would let you run fallout up to whatever max resolution your adapter/screen was capable of. lemme see if I can hunt it down.
posted by juv3nal at 4:51 PM on October 4, 2007

Second the scaling setting in the BIOS. My Thinkpad used to have the exact same problem running MAME.
posted by ReiToei at 4:53 PM on October 4, 2007

Hmm my memory is a bit hazy it seems. This isn't exactly what I was talking about, but it might do the same thing.
posted by juv3nal at 4:54 PM on October 4, 2007

This might also be worth taking a look at.
posted by juv3nal at 4:57 PM on October 4, 2007

Response by poster: Thanks for the suggestions, everyone - I'll try playing with the BIOS settings tonight, or using juv3nal's links. I'd tried pushing the laptop's 'CRT/LCD' button a few times but that didn't help.
posted by Drexen at 4:13 AM on October 5, 2007

You may find D3Dwindower of some use. It's not in English, but its workings are easily enough discerned - just make sure to point it to a shortcut, and not the actual .exe file.
posted by unmake at 10:43 PM on October 6, 2007

You may find D3Dwindower of some use.

That's the one I was originally thinking of.
posted by juv3nal at 11:24 PM on October 6, 2007

« Older Cloud city! What is this weather phenomenon?   |   Eastern Promises Plot Newer »
This thread is closed to new comments.