Macbook keyboard functionality problems
October 3, 2007 3:04 PM   Subscribe

Macbook keyboard issues: I clicked on a google search result and was sneakily redirected to one of those malware scan sites, now macbook keyboard is doing funny things. The arrows do not work and the apostrophe and forward slash keys bring up the "find" window at the bottom of the screen (firefox). How do cancel out whichever setting was changed and get my key functionality back?

I love my mac, but I am not so mac savvy so I have no idea what happened. If it helps, it is a macbook running os x 10.4.10.
posted by birdlady to Technology (7 answers total)
Response by poster: I should have tested the issue before posting, but it seems that this is happening only in firefox. I can use the keys in other programs. So I guess it is a firefox issue rather than a straightforward keyboard issue?
posted by birdlady at 3:07 PM on October 3, 2007

Best answer: You ought to be able to go into the "Add-ons" menu and find something mysterious and disable it.
posted by Steven C. Den Beste at 3:36 PM on October 3, 2007

The apostrophe and forward slash keys bringing up the Find dialog are built-in functionality of Firefox, so that is normal behavior. I'm not sure about the arrow keys, though.
posted by phrayzee at 3:49 PM on October 3, 2007 [1 favorite]

Best answer: Relaunch Firefox, if that doesn't work reboot the machine, if that doesn't work check the "Add-ons" menu and if that doesn't work you can get a clean Firefox from Mozilla.
posted by TeatimeGrommit at 6:14 PM on October 3, 2007

Response by poster: Thanks all. There was nothing in the add-ons and I re-started firefox and now all is well. I wonder what happened, but I'm glad all is back to normal. Thanks again!
posted by birdlady at 6:34 PM on October 3, 2007

You may have accidentally entered caret browsing mode (normally turned on/off with F7). That would cause the arrow keys to seem not to work.
posted by Who_Am_I at 5:37 AM on October 4, 2007

the ' and / keys you mention are a "feature" in firefox; though smoewhat annoying. So, in firefox hitting those keys will always bring "quick find" at the bottom of the browser.

Since it is a default feature, I doubt if by doing nothing it just went back to "normal" -- chances are you are not tying those characters outside of a textarea. quick find will show up unless you ahve taken measures to disable it or change the hotkeys
posted by cusecase at 11:34 AM on October 4, 2007

« Older Tuition Assistance   |   This slide film is almost as old as me, and slight... Newer »
This thread is closed to new comments.