Help me not download .pdfs I don't want!
September 19, 2007 7:28 PM   Subscribe

How do I keep Firefox from saving every .pdf file I look at onto my desktop?

I love everything about my new Mac except one thing. When I view a .pdf file in Firefox (using either Preview or Adobe Reader) the file is automatically saved to Desktop. Since I look at dozens of .pdfs every day, this means that there are tons and tons of random files cluttering up my desktop. What's more, since these .pdfs are often from the arXiv or Math Reviews, they have meaningless filenames, so I have to open each one in order to see whether it's something I want to trash.

What I would like: either a) to be able to view .pdfs in Firefox without downloading the file to my Mac at all; or b) to have the download automatically go to a folder "Temp Downloads," which I would trash every once in a while. What's more, for the files I _do_ actually want to keep, I would like it if it prompted me to choose a filename for the download -- as it is, I seem to have no choice except for the meaningless filename that the file comes with.

I've already tried changing the Preferences in Firefox to the Temp Downloads folder -- this works for ordinary downloads, but the .pdfs I view still go to the desktop. I installed the PDF Download plugin, which also didn't help.

Using OS/X 10.4.10, Intel processor, Firefox 2.0.0.3, if this matters. Any ideas, or am I fated to a life of tedious Desktop cleaning?
posted by escabeche to Computers & Internet (16 answers total) 4 users marked this as a favorite
 
Have you looked into DocuFarm's service? After installing their browser plugin, you'll be shown an easy-to-navigate copy of the PDF as long as they've processed it in the past. This also applies to other document types, too.
posted by odinsdream at 7:45 PM on September 19, 2007


ODINSDREAM I KISS YOU -- this is not totally perfect (I have to control-click on the "download pdf" point on the arXiv, then scroll down to "view on docufarm", rather than one-clicking) but this is a hell of a lot better than what I was doing before.

Other suggestions are still very welcome, but in 15 minutes I got a great workaround for something that's been bugging me for weeks. AskMeFi is great.
posted by escabeche at 7:59 PM on September 19, 2007


You can change the downloads directory in the preferences (Firefox / Preferences / Main). Aside from that, I don't know what you can do, but if there is something, I'd love to know about it.

Oh, there is also the PDFDownload Extension which gives you a few more options (view as HTML is one of them).
posted by synecdoche at 8:00 PM on September 19, 2007


I had this exact same problem. A little googling brought me to Schubert|it PDF Browser Plugin. I've been using it ever since.
posted by alopez at 8:15 PM on September 19, 2007


Oops, I should have read more carefully. Still, the PDFDownload Plugin might be helpful.
posted by synecdoche at 8:19 PM on September 19, 2007


This has been one of my major complaints as well, but I figured out a workaround. It only happens if you select "Open File" instead of "Save File." I am still annoyed by this (I don't want to have to save these stupid little things and delete them later) but at least they go somewhere where I can ignore them.
posted by dondiego87 at 8:40 PM on September 19, 2007


see also
posted by Tuwa at 8:57 PM on September 19, 2007


I had this exact same problem. A little googling brought me to Schubert|it PDF Browser Plugin. I've been using it ever since.

Have you actually got that thing working? I've tried installing it several times but still get the open/save dialog when clicking PDFs. It doesn't even show up in about:plugins. (I put it in /Library/Internet Plug-Ins like the read me said.)
posted by DakotaPaul at 9:07 PM on September 19, 2007


Tuwa: the solution given there works for general downloading, but for whatever reason not for opening .pdfs. I believe it would work if I used "save file" instead of "open file," but then I'd have to do something else to open the file!

I tried the Schubert|it browser plugin, which seems just the thing, but couldn't get Firefox to see it for whatever reason. So far, DocuFarm remains in the lead (except that I don't think I can print from DocuFarm preview.)
posted by escabeche at 9:09 PM on September 19, 2007


escabeche: really? How strange. Don't mind me; I'm just a Mac-less guy who remembered the other thread.

I will say it's odd that this is the behavior Apple's gone with; when I had one of their laptops briefly the UI seemed perfectly intuitive and sensible.
posted by Tuwa at 9:29 PM on September 19, 2007


Hmm, after a bit of checking, it turns out that it works for me because I'm on a PPC Powerbook -- apparently it doesn't work on the Intel Macbooks. Here's a workaround. I have no way to test it, but maybe it will work for you.
posted by alopez at 9:44 PM on September 19, 2007


You can set it to download to a temp folder instead of the desktop. Trick is, the settings are in the Safari preferences. Weird, huh?

Anyway: Safari Preferences, General, Save Downloaded Items to...

escabeche writes "I tried the Schubert|it browser plugin, which seems just the thing, but couldn't get Firefox to see it for whatever reason."

It's for powerPC rather than intel macs. But you can make firefox think it's running on a powerpc mac, and force the Schubert plugin to run. I can't remember how to do it, 'cause I have my powerpc in front of me, and not my intel machine. But you find the firefox app, click on "get info" and there's a box there to check...

I'll be more helpful tomorrow if there's not a better answer.
posted by mr_roboto at 10:58 PM on September 19, 2007


Summary: DocuFarm is a good web-based solution, apart from the fact that you can't print (unless I'm missing something.) For a PowerPC Mac, the Schubert|it plugin should do the trick. That plugin doesn't work on an Intel Mac unless you run your browser through an emulator (as alopez's linked workaround above explains) -- this apparently slows down browsing. I have best-answered links to all of the above.

mr_roboto, just checking, you aren't saying that by changing Safari preferences I can change the location where Firefox automatically downloads .pdfs...?
posted by escabeche at 8:10 AM on September 20, 2007


escabeche writes "mr_roboto, just checking, you aren't saying that by changing Safari preferences I can change the location where Firefox automatically downloads .pdfs...?"

Yes. Here's a discussion describing how it works. Basically, Firefox uses the OS X systemwide default download directory, which is set in the Safari preferences.

To make the Schubert|it plugin work on an intel Mac, find the firefox application file and get info on it. Check the box labeled "open using Rosetta". The plugin should work now. There could be a performance hit, but I haven't noticed one.
posted by mr_roboto at 4:58 PM on September 20, 2007


Yeah, so this is a solved problem. From a question that I asked earlier today:

http://ask.metafilter.com/71889/How-do-I-keep-my-desktop-clean
posted by rachelpapers at 7:14 PM on September 20, 2007


Yep, just changed the preferences in Safari and now Firefox downloads the pdfs I open to the Temp Downloads folder I made, just as I wanted. And thanks, rachelpapers, I didn't catch your question because I had convinced myself my problem was unique to .pdfs and was searching for that.
posted by escabeche at 9:58 PM on September 20, 2007


« Older i just feel gross   |   Photography music? Newer »
This thread is closed to new comments.