Jumpy slow mouse pointer in one screen
August 25, 2007 7:24 PM   Subscribe

Jumpy mouse in one screen. My mouse pointer does not refresh fast enough in one screen but is fine in second screen.

I have an Asus video card based on nvidia 6200. It's driving 2 displays, one optiquest 22", the other NEC 19". The first one is dvi, windows is XP. On first screen, the cursor is very jumpy, it does not refresh often enough. If moved with an average speed, it jumps about every 1/3rd of a centimeter, instead of moving smoothly. On the second display it does jump but very little, the difference is huge. I guess they always jump a little, it should depend on monitor refresh rate unless processor is extremely slow. Here processor is athlon X2 3200. Changing resolutions and color depths does not make any difference. Using Asus or nvidia drivers and various settings in them does not make any difference. Everything else works fine on that large display, including dvd movies - this seems to be related only to mouse cursor. In win2k which I dual boot it seems to work much better, but I don't remember for certain, I used win2k and did not notice anything but after a day in XP I did notice by contrast with the 2nd display. I tried both Asus driver and Nvidia driver, and many various options in either. This is annoying because I work in CAD programs and I have to watch cursor carefully and it's just annoying that it jumps so much. I get the feeling that system is slow even though it's very fast. In the end it's more comfortable to use the 2nd display even though it's so much smaller. Another clue is that it seems to be ok after system is started but I think (I didn't test yet), if you start Autocad it becomes bad and after closing Autocad it stays bad. What could it be?
posted by rainy to Computers & Internet (7 answers total)
 
Just curious, are you using an optical mouse? And is it on a surface which has stripes or a similar pattern (wood desk, tiger stripe mousepad, etc.)? Try putting your mouse on a plain white piece of paper, see if this helps with the jumpiness.
posted by anaelith at 8:12 PM on August 25, 2007


anaelith: it's optical and surface does have stripes but that's not the issue because it's always been fine in win2k in different video cards and it is still fine on the analog screen. This is related most likely to the larger screen being DVI. Probably a combination of it being DVI & win XP & this particular card. It's jumpy in a consistent manner - IOW it's obvious that it's just redrawing very slowly. If you move it very slowly jumps aren't noticeable.
posted by rainy at 9:00 PM on August 25, 2007


to clarify: I have dual screen desktop on the same card and as I move the mouse from one screen to the other, it instantly becomes smooth. I move it back to 1st one, jumpy. Move it back to second again, smooth!
posted by rainy at 9:01 PM on August 25, 2007


This problem seems to crop up every now and then with Nvidia drivers on some systems. The usual solutions are to either drop back a version or 3 and see if that fixes the problem, or to go into the driver control panel and drop hardware acceleration back a notch or 2.

The other thing is that usually the cursor is only hardware accelerated on the primary display - on the secondary display, it's software accelerated. This can cause problems if the 2 displays are running at non-simply-related refresh rates (e.g. 60 / 75 Hz, 60 / 90 Hz, or 75 / 90 Hz are usually OK, but 75 / 72 Hz causes problems)
posted by Pinback at 1:01 AM on August 26, 2007


Pinback: thanks, it's fixed when and only when I push hardware acceleration all the way down to the point where directdraw is disabled. That's good enough for me. I can turn it on when playing games. Thanks a ton - I never thought of playing with this setting.
posted by rainy at 8:03 AM on August 26, 2007


Pinback's working solution makes me think it might be the mouse shadow option - maybe see if disabling the shadow makes it less jumpy. Just a wild guess, but I've experienced something similar.
posted by aye at 9:39 AM on August 26, 2007


aye: that was my first thing to try. Doesn't help. Incidentally, cursor in Heroes of might and magic 5 is *really* slow, to the extent that makes it completely unplayable, until you turn on hardware cursor. Then it's somewhat slow but a hundred times better than before. So, it is a directdraw issue..
posted by rainy at 7:18 PM on August 26, 2007


« Older VLC command line to autoplay a dvd?   |   Age formulas in MS Excel Newer »
This thread is closed to new comments.