Stop my Wireless from disconnecting when idle
August 15, 2007 3:19 PM   Subscribe

When I leave my PC on during the day while I'm out, it disconnects from the wireless router, stopping any downloads I have running. if I'm at home using it this never happens.

I have turned set all the power-saving options to "Never", and have checked that the Wireless USB dongle is set to "CAM" power-saving mode.

Is there anything I can do to stop it doing this? The Router is a brand new Netgear DG834G, the USB dongle is a "Dynamode" but has no model number. I'm running XP/SP2.
posted by lemonfridge to Computers & Internet (10 answers total)
 
Have you set the network card's power setting to off? This is a separate setting from the Control Panel power settings.
posted by jmd82 at 3:37 PM on August 15, 2007


...do you have a housemate?
posted by pantsrobot at 4:11 PM on August 15, 2007


jmd82 has it, the power settings control which parts of your PC will go to 'sleep' after a period of inactivity. If not the network card, then some other hardware vital to your downloads is being deactivated to save juice.
posted by IronLizard at 4:20 PM on August 15, 2007


Since IronLizard agrees, I'm sure there's an easier way to configure settings, but:
Control Panel --> Network Connections --> Right click on your LAN connection and click properties. Click "Configure" button near the top --> Power Management tab. (un)check boxes so power doesn't turn device off.
posted by jmd82 at 4:48 PM on August 15, 2007


There also may be power management settings in the BIOS.
posted by rhizome at 8:49 PM on August 15, 2007


I have checked the Wireless connection's Power Saving settings, but I didn't look at the LAN settings. Will altering them make a difference?

I'll check the BIOS when I get home tonight.

Failing these settings, is there any software that I can have running to keep everything busy and "awake"?
posted by lemonfridge at 1:38 AM on August 16, 2007


First thing to do with this kind of nonsense is see if it happens with a wired connection as well. Wireless is subject to random interference, quite apart from all the things that can go wrong at one end or other of the link. Wires, not so much.
posted by flabdablet at 3:51 AM on August 16, 2007


If you have downloads running, then the connection is already active, and nothing's going to help in that department.

Many accesspoints/routers have bugs that make them run out of buffer space after a certain number of connections have been opened, and if you're using p2p software, it's opening a lot of connections the whole time it's active. I suspect that your AP/router is actually resetting itself.

Check Netgear's site for updated firmware. Even though it's new, it's likely that while the unit was sitting on the shelf, several bugs were found and fixed.

Or better yet, plug straight into it with a wired ethernet cable. Then open a cmd window and run ping -t 192.168.1.1 or whatever the IP address of your router is. Let it run like that all day. When you get home, hit Ctrl-C to stop the ping, and look at the statistics. It should say 0 lost, since your wired connection should be perfectly stable and you're only pinging the local router. If you have dropped packets there, blame the router.

If on the other hand, the wired connection works perfectly, then the wireless problem could be a few things. It could be Wireless ZeroConfig playing with your card's settings, so try disabling that. It could be a firmware issue between the card and the AP, so update the card's firmware. It could be radio interference, so borrow a WiSpy or just try to see if the dropouts coincide with the neighbor microwaving lunch.
posted by Myself at 4:04 AM on August 16, 2007


Definitely check the LAN settings. While it's possible that your router is screwing up, I seriously doubt it because it's not happening while you're using it. It's possible that your firewall is also set up to stop all traffic when your PC isn't in use. What firewall do you use? (I know sygate had this feature, for certain.)
posted by IronLizard at 1:46 PM on August 16, 2007


In that same train of thought, do you have your PC set to lock when your screen saver comes on? (It asks you for a password, in other words.)
posted by IronLizard at 1:47 PM on August 16, 2007


« Older Help me track down this absurd South African...   |   Eagle, Alaska ???? Newer »
This thread is closed to new comments.