S3 Standby mode...Wake On LAN...Energy Savings...WHY DOESN'T IT WORK!!!!
August 4, 2007 8:17 AM   Subscribe

S3 Standby mode...Wake On LAN...Energy Savings...WHY DOESN'T IT WORK!!!!

After reading the great article in the Aug07 Maximum PC "Put Your PC To Sleep and Save Hundreds of Dollars", and after finding the article's roots on the web, I decided to give it a shot. I followed the instructions (as well as any info i could find online) to a T, and I can't get it to work right.

I need the system to be available for file serving to Xbox Media Center, and for printing from the wireless laptop (not sure if that will wake it up anyway, but hopeful). I would like to it sleep when nothing is going on.

I can enter S3 Sleep mode just fine, but it wakes up automatically after a second or 2. I assume this is because of normal network activity, so how do I get the system to know the difference between normal network refreshing stuff and an actual call for a file?

Here's my specs: Home-built system with an Abit AN8-SLi (Nforce 4) motherboard, fresh install of Windows XP. Networked via the on-board LAN.

Checklist:

Wake on Lan is enabled in BIOS.

BIOS option "USB resume from S3" disabled - I don't need the mouse to wake it up, i can use the power button

BIOS option "Wake-up by PME# of PCI" disabled - I don't need any PCI devices waking it up

BIOS option "Wake-up by OnChip LAN" enabled

in XP:
NVIDIA nForce Networking Controller Properties:

"Allow this device to bring the computer out of standby" is checked.

"Only allow management stations..." is unchecked (when checked, apparently only the elusive "magic packet" can wake it, and I don't think the xbox can deliver this magic. It does, however, stay asleep when this is checked.

On the advanced tab, "Wake on magic packet", "Wake on pattern", and "WakeOnLAN from PowerOff" are all enabled.

Computer is set to a static IP

All network shares are mapped to network drives, using the IP address instead of the computer name.


Help please?
posted by bradn to Computers & Internet (13 answers total)
 
Wake on LAN doesn't work on just any traffic, you need a special magical packet to wake your computer. And static IP isn't enough, it needs to be either broadcast or you need to have static ARP as well.

Wake on Lan
posted by fvw at 8:33 AM on August 4, 2007


So you are saying that the Max PC article is incorrect?
posted by bradn at 9:30 AM on August 4, 2007


As someone who wakes up his XP machine all the time without a magic packet and using just a static IP...it works.

Unfortunately, I have no insight on the coming-out-of-suspend issue.
posted by backupjesus at 10:04 AM on August 4, 2007


It's not going to stay asleep unless you use "magic packet" or "pattern."
posted by rhizome at 10:09 AM on August 4, 2007


Ah, I think rhizome nailed it -- if the box is on the same network segment as other machines, it's going to wake up whenever there's traffic on that segment unless you use a magic packet. I had forgotten that my machine goes straight into a switch, which prevents other traffic from bringing the machine out of suspend.
posted by backupjesus at 10:12 AM on August 4, 2007


But I have both "magic packet" and "pattern" enabled.
Is the only answer to add a switch between the router and the computer?
posted by bradn at 12:27 PM on August 4, 2007


What happens if you check "Only allow management stations..."? (That might not allow the XBox to wake the machine, but it's a data point.)

The other thing to try is to pull the network cable from the machine and see if it stays suspended -- BIOS settings aside, this could still be USB wackiness or something else.
posted by backupjesus at 12:51 PM on August 4, 2007


When I check "only allow management stations..." it stays sleeping until I press the power button, I assume it's waiting for the magic packet. I don't know or really care how to send the magic packet, because my objective here is to get it to wake when i request a file.

I pulled the cable and it stayed asleep. Interestingly, it did not wake up when i plugged it back in, until I hit the power button.
posted by bradn at 1:13 PM on August 4, 2007


I suspect the NIC won't establish a new link if there was no link when it was suspended, so it's probably not seeing the traffic when you plug the cable back in.

If it were me, my next step would be to take everything else off the machine's network segment (i.e., have it hooked up to a router or hub with nothing else attached) and see what happens. If it stays suspended, I'd pick up a switch and see if it does the trick -- although I'd also save the receipt for the switch, since maybe there's something else going on.

(Or wait for more guidance from AskMeFites; I just use S3, I don't claim to understand it.)

Also...rereading the original post, have you tried not having the drives mapped? Clients that are pinging the drives might be causing the traffic that's keeping the NIC awake.
posted by backupjesus at 1:34 PM on August 4, 2007


Thanks for the help. I have an old router I can use as a switch...if I can find the damn AC adapter.

I originally tried it without the drives mapped with the same results. Also, both clients are currently powered off, so that can't be it.
posted by bradn at 1:42 PM on August 4, 2007


Have you unchecked Wake on LAN?
posted by BrotherCaine at 4:48 AM on August 5, 2007


Yeah, I've tried every possible combination.

I did find out you can use a Python script to send a magic packet from XBMC...
posted by bradn at 8:27 PM on August 6, 2007


In case anyone is still listening...
After revisiting this several months later, and after installing a switch so the computer is on it's own network segment and still having the same problem, I think I have narrowed the problem down to this event from the Event Viewer:

Event Type: Information
Event Source: Tcpip
Event Category: None
Event ID: 4201
Date: 10/16/2007
Time: 10:15:01 PM
User: N/A
Computer: CENTURION
Description:
The system detected that network adapter NVIDIA...Controller - Packet Scheduler Miniport was connected to the network, and has initiated normal operation over the network adapter.


Can I disable this NVIDIA Packet Scheduler Miniport?
posted by bradn at 9:55 AM on October 17, 2007


« Older Hiding certain photos in iPhoto.   |   Going Carless in Minneapolis? Newer »
This thread is closed to new comments.