Addressbar search problems in Firefox: returns Russian results!
August 2, 2007 3:14 PM   Subscribe

When I search Google from the Firefox address bar I get Russian results - why and how can I fix it?

When I type a word in Firefox's addressbar (e.g. "Biology") I get results in Russian:

http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=biology

If I do the same search in the Google search bar I get results in English:

http://www.google.co.uk/search?q=biology&source-id=Mozilla%20Firefox&start=0

If I try with "BBC" I get the Ukrainian BBC site when I used to get the UK BBC site.

I guess some config files got changes somewhere along the line.
Can anyone help get it working nicely again?
posted by jonesor to Computers & Internet (6 answers total)
 
go to about:config (enter it like a URL in the address bar.)

Search for "keyword."

Right click on the value for keyword.URL. If it's something like

http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=

then change it to

http://www.google.co.uk/search?q=

If it's not, then there's something really screwy going on. Restart firefox in safe mode and see if it stops.
posted by Zed_Lopez at 3:28 PM on August 2, 2007


Google language settings? Firefox language settings?

Ah, you're in the UK. That might explain it.

I wonder if you've mixed up one of the language settings, because uk is the abbreviation for 'Ukranian' while en_GB is 'UK English'. Understandable mistake, or perhaps FF standardised its 18n settings in a funky way.

(The US DHS has the same problem: it's 'EN' for the UK, and 'UK' for Ukraine.)
posted by holgate at 4:24 PM on August 2, 2007 [1 favorite]


Anyway, go to Preferences > Advanced, click 'Choose' under languages, and see if you've got Ukranian at the top of the list.
posted by holgate at 4:29 PM on August 2, 2007


You're not traveling abroad, are you? It does try to use your IP to guess at what you want for a language.
posted by yerfatma at 6:05 PM on August 2, 2007


I think holgate has it, since that's not Russian: that's Ukrainian. You can tell by the character "i" that isn't used in Russian.
posted by watsondog at 6:17 PM on August 2, 2007


jonesor, after you fix your search make sure to run some system scans such as spybot and adaware... you've probably got other gunk on your system too... :-(
posted by wfrgms at 9:07 PM on August 2, 2007


« Older The impossible to find clip??   |   Identify a song in three seconds Newer »
This thread is closed to new comments.