iTunes added my new music tracks as podcast episodes, but doesn't show them under Podcasts -- how can I delete them?
July 31, 2007 4:09 AM   Subscribe

I added some new music tracks to iTunes, and for some reason it thought they were podcast episodes. So it doesn't show them under 'Music'. But it's not showing them in the 'Podcasts' library either. I've deleted the music files from the Finder, but how can I clear out the tracks from my iTunes library?

Here's exactly what happened:

1. I dragged some MP3s into iTunes (these ones, to be precise).
2. iTunes copied them to my iTunes Library folder, and started playing them...
3. ...but I couldn't find them in 'Music'. I could only see them in my 'Unplayed tracks' smart playlist.
4. I looked for them in the Finder, and saw that iTunes had put them in the 'Podcasts' folder.
5. But, in the 'Podcasts' source in iTunes, they don't show up. (I'm guessing it's because the Podcasts view groups episodes by podcast, and since these tracks aren't attached to an actual podcast, it's not showing them.)
6. I deleted the files from the Finder, but obviously this doesn't remove them from the iTunes library -- they're still listed there, with the little exclamation mark icon next to them, indicating that the files are missing.

Because I can only see the tracks in a smart playlist, and not in a true source list, there's no 'Delete' option, so I can't figure out how to remove these orphaned tracks from my library. So how can I clean them up?

(I subsequently used the ID3 tag trick from this AskMe to successfully import the files into the 'Music' section, but I'm still left with a bunch of orphaned tracks from the failed first import that I'd like to get rid of.)
posted by chrismear to Computers & Internet (5 answers total) 1 user marked this as a favorite
 
I just discovered I have the same problem (though I usually don't have an "unplayed track" smart playlist).

I suppose this is more of a "cure the symptom and not the disease" answer, but if I were you I'd just edit the smart playlist to not include tracks by "crackedpepper".
posted by Lucinda at 5:19 AM on July 31, 2007


The same thing happened to me last night; did you add the songs by dragging and dropping the folder icon into iTunes like I did?

Anyhoo, there should be a modifier key to hold down when you tell iTunes to delete the songs from a playlist. It's Option on the Mac; I'd expect it to be Alt on Windows.
posted by kimota at 5:42 AM on July 31, 2007


Option-Command-Backspace seems to have done it! Beautiful. The perfectitude of my library is restored.
posted by chrismear at 6:29 AM on July 31, 2007


Chris, if you're looking to convert a podcast to a normal track, you might want to try the AppleScript contained in Yuckandmuck's comment on this page.
posted by WCityMike at 6:14 PM on July 31, 2007


Something freaky is up with those tracks. Exact same problem here, on WinXP, except I added them with the iTunes Library Updater program. Eventually, I realized iTunes thought they were podcast episodes, and chose "convert to mp3", even though they were already mp3s. Deleted the original versions, new ones play like any other mp3. I have to say, though, completely worth the extra effort.
posted by donnagirl at 9:15 PM on July 31, 2007


« Older Navy life   |   food that takes the roof of your mouth off Newer »
This thread is closed to new comments.