musicus interruptus
July 29, 2007 10:35 AM   Subscribe

Why does every mp3 track on my laptop "break-up" for 3 seconds at the same point (with about 20 left in the track)? Does anyone else have this problem?

It's Windows Media PLayer on a Dell Insp E1505 w/Win Vista Home Prem.

thanks
posted by wfc123 to Computers & Internet (11 answers total)
 
Have you tried to play your mp3s in any other mp3 players?
Try Winamp
Are all of your mp3s from the same source, by any chance?
posted by zerokey at 11:28 AM on July 29, 2007


You may also want to get the latest drivers from Dell if you haven't done so.
posted by zerokey at 11:34 AM on July 29, 2007


Always 20 seconds from the end, regardless of how long the track actually is? Maybe that's when Media Player starts precaching the next track?
posted by rlk at 12:22 PM on July 29, 2007 [1 favorite]


They play fine in other players.

Yes always 18 to 20 seconds before.
posted by wfc123 at 4:19 PM on July 29, 2007


Yeah, sounds like it's loading the next track. Do you experience the problem if there's no playlist?
posted by krisjohn at 4:42 PM on July 29, 2007


yes
posted by wfc123 at 4:56 PM on July 29, 2007


This happens on Windows Media Center, as well.
posted by wfc123 at 5:16 PM on July 29, 2007


It might not just be loading the audio of the next track. It could be trying to look up CDDB info, or hit a website looking for an album cover. Or, for that matter, an ad targeted toward fans of the band.

I'd say nobody really knows what all Media Player does at any given moment, not even any single one of its developers. Like many pieces of MS software, it's a deep hierarchy of classes upon classes. Version updates sneak new layers in between previous layers adding features well beyond just moving from one chunk of audio to another.
posted by rlk at 7:34 PM on July 29, 2007


Thanks. I contacted Dell support and he downloaded a codec but it didn't work.
posted by wfc123 at 7:49 PM on July 29, 2007


rlk is right, that WMP is doing SOMETHING at that point. If that "something" is hard drive access and your hard drives aren't running in DMA mode for some reason, that might be it; there are lots of other, similar, driver-related things it might be.

So don't just get the latest audio drivers; get ALL the latest drivers, and make sure obvious stuff isn't broken (speed test your drives and whatnot.) Also try playing them with the network connection shut down, to rule out a net-related access making the skip happen.

Oh, and you could listen to music while watching the process list (from ctrl-alt-del menu) to see what jumps to the top when the skip happens...
posted by davejay at 11:07 PM on July 29, 2007


These steps have been resolving the issue. Follow these suggested steps :

1. Disabled the enhancement in the Control panel-> Sound-> Speaker Properties->Enhancements->Disable all Enhancements.Resolved.

2. In Media Player, click the down arrow under Now Playing and go to Enhancements. Click on Crossfading and Auto Volume Leveling. At the bottom of the Media Player, you should see that Crossfading and Auto Volume Leveling adjustments are showing. Make sure that Crossfading is off and Auto Volume Leveling is off.



3. In windows Media Player, hit ALT and go to TOOLS and the OPTIONS. Go to the Performance tab and under Network Buffering choose Buffer and change it to 1 second of content. Perhaps that might make a difference.



4. Set power management to High Performance.



5. Rollback the Sigmatel Drivers


Thanks again.
posted by wfc123 at 9:32 AM on July 30, 2007


« Older What is this addictive game structure called?   |   What does one do with an advanced degree in... Newer »
This thread is closed to new comments.