Chkdsk has eaten my computer
July 29, 2007 1:20 AM   Subscribe

My laptop started to run chkdsk, then froze, so I had to hard shut it. Now I cant get into windows XP at all. Help?

What happens is that upon startup the computer asks me if I want to start in Safe Mode, Last good settings, etc. The problem is that no matter what option I choose, it goes to the windows startup screen for about two seconds, then blue screens, then restarts and begins the whole process over again. I have since installed Ubuntu and backed up my C drive onto an external hard drive just in case. Is there any way to fix this? I dont have the windows reinstall disk, I'm pretty sure I left it in the States when I moved here last year.
posted by supercrayon to Computers & Internet (5 answers total)
Does the blue screen stick around long enough for you to see what error code it's throwing up?
posted by holgate at 1:22 AM on July 29, 2007

Response by poster: It says STOP: 0x00000024 (0x00190203 0x82BDF2E0 0xC0000102 0x00000000 ) on the bsod.

Running the hard drive self-test yields a #1-07 fail.

I've backed up the data by running Ubuntu off a Live CD, so I also have limited access to the hard disk.
posted by supercrayon at 1:34 AM on July 29, 2007

MS Knowledgebase article for troubleshooting STOP 0x00000024 errors. If you terminated chkdsk while it was doing volume repair operations, it's quite possible the MFT is borked if your volume was formatted NTFS, or that the FAT tables are screwed if it was formatted FAT or FAT32. You could try R-Studio, an excellent suite of disk recovery tools, but you're liable to be in for a long slog, with limited return on your efforts, if you are new to data recovery, even with a good tool like R-Studio.
posted by paulsc at 1:57 AM on July 29, 2007

Best answer: I had virtually the same thing happen to me about 2 weeks ago.

If you have access to another PC, download and burn a copy of the Ultimate Boot CD. Pop this in your CDROM drive and on boot up open BIOS and change the boot option to check the CDROM drive first.

Ultimate will start a facsimile of WinXP, but run entirely off the CD. Rerun the checkdisk utility and wait.... Once checkdisk has run, reboot, change BIOS settings to run off the hard drive and hopefully WinXP will start again.

This sorted out my PC, I hope it works for you.
posted by SpacemanRed at 5:12 AM on July 30, 2007

Response by poster: Thanks SpacemanRed, that fixed it up nicely! (Thanks everyone else too!)
posted by supercrayon at 7:15 PM on July 31, 2007

« Older Seeking t-shirt screenprinter who can handle a...   |   How to remove a wad of cotton stuck in my ear? Newer »
This thread is closed to new comments.