Xine stutters every 5 seconds!
July 28, 2007 12:20 PM   Subscribe

Xine stutters during playback, but Gstreamer not. Any suggestions?

Hello all.

I've just installed Ubuntu 7.04 Feisty on my computer. I'm using the integrated soundcard on my Intel DG965RY motherboard. All the sound architecture settings are on 'autodetect' in the Ubuntu control panel.

At first, there was no problem when playing movies or music using xine. But now (and I haven't done anything that I can think of to the computer to affect it) every 4-6 seconds the sound of whatever I'm playing (music, movies etc) drops out for about half a second or so. And this happens in every program that uses xine as a backend (Amarok etc).

Now, Gstreamer works fine, and I just can't work out why!

If you're wondering why I don't just use Gstreamer, there are two reasons:
1. I hate to have something suddenly stop working for no reason and not be able to work out why!
2. Amarok uses Xine and I can't work out how to get it to use Gstreamer instead. In fact, if someone could tell me how to do that, I'd be very grateful.

Thanks for your time!
posted by edbyford to Computers & Internet (4 answers total)
 
Amarok hasn't supported the gstreamer backend for a very long time so unless you want to downgrade you should just forget about using gstreamer.
posted by uandt at 6:06 PM on July 28, 2007


Try running xine from the console with verbose=1 to see if it tells you anything helpful, like:

xine --verbose=1 file.to.play.avi

I had huge problems with mplayer using mp3lib and had to force it to use libmad for stuff with mp3 audio. But a quick look seems to show that xine uses libmad anyway.
posted by markr at 4:39 AM on July 29, 2007


If it helps, I just ran Xine in verbose mode and in the log I've highlighted the line that occurs just after the sound drops out:

fixing sound card drift by -3311 pts
fixing sound card drift by -3540 pts
fixing sound card drift by -3714 pts
fixing sound card drift by -1250 pts
fixing sound card drift by -1996 pts
fixing sound card drift by -2555 pts
200 frames delivered, 0 frames skipped, 2 frames discarded
fixing sound card drift by -2982 pts
fixing sound card drift by -3308 pts
fixing sound card drift by -3539 pts
fixing sound card drift by -3712 pts
fixing sound card drift by -1253 pts
fixing sound card drift by -1998 pts
fixing sound card drift by -2545 pts
fixing sound card drift by -2999 pts
fixing sound card drift by -3306 pts
fixing sound card drift by -3538 pts
fixing sound card drift by -3709 pts
fixing sound card drift by -1253 pts


etc etc etc
posted by edbyford at 5:49 AM on July 29, 2007


From the xine site:

Audio is stuttering and i see a lot of "metronom: fixing sound card drift by -2115 pts" on the console output

Might be a soundcard problem, if it only comes in longer intervals. Your soundcard does not keep it's sampling frequency accurately enough, which results in audio and video getting out of sync and xine has to compensate. If you see the message only from time to time, you might remedy it by using the resampling sync method. You can do this by setting the configuration entry audio.synchronization.av_sync_method to resample.

If you receive the metronom message more often, maybe switching to different drivers (alsa to oss or vise-versa) can help here. It has also been reported that setting the configuration entry audio.synchronization.force_rate to the native sampling rate of your soundcard (try 44100 and 48000) helps sometimes.

Another, whole different possibility is that you have some background process running which is messing with the clock (like some ntp client - chronny, ntpd, ...).

Occasional messages of "fixing sound card drift" may happen on start and when playing a long stream (like a movie). This is normal behaviour, nothing to worry about.


So a few things to try there. Good luck.
posted by markr at 2:16 PM on July 30, 2007


« Older ABBAFilter: Has anyone done a DECENT 'hard' cover...   |   Riding the short bike. Newer »
This thread is closed to new comments.