Mac sucking the life out of our network?
July 22, 2007 11:43 AM   Subscribe

Is it possible that my MacBook Pro is sucking the life out of our home network?

My partner and I are being driven crazy by our home networking problems, which have been occurring for around two months. We have a cable internet connection with a Motorola modem, connected to a Motorola wireless router. We haven't made any hardware/settings changes in a long time, and this setup has worked for 2 years.

But now, our connection intermittently stops, roughly about once every hour. If we hard boot the modem up again, it re-boots and momentarily delivers great speeds, then slows down and eventually quits again. The internet connection itself is incredibly slow, much slower than the 2.5MB connection we're supposed to have.

We've phoned support multiple times and had the line replaced and engineers checking things out, but nothing has solved the problem. The only explanation one engineer had was that we were getting "power spikes" that shut down the modem, but no engineers could confirm this.

On our last call (now charged at .25/min, thanks Virgin!), they insisted that the problem must be with my Macbook -- when my partner connected his XP laptop to the modem, he got download speeds of 2-2.5 MB, when i connected mine, i got download speeds of 750b. We further tested this by testing my partner's laptop on the network alone, then with my machine also connected. His download speeds went from 2-2.5 to about 140b, and mine was about 3-400b. The tech guy suggested I had a Trojan, and refused to help us beyond that. I've scanned my machine with MacScan and it claims i'm green. That leads me to two questions:

1) What's going on here!? Is it possible for my machine to be sucking bandwidth? If not, what else could be the cause?

2) How can I identify any programs that may be repeatedly accessing the internet on my Mac? I've downloaded a ton of "traffic monitoring" applications, but they all list overall network consumption, not broken down by applications.

Additional information: I switched on the OS X firewall, closed everything but Firefox and restricted everything but basic internet and nothing changed. I don't have any Bittorrent/P2P apps running, we're in the UK using Virgin, and there's not a lot of options to switch.
posted by ukdanae to Technology (16 answers total) 6 users marked this as a favorite
 
I got a MacBook about a month ago and ever since I've been having the same problems with my network. I've been doing a hard reset on my Netgear router everytime it happens and I get similar results.
posted by studentbaker at 12:11 PM on July 22, 2007


When you're connected with your MacBook Pro, can you open up the Terminal application (Application > Utilities > Terminal) and report back the output from the following two commands:

netstat | grep udp4
netstat | grep tcp4

This will tell us what types of traffic are going across your wireless adapter.
posted by Blazecock Pileon at 12:11 PM on July 22, 2007 [1 favorite]


Hi Blazecock, thanks for helping:

netstat | grep udp4
udp4 0 0 *.* *.*
udp4 0 0 *.mdns *.*
udp4 0 0 *.mdns *.*
udp4 0 0 *.mdns *.*
udp4 0 0 192.168.10.6.56016 *.*
udp4 0 0 *.* *.*
udp4 0 0 *.* *.*
udp4 0 0 *.ipp *.*
udp4 0 0 localhost.49169 localhost.1022
udp4 0 0 localhost.49168 localhost.1022
udp4 0 0 localhost.1022 *.*
udp4 0 0 localhost.49165 localhost.1023
udp4 0 0 localhost.1023 *.*
udp4 0 0 192.168.10.6.ntp *.*
udp4 0 0 localhost.ntp *.*
udp4 0 0 *.ntp *.*
udp4 0 0 *.mdns *.*
udp4 0 0 localhost.netinfo-loca *.*

netstat | grep tcp4
tcp4 0 0 192.168.10.6.63049 mg-in-f18.google.https ESTABLISHED
tcp4 0 0 192.168.10.6.63046 66.102.11.99.http ESTABLISHED
tcp4 0 0 192.168.10.6.63030 el-in-f91.google.http ESTABLISHED
tcp4 0 0 192.168.10.6.63005 apache2-bongo.tr.ftp ESTABLISHED
tcp4 68 0 192.168.10.6.62913 apache2-bongo.tr.ftp CLOSE_WAIT
tcp4 0 66608 192.168.10.6.61955 code42.com.https ESTABLISHED
tcp4 0 0 192.168.10.6.61904 161.208-100-1.no.http ESTABLISHED
tcp4 0 0 localhost.netinfo-loca localhost.975 ESTABLISHED
tcp4 0 0 localhost.975 localhost.netinfo-loca ESTABLISHED
tcp4 0 0 localhost.ipulse-ics localhost.49158 ESTABLISHED
tcp4 0 0 localhost.49158 localhost.ipulse-ics ESTABLISHED
tcp4 0 0 localhost.ipulse-ics localhost.49157 ESTABLISHED
tcp4 0 0 localhost.49157 localhost.ipulse-ics ESTABLISHED
tcp4 0 0 localhost.ipulse-ics localhost.49156 ESTABLISHED
tcp4 0 0 localhost.49156 localhost.ipulse-ics ESTABLISHED
tcp4 0 0 localhost.netinfo-loca localhost.1021 ESTABLISHED
tcp4 0 0 localhost.1021 localhost.netinfo-loca ESTABLISHED

studentbaker, glad to hear it's not just me!
posted by ukdanae at 12:32 PM on July 22, 2007


The apache2-bongo.tr connections look suspicious - were you using ftp to that host at the time you ran the netstat command?
posted by aberrant at 12:38 PM on July 22, 2007


(unless that hostname's been truncated to 16 bytes, which I suspect. In any case, worth checking.)
posted by aberrant at 12:40 PM on July 22, 2007


I have the same problem with my iBook G4.
posted by smorange at 12:45 PM on July 22, 2007


Same problem with my Powermac G4! Any insight would be much appreciated.
posted by limeonaire at 12:46 PM on July 22, 2007


Your post spurred my curiosity so I went searching and found this thread a macosxhints.com. I'm a novice when it comes to networking but I'll let you know if it works for me.
posted by studentbaker at 12:58 PM on July 22, 2007


apache2-bongo.tr seems to connected with Dreamhost. Perhaps ukdanae has an account with Dreamhost?
posted by Blazecock Pileon at 1:29 PM on July 22, 2007


That's right, Blazecock -- forgot to close my FTP before taking the settings :-)
posted by ukdanae at 1:31 PM on July 22, 2007


I was having similar problems - it was related to WPA2 / TKIP - the mac was getting screwed up with tkip key regeneration. Switching to AES solved the issue for me. I don't know what your wireless security settings are, but you might want to check.
posted by aberrant at 2:05 PM on July 22, 2007


Basically, ukdanae, from the netstat data I think you can reasonably rule out a bot or other unwanted process running on your computer that is causing your network service provider to ramp down your connection speeds.

More likely is that the wireless router is the culprit, as it connects both your MBP and the Windows laptop to your network connection, and both devices are afflicted with speed loss.

Make sure your MBP has the latest Airport firmware.

Aberrant's suggestion is worth trying: open your Motorola wireless router settings page and turn off the security method temporarily, to see if the speed improves.

Another troubleshooting method is to plug in a friend's wireless router into your Motorola modem, temporarily replacing the Motorola wireless router.

If your connection speeds improve, the problem is with the wireless router. Reset the router, choose a different security method, or update the router's firmware.

There are other tuning possibilities, but these should not have to be done if the equipment is interoperating properly.
posted by Blazecock Pileon at 2:57 PM on July 22, 2007


I've gone away and read studentbaker's link, and have been trying all the recommended things. Here's what i've learned:

* Unlike some in the forum link, I don't think my problem is packet loss. I pinged my router a few times and got 0% loss. My router is in 802.11g mode only (the highest it supports)

* On quite a few instances, my initial speed after changes was in the 1.5MB range, but on a refresh went down to 700-800kbps. I'm using Internet Frog to test speeds.

* Switching from TKIP to AES didn't work, sadly.

* Changing my DNS doesn't seem to have any huge difference -- an OpenDNS yielded speeds of 732kbps, and the Virgin DNS's on this page was 873kbps. I'm changing the DNS in both Airport preferences and on the router itself.

I'm currently running at an improved 1.1-1.5mbps speed, but that's without my partner's laptop online, so I don't think i've quite cracked it!

All these changes worked for somebody else on that forum, so if you're having the same trouble as me I recommend trying them out.
posted by ukdanae at 3:09 PM on July 22, 2007


waitasec - are you both running at 802.11g or 802.11n? Using mixed machines - or, in some cases, having the access point configured to allow mixed machines - can affect performance.
posted by aberrant at 3:40 PM on July 22, 2007


aberrant, my router is running at 802.11g (it ony does b or g) -- how do i check what my laptop is running?
posted by ukdanae at 12:26 AM on July 23, 2007


We've been having similar problems since I got my new MacBook a few months ago.
posted by exquisite_deluxe at 7:01 AM on July 23, 2007


« Older Why do the pages to some hardback books have...   |   What was that high-school football documentary... Newer »
This thread is closed to new comments.