Safari status bar problem (and one more Mac problem, too)
July 19, 2007 8:01 PM   Subscribe

My old G4 iMac is suddenly doing two things differently, and I don't know why or how to get it back the way it used to work.

1. Using Safari, moused-over links no longer show in the status bar. (They show up fine using Firefox.) I can make them appear by pressing the control key (or the command key) for each link I move to - but I want them to just show automatically, like they did before.

2. When I launch a new application, the window appears below any one I have open, instead of on top as it used to.

I'm on the latest version of OS/X.
posted by jeri to Computers & Internet (1 answer total)
 
I would recommend following the advice from macOSXhints.com.

The user says he fixed his issue by removing all the preferences and then adding them all back in slowly. Another user in the same thread notes that it only happens when his 3-rd party mouse is plugged in. If you are still at a lose, I would encourage you to use this search query from http://google.com/mac

hayne
10-05-2006, 11:15 AM
Here's my generic prescription for user-specific problems:
----------------------------------
You have determined that the problem is only with the one user account.
The problem thus is almost certainly due to something under your home folder.
And it likely is something under ~/Library
( ~ = your home folder)
The most likely thing is a bad preference file under ~/Library/Preferences
You could start by removing the preference files for the apps you are having trouble with.
If the problem persists, you need to narrow the problem down - you could start by moving (via drag & drop) the whole "Preferences" folder that is under ~/Library to the Desktop, then log out and log in again. A default copy of the Preferences folder will have been recreated. Does that improve things? If so, you could use a divide & conquer approach to figure out which of the preference files is causing the problem - move half of the preference files back into the Preferences folder, log out & in again, etc.

If the problem persists, try the same thing with the other sub-folders of ~/Library. E.g. with ~/Library/Caches, ~/Library/InputManagers, ~/Library/Fonts, ~/Library/PreferencePanes, ~/Library/Application Support, ~/Library/Application Enhancers, contents of ~/Desktop, etc.
Also remove any files owned by your user in /Library/Caches (the Library folder at the top-level of the drive) or the sub-folders of /Library/Caches (e.g. the font caches under /Library/Caches/com.apple.ATS)

spookmonkey
10-05-2006, 11:49 AM
Well, I fixed it, but I'm not sure how.

I cleared out the Preferences folder, logged out, then back in, and it was working correctly again. So, I began copying the old preference files back in, in groups of ten, logging out then logging back in each time.

Eventually, I had copied back in all of my old preferences, and after logging out, then logging back in multiple times, everything was still working correctly again.

So, thanks for the help, as something in that preferences folder apparently needed to be tweaked. What, I don't know. But thanks again.

posted by B(oYo)BIES at 8:43 PM on July 19, 2007


« Older [AustinFilter] What are your favorite places to...   |   What's the name of the piece of music at 12:29 in... Newer »
This thread is closed to new comments.