Linux newb here!....
July 9, 2007 2:25 PM   Subscribe

AVI,MPG,WMV video files will only play sound but no video (with the exception of Web based Flash videos like YouTube....they play fine!!??) on my Dell latitude D620 running Feisty Fawn 7.04 when playing to external 1708FP Dell LCD monitor....why?? (see explanation)

Whether I'm using VLC or the built in Movie Player same result but when I play to the default screen on my laptop they play fine. Can't seem to find any drivers for Dell LCD monitor or screen settings other than resolution that might affect video playback....weird.

Any help would be, I haven't posted here in a long time...but I'm glad it's here when I need it...
posted by stevyb to Computers & Internet (6 answers total) 1 user marked this as a favorite
What player are you trying to watch the videos in? Do you know what codec the videos are encoded with?
posted by rancidchickn at 2:29 PM on July 9, 2007

Response by poster: Like I said in my explanation....VLC or Movie Player...and no, I don't know which codec they're encoded with (they're all kinds of videos)...but the problem is ONLY when I output to the LCD 1708FP Dell monitor....not when I play to the laptop screen....
posted by stevyb at 2:33 PM on July 9, 2007

Best answer: Well, the others are probably fine video players too, but you might try MPlayer, which is the one I've always used. "mplayer -vo x11" will almost certainly work. So if you just want to play videos, "vo=x11" in ~/.mplayer/config should do it.

Next thing to try would be replacing your video driver, which can be an amusing challenge if it happens to be hardware that's not well-supported.
posted by sfenders at 3:54 PM on July 9, 2007

You probably want to look here because you're almost certainly missing the video codecs and will need to install them
posted by singingfish at 5:50 PM on July 9, 2007

Best answer: If they play on the notebook's screen - but not the external monitor - I'd bet it's an overlay issue - not a codec problem. sfenders is probably pointing you in the right direction.
posted by unmake at 8:46 AM on July 10, 2007

Response by poster: Thanks guys that did it.... I installed Mplayer and it looks like a cool video player too....but I found the video output settings in VLC and set it to X11...and voila! Thanks sfenders!
posted by stevyb at 9:33 AM on July 10, 2007

« Older Is it ok to keep posing as a virgin?   |   Give me the job already, dammit! Newer »
This thread is closed to new comments.