Trying to figure out a WAP gateway problem
May 30, 2007 6:01 PM   Subscribe

Why is it that my WiFi doesn't work unless I go to TCP IP Settings > Advanced and delete the Default Gateway?

Every day I have to take my laptop computer back and forth between a Linksys WAP and a Linksys WAP combo Ethernet-WAP, both of which are connected to the same 8-port router. I have no trouble connecting to either of the WAPs but I sometimes have trouble getting my Internets to work.

I can unplug the card and reboot my computer all I like to no avail, and I'll be connected to the WAP but not to the Internet. The one thing that is guaranteed to make things start working is to delete the default gateway in Networking > TCP IP configuration. After I delete this, the Internet comes up in 2 seconds. Windows always sticks in there when I'm done but the connection works. If I look at Linksys > Link Information I can see that one WAP does use a gateway of and the other of

From what I've seen my Internet only gets stuck if my laptop goes into Standby mode.

If there is no good explanation, then teach me to fish... are there any good tutorials that will help me wrap my head around gateways, routers, bridges, and that kind of thing without assuming I have a graduate-level understanding of networking?
posted by zek to Computers & Internet (5 answers total) 1 user marked this as a favorite
I don't know if this is really an answer to your question, but I think the reason why deleting the gateway address fixes things, is because your computer can get the correct gateway address from DHCP.

So what I think happens, is you go to one network, where the gateway is, and your computer gets all the settings from DHCP, and works fine.

Then you go to the other network, and it fails because it still has the old settings in it. But when you clear the old default gateway, it discovers the correct address, via DHCP.

Personally I think the solution might be to use some type of software that lets you have various 'profiles,' e.g., "Home" and "Work," with different network settings for each, and switch back and forth between them. (I have vendor-supplied software on my Windows notebook that does this, but I thought that stock WinXP does it somehow...?) If you just configure each profile manually, and include the correct gateways, you ought to be able to switch from one to the other and not have to retype or configure anything.
posted by Kadin2048 at 6:35 PM on May 30, 2007

Well, I'm using Windows 2000 if that makes a difference... I suppose XP might handle this more gracefully.
posted by zek at 6:40 PM on May 30, 2007

You're correct, Windows 2000 isn't as graceful about renewing IP settings (especially wireless ones) from one network to another.

As a quick fix, try running these commands from the Start/Run box (or start/run/cmd, then type them in manually) when you lose your connection:

ipconfig /release

ipconfig /renew

This will refresh your IP address from the DHCP server (whichever one is available).
posted by disclaimer at 7:14 PM on May 30, 2007

For a quicker quick fix:

  • If you go to Network Connections and right click on your wireless card, then select 'Repair', I think it will do the same thing as what disclaimer suggests.

  • You can also right click on your wireless connection from your systray, if it's there.

    I was looking around in 'TCP IP Settings > Advanced' and I see an option for multiple default gateways (in XP). Is that there in 2000 also?

    Another difference I see is that I don't have ANY default gateways listed. If that's not a difference in Windows versions, then maybe you have some sort of auto-setup software installed?
    posted by philomathoholic at 9:15 PM on May 30, 2007

    You can also disable DHCP on one of the WAPs (the one that hands out the wrong default gateway). Or just manually input the correct gateway in your IP address settings.
    posted by Burhanistan at 10:00 PM on May 30, 2007

    « Older [ArabicFilter] لكن vs لكنَّ: I still don't get the...   |   Drum n Bass in a major key? Newer »
    This thread is closed to new comments.