hosts file broke my Internet
May 24, 2007 3:08 AM   Subscribe

The hosts file on my Windows machine seems to have broken the Internets...

When Metafilter made the change to new IP addresses, a good samaritan showed me how to change the hosts file in C:\WINDOWS\system32\drivers\etc so I would not have to wait for the change to register.

It worked beautifully when I was in Afghanistan. My hosts file has this in it:

127.0.0.1 localhost

74.53.68.130 metafilter.com
74.53.68.130 www.metafilter.com
74.53.68.130 ask.metafilter.com
74.53.68.130 metatalk.metafilter.com
74.53.68.130 music.metafilter.com
74.53.68.130 projects.metafilter.com

Now I am in Bishkek, on my friend's wireless network, and everything EXCEPT Metafilter times out. If I mem out the above Metafilter lines, Metafilter also times out and won't load.

I know the actual network connection is good because Metafilter will load (when those lines are in the hosts file), and the googletalk program fetches my email headers, my antivirus auto-downloads its updates, etc.

I would love to solve this stupid problem myself, but as it is I can only connect to you nice people, no google, no email... please help me?
posted by Meatbomb to Computers & Internet (11 answers total) 1 user marked this as a favorite
 
It's not the hosts file. Your machine can't find a DNS server, so metafilter's the only thing left working (you've "hardcoded" meatfilter IPs so you don't need to look them up).

Start->Settings->Network Connections
Right-click your active connection
Properties
Internet Protocol (TCP/IP)
Properties
General

Is "Obtain DNS server address automatically" set?

(If not, try setting it. If yes, someone will be along in a minute with an open DNS server you can plug in).
posted by Leon at 3:25 AM on May 24, 2007


Oh! And if there's currently an IP address for a server set, write it down just in case.
posted by Leon at 3:28 AM on May 24, 2007


Meatbomb! I just clicked your profile a few minutes ago, wondering where you'd been for the past month. Welcome back to the internet!

You might want to look at this MetaTalk thread and this AskMe. I can't say for sure whether they're relevant, but they feel relevant. Good luck!
posted by cgc373 at 3:35 AM on May 24, 2007


Leon: yes, my automatic DNS server box is checked. You sounded like you had the easy fix, but sadly that is not it. Thanks anyways though.
posted by Meatbomb at 3:47 AM on May 24, 2007


Definitely sounds like DNS isn't working; you could try switching to OpenDNS (there are guides on the site) to see if that solves it.
posted by malevolent at 3:49 AM on May 24, 2007 [1 favorite]


Could be that the network you're connected to isn't offering you DNS. The fact that googletalk/AV are working is weird; maybe they connect to IPs.

For diagnostics, try this for us:

Run a Command Prompt. Type:

ipconfig /all

What do you get back? You should get a line like this:

DNS Servers . . . . . : 192.168.0.254

If you don't, then I'm sure that's the problem.
posted by Leon at 4:02 AM on May 24, 2007


Something to get you to Google and it's cache, at least, so you can do some searching of your own. Add this to your hosts file:

66.102.9.99 www.google.com
posted by Leon at 4:06 AM on May 24, 2007


As has been mentioned, your hosts file has saved you. One more thing to try is just setting your gateway IP as a DNS server. It may relay DNS.

Apologies for the ugliness, but here are a bunch of publicly accessible DNS servers:

ns1.de.opennic.glue (Cologne, DE)
217.115.138.24
ns1.jp.opennic.glue (Tokyo, JP)
219.127.89.34
ns2.jp.opennic.glue (Tokyo, JP)
219.127.89.37
ns1.nz.opennic.glue (Auckland, NZ)
202.89.131.4
ns1.uk.opennic.glue (London, UK)
194.164.6.112
ns1.phx.us.opennic.glue (Phoenix, AZ, US)
63.226.12.96
ns1.sfo.us.opennic.glue (San Francisco, CA, US)
64.151.103.120
ns1.co.us.opennic.glue (Longmont, CO, US)
216.87.84.209
ns1.ca.us.opennic.glue (Los Angeles, CA, US)
67.102.133.222
bigguy.gte.net
206.124.64.1
ns1.granitecanyon.com
205.166.226.38
ns2.granitecanyon.com
69.67.108.10
nl.public.rootfix.net - Nederlands
199.166.29.3
NS1.QUASAR.NET - Orlando, FL, USA
199.166.31.3
SpeakEasy Nameservers
66.93.87.2
216.231.41.2
216.254.95.2
64.81.45.2
64.81.111.2
64.81.127.2
64.81.79.2
64.81.159.2
66.92.64.2
66.92.224.2
66.92.159.2
64.81.79.2
64.81.159.2
64.81.127.2
64.81.45.2
216.27.175.2
66.92.159.2
66.93.87.2
Sprintlink General DNS
204.117.214.10
199.2.252.10
204.97.212.10
Cisco
128.107.241.185
192.135.250.69
ns1.mailworx.net
69.1.200.68
usenet.net.nz
202.49.59.6
zbasel.fortytwo.ch
193.138.215.60
ns.second-ns.de
213.133.105.2
ns2.your-server.de
213.133.106.251
posted by pompomtom at 4:39 AM on May 24, 2007 [1 favorite]


DING DING DING!! We have a winner!!

Thank you very much malevolent, that did the trick. pompomtom, you get best answer too, as that stuff you provided would have worked, if my problem had not already been solved.

And to all the other contestants, thanks for playing. We are all winners today.
posted by Meatbomb at 4:48 AM on May 24, 2007


No worries.

Last time I moved ISP I ended up stuck for a while without DNS and it shat me to tears (I just rang a friend in the end).

I'm impressed that your dedication to mefi allowed you a little keyhole view of the name-space.
posted by pompomtom at 5:02 AM on May 24, 2007


pompomtom: nice resource

The ones I use when I'm stuck in a situation like this are 4.2.2.1, 4.2.2.2 and 4.2.2.3. If anyone has got a more memorable set of IPs, I'd like to hear it.
posted by lodev at 5:30 AM on May 24, 2007 [1 favorite]


« Older Red screens of death even without Vista   |   Can you recommend a book on small group leadership... Newer »
This thread is closed to new comments.