More than 2 IE7 connections?
May 22, 2007 9:21 PM   Subscribe

How do I make IE7 use more than 2 connections at once?

I finally bit the bullet and upgraded to IE7, and now that I'm used to it I do like it. But there's one aspect of it that drives me nuts: IE7 won't open more than two connections at a time total among all my tabs, no matter what they're connected to.

I have a cable modem which is connected to one of the ethernet ports on my Linux server. The other ethernet port on the server is on my LAN, and my computer connects to that. All of my web browsing is done using my server as a proxy. (And NAT.)

With IE6 there were registry patches you could make which would increase the number of connections it would use. I found one place online that recommended this for IE7:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings]

A value of 10 seemed excessive to me so I set it to 6. Result: no change at all. If I have two downloads going I can't access anything else online.

Anyone know what I can do to correct this? It's not an inherent aspect of my system; Firefox uses more connections simultaneously, and so did IE6 before I upgraded. (Do not suggest "Switch to Firefox". I use them both, and there are times and places where IE7 is the better solution for me.)

My suspicion is that IE7 is treating the entire web as a single server because of my proxy. The question is what can be done about increasing the number of connections it's willing to make to my proxy.
posted by Steven C. Den Beste to Computers & Internet (3 answers total) 2 users marked this as a favorite
Perhaps this.
posted by Good Brain at 9:45 PM on May 22, 2007

I think your hex value is wrong. Try

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings]

10 TCP/IP connections in your circumstances is fine.
posted by paulsc at 9:47 PM on May 22, 2007

Thank you; that did it. The difference seems to be HKEY_CURRENT_USER instead of HKEY_LOCAL_MACHINE.

Visiting CNN now, Proxomitron sometimes showed 10 connections open at once. MUCH better...
posted by Steven C. Den Beste at 9:57 PM on May 22, 2007

« Older DROD help   |   Teeth slanting inward Newer »
This thread is closed to new comments.