Why does my router hate you so much?
May 11, 2007 6:38 AM   Subscribe

Networking mystery! My router hates one site on the Internet: MetaFilter. Why?

Here's a stumper: my wireless router will let me access every site on the Internet, except one: MeFi.

After MeFi changed servers (and, I'm presuming, IPs) a few months back, I suddenly found myself unable to access it. My browser would appear to do the DNS lookup and "find" MeFi, but then the loading process would just hang. The page would never appear.

It wasn't my computer's fault; I could reach it from other people's networks. It wasn't my ISP's fault; I get my DSL from a small outfit that, believe it or not, has a human answer the phone on the second ring - and that human was willing to tool around because one subscriber can't see one website. It wasn't my IP address getting blocked, since I've been assigned several new ones.

In the end, the culprit seems to be my wireless router: when I connect my computer straight to my modem, I can connect. I figured that resetting the router would solve the problem, but no: it's adamant that MeFi is out.

Now, this isn't a pressing support question, since it's an old clunker (a US Robotics USR8054 802.11g) I picked up for $25 a year ago, and I'm going to replace it anyway. But I'd be really interested if anyone has any ideas as to why a router would hold such a peculiar grudge?
posted by bicyclefish to Computers & Internet (4 answers total) 1 user marked this as a favorite
Seen this?
posted by edd at 6:43 AM on May 11, 2007

It's not the Blue and Green, as noted in the above referenced thread it's a battle between PMTUD (Path MTU Discovery), your MTU size and possibly, hopefully not, the MSS. Generally if you have MSS problems you'll have SSL break left and right.

Update your wireless router's firmware, or purchase a new one. More than likely you've got a bug or some problem with PMTUD.
posted by iamabot at 11:20 AM on May 11, 2007

Best answer: For starters I'd try upgrading the router to the latest firmware (Version 1.67b44 (125 Mbps Update), available here).

If that doesn't work, changing your computer's settings to use a smaller MTU (MeFi seems to reject anything bigger than 1472, don't ask me why) may solve the issue, although I think this solution is ugly.

The source of the problem is that MeFi dislikes big packets (large MTUs). This would be OK in most circumstances, since there's a protocol for dealing with that, called "Path MTU Discovery," which uses ICMP packets to tell a client (you) when the packets it's sending are too big and need to be broken up into smaller pieces. However, if some computer in the chain -- namely your router -- discards these ICMP packets (which some do, for various historical reasons), then your computer never knows to step down the MTU size.

So hopefully, if it's your router that's causing the problem by throwing away the ICMP packets, updating the firmware will fix this misbehavior and solve the issue. If it doesn't, and you don't want to get a new router, dropping the MTU size will probably fix it. But I would not do this permanently, because there's a chance that having an MTU that's smaller than it needs to be could adversely impact performance, because they increase the amount of overhead for a given quantity of data transmitted.
posted by Kadin2048 at 1:01 PM on May 11, 2007

Try to use TOR as a go-between? This might also help you trouble shoot your network.
posted by acro at 2:14 PM on May 11, 2007

« Older Vertical Lego Robot   |   "eleven" in Aramaic? Newer »
This thread is closed to new comments.