Photoshop Typography Woes
May 10, 2007 10:59 AM   Subscribe

Why does type always look terrible in Photoshop CS2?

It seems like whenever I put type into something in Photoshop, it always has very strange and inconsistent spacing. There will be giant spaces between some letters and others will be pushed right up next to each other. I've tried resetting the type dialog to defaults, but that didn't seem to help, and anything else I do seems to make it worse.

Any suggestions?
posted by deansfurniture5 to Computers & Internet (9 answers total) 2 users marked this as a favorite
 
Best answer: Try resetting the kerning to Metrics in the Character palette?

Unjustify the text?

Or go to the flyout menu for the pharagraph and character palettes and reset them. The type preset is more of a styles dialog, so nuking these other dialogs might help.
posted by cowbellemoo at 11:13 AM on May 10, 2007


Does this happen with every font you use? You might experience this with poorly crafted free/shareware fonts, usually TrueType, where the authors don't bother to create proper hinting and other built-in spacing mechanisms to ensure the type has an acceptable default appearance.
posted by wubbie at 11:37 AM on May 10, 2007


See at the top where it says None, Sharp, Crisp, Strong, Smooth? Try Strong.
posted by paulinsanjuan at 11:38 AM on May 10, 2007


Best answer: Does this happen with every font you use? You might experience this with poorly crafted free/shareware fonts, usually TrueType, where the authors don't bother to create proper hinting and other built-in spacing mechanisms to ensure the type has an acceptable default appearance.

If this is the case, kern using optics. That has PS look at the geometry itself to fit characters together.


See at the top where it says None, Sharp, Crisp, Strong, Smooth? Try Strong.

This is likely to matter if the resolution is very very small (like with web banners). Anything but 'none' will feather the edges across pixels instead of 'rounding' or snapping the edge to the nearest pixel.

There are many many possibilities. A screenshot or more information would help a great deal.
posted by cowbellemoo at 11:46 AM on May 10, 2007 [1 favorite]


If none of the above, one quirk about Photoshop is that it renders a lot of things "incorrectly" at odd zoom levels - that is, 25%, 50%, 12.5%, etc tend to look better than 33.3%, etc. But you've probably checked that out already?
posted by tmcw at 1:24 PM on May 10, 2007


Why does type always look terrible in Photoshop CS2?

Because Photoshop isn't a typesetting program. Sorry, but it's true. Photoshop's type controls are rudimentary at best when compared to Illustrator (good) or InDesign (best).

However, there are some things that Photoshop can do that Illustrator and InDesign can't. If you have either Illustrator or InDesign, I'd suggest setting your type there, converting to outlines, exporting as an eps, and importing the resultant eps into Photoshop for any final rendering you need to do.
posted by lekvar at 2:02 PM on May 10, 2007


Just coming here to suggest using Illustrator, which is far better at managing fonts. Or, what lekvar said.
posted by Lynsey at 2:28 PM on May 10, 2007


Are you sure is not an zooming issue? When an image is zoomed Photoshop tends to have problems escaling vector stuff.
posted by Memo at 2:39 PM on May 10, 2007


Response by poster: Alright, it seems like the core problem was that the paragraph menu was not reset (although when I went ahead and reset it, no settings seemed to change, but the type looked 10x better)

Thanks for all your help!
posted by deansfurniture5 at 6:08 PM on May 10, 2007


« Older Collaborative document writing   |   What should I look for in homeowner's insurance? Newer »
This thread is closed to new comments.