Google Redirects
March 31, 2004 11:20 AM   Subscribe

Has Google permanently gone into redirect mode? Seems to me that prior to the redesign, a result link was usually a link directly to the result site, and only occasionally did they go into "link goes to google with a redirect to the search result site" mode. Now it seems like all result links are like that. More inside.

I'll give you an example. On one search, instead of the result link going to

"http://www.webmasterworld.com/forum81/2221.htm"
it goes to
"http://www.google.com/url?sa=U&start=1&q=http://www.webmasterworld.com/forum81/2221.htm&e=7417".

Now, a lot of search and directory sites do this: it allows them to track your click-throughs. But the bad thing about this is now you have to contend with more latency -- that is, how slow Google's server response is, and then how slow the response of the result site is. It basically sucks and I'd like to turn it off, but Google preferences don't seem to let you control this. I used to run Proximotron which lets you do mediate your web browsing and programmatically rewrite obnoxious things like this but I move between too many computers for that to really be an option. (And besides, Proxomitron's no longer distributed.) Is everyone getting this now?
posted by George_Spiggott to Computers & Internet (4 answers total)
 
I'm still getting direct hrefs. I'm in the USA, and using Firefox. I guess, to try to figure this out, you need to give a bit more info about where your ISP is located, exactly how you're doing the search and so on. I remember hearing awhile ago that Google would randomly do redirect links ever so often, but I've never gotten one as far as I know.
posted by skynxnex at 11:37 AM on March 31, 2004


I've had it happen occassionally, but not yet with the new interface.
posted by fvw at 11:38 AM on March 31, 2004


Try deleting all cookies stored in your browser by Google. I noticed the redirection back when they were still beta testing the new look, and was similarly annoyed, but found that deleting the cookie they used to store the "show this user the beta interface" solved the issue.

I'm not seeing any redirection now that the new interface has been launched, so you may want to try deleting said cookies.
posted by Danelope at 11:40 AM on March 31, 2004


Danelope -- embarrassingly, it was as simple as that. I didn't suspect that cookies might be involved because I've been getting it on a variety of computers and at least two different browsers. But clearing them did the trick. Still, this page may come up on a search when someone's trying to resolve this issue, so I'm glad I asked.
posted by George_Spiggott at 11:47 AM on March 31, 2004


« Older I Swear...   |   What's the best site to backorder a domain name? Newer »
This thread is closed to new comments.