Meta-meta Mac trouble
May 4, 2007 7:58 AM   Subscribe

Why can't I get to Metafilter any more?

I've got a network problem that has me stumped. At home, I have 4 computers, 2 are PCs, 2 are Macs. (Yes, the computers outnumber the people 2 to 1 in my house. I'm a huge nerd). All of the computers connect to the Internet via the same wireless router. 1 Mac and 1 PC are connected directly to the router via ethernet, the other Mac and PC connect wirelessly. The network is Verizon's FiOS.

Neither of the Macs are able to load any of the metafilter.com sites anymore: www, ask, metatalk. They were able to load as of a few weeks ago, then just stopped. I didn't install any patches in that timeframe.
It doesn't matter what web browser I use, Firefox, Safari, Opera, Camino, even Lynx, all are unable to load anything coming from metafilter.com. The PCs load everything normally.

When I try to access metafilter, the browser seems to make its connection, then the status bar just keeps displaying "Waiting for metafilter.com". The connection will eventually time out after 10 minutes or so. I am able to load the site if I go through a third party site, such as proxify.com.

I've checked every TCPIP setting I can think of, no dice. I even added metafilter to my hosts file thinking it was a simple DNS problem, with no luck.

I'm pretty much out of ideas at this point. What am I missing?
posted by Eddie Mars to Computers & Internet (20 answers total) 4 users marked this as a favorite
 
can you 'ping metafilter.com' from the terminal?

can you 'traceroute metafilter.com' from the terminal?

can you 'host metafilter.com' from the terminal?

(I get curious results with traceroute)


post the results here
posted by unSane at 8:08 AM on May 4, 2007


Just a few more points:
The Macs are able to load every other site on the Internet I've tried...just not anything from metafilter.com. DHCP assigns the router as the DNS server, in my case 192.168.1.1. I've changed this to the actual Verizon DNS servers, but still had the same problem: *.metafilter.com won't load, everything else will. Pinging www.metafilter.com returns the same address from both Mac and PC, so I'm pretty sure this isn't DNS causing the problem.
I've tried turning IPv6 on and off with no effect.
posted by Eddie Mars at 8:09 AM on May 4, 2007


miss lynnster, I thought about Metatalk, but since this is only affecting some of my machines, I have to assume that it is my fault and not Matt's.

unSane, tried Ping, as I've indicated above. I'm at work now (which is why I'm able to post!), but I'll try traceroute and host when I get home.
posted by Eddie Mars at 8:13 AM on May 4, 2007


I had the same problem. The solution was to change my MTU setting from 1492 to 1500. I have absolutely no idea why this worked, but it did. In my case, it was a Windows PC that could connect, and Linux PC that couldn't. I put

ifconfig wlan0 mtu 1500

in my /etc/rc.local file. I don't know what the Mac equivalent for this is, but perhaps somebody else will.
posted by hoverboards don't work on water at 8:16 AM on May 4, 2007 [1 favorite]


If ping and traceroute look normal, try:
% curl -I http://www.metafilter.com
Which should produce output similar to this:
HTTP/1.1 200 OK
Date: Fri, 04 May 2007 15:15:18 GMT
Server: Apache/2.0.59 (Win32) JRun/4.0
Content-Language: en-US
Vary: User-Agent
Content-Type: text/html; charset=UTF-8

posted by ijoshua at 8:16 AM on May 4, 2007


OK, do this.

Download Interarchy and fire it up in demo mode.

Close all your internet apps except Safari, with no page open.

Choose File>Net>Traffic

Click settings and choose the HTTP filter

Now open a blank window in Safari and type Metafilter.com

Look at the HTTP traffic -- what do you see?
posted by unSane at 8:18 AM on May 4, 2007


also seconding checking the MTU settings. Verizon FiOS requires a setting of 1492. If your Router is configured to do this automagically, it could be wrong. Try setting it to 1492 manually.
posted by unSane at 8:20 AM on May 4, 2007


If you're on Windows, go to Start > Run > "cmd.exe" and then type
"nslookup metafilter.com".

If you're on a Mac, go to run Terminal and then type "nslookup
metafilter.com".

Post your results.

Also, if you've ever edited your HOSTS file (if you know what that means, you probably have) make sure you don't have metafilter.com pointed at the old IP.
posted by mathowie at 10:42 AM on May 4, 2007


It's down to your MTU. If it's set to too small a value (seemingly anything under 1480), then Metafilter is a no-go. You should be able to change the MTU in your router setup page. You might have to change it on your PCs too, although my Mac seems to learn the MTU value from the router and set it to match. It's no good setting it on your computers without changing your router–the router is what matters.

I had this problem for two weeks until I figured it out, during which Metafilter's banner loaded but nothing else. Other sites worked fine. I figured the site was borked.

Apparently it's something to do with an overly sensitive firewall on the Metafilter server (I believe it's a Microsoft shop), and a response to requesting too many packets, or perhaps receiving too many packet fragments. A correct MTU means you request fewer packets.

They ought to fix it.
posted by humblepigeon at 10:48 AM on May 4, 2007 [1 favorite]


Incidentally, set your MTU to 1,500 and see what happens.
posted by humblepigeon at 10:49 AM on May 4, 2007


Shortly after the site switched over to the new servers I had the same problem on my mac boxes. Oddly enough, I was able to navigate to the site by googling on specific questions and entering through the search engine's found results. The problem resolved itself but left me wondering what had happened and why. I believe estimation from the pigeon is indeed correct.
posted by bkeene12 at 11:22 AM on May 4, 2007


Incidentally, set your MTU to 1,500 and see what happens.

You can use this site to fine-tune your MTU.
posted by humblepigeon at 11:30 AM on May 4, 2007 [1 favorite]


At risk of sounding stupid—because I really have no idea what I'm talking about: This happens to me occasionally. I unplug my router and modem for a minute. After plugging them back in and all the pretty lights settle down, I can suddenly surf to the troublesome sites again.

Magic!


posted by mealy-mouthed at 12:40 PM on May 4, 2007


Just a note here to say that I've been having the exact same problem as Eddie Mars, ever since Metafilter was down for a day or two at the end of March.

Note sure if you've found success yet, Eddie, but I've tried the suggestions on this page and nothing has worked so far. MUT on our D-Link router is set to 1492, and I'm apparently not able to set it any higher than that (according to the error the wizard gives me every time I try) -- could that be the problem? Any suggestions?

Thanks for asking this questions, Eddie. I'm looking forward to hearing the solution!
posted by EL-O-ESS at 1:43 PM on May 4, 2007


I have basically the same problem, though I don't have PCs running on my network at home. But still: my iMac won't load any metafilter sites (or a.whole, for that matter), but it loads at work just fine.

Actually, I take that back. I *was* able to connect to one MeFi post after a five minute wait maybe a week ago (a friend emailed the link), then couldn't load anything else.
posted by rocketman at 1:52 PM on May 4, 2007


I also have had exactly the same problem. I thought the site was down for several weeks, until I realised others could view it.

Changing my MTU (using Dr TCP) to 1400 worked for me.
posted by girlgeeknz at 4:31 PM on May 4, 2007


OK. First off, thank you everyone for all the suggestions.
First thing I checked tonight was the MTU since that seems to be everyone's preferred culprit. Router and Mac were both set to 1500. On unSane's advice, I lowered this to 1492 for both the Mac and router. I'm afraid that didn't help.
I checked the MTU on my work laptop(Windows), and it is set to 1300. I then ran humblepigeon's tool, and it said my connection maxed out at 1480.

Traceroute on the Mac gets to p02.car05.dllstx6.theplanet.com and then times out. From my Windows box, I can see that this is the second to last hop, must be the firewall also mentioned by humblepigeon.

My next step is to lower my MTU to 1480, then if that doesn't work 1400. I'll report my results.
posted by Eddie Mars at 7:53 PM on May 4, 2007


Woohoo! That did it. MTU of 1480, and everything is loading perfectly. Thanks again to everyone for their help.
posted by Eddie Mars at 8:02 PM on May 4, 2007


I had to change the MTU value on my Mac to get this to work, rather than changing on my router.

from the Terminal prompt:

sudo ifconfig en1 mtu 1464

If sudo doesn't work, you'll need to switch to an administrator account, e.g.:

su administrator

en1 is usually Airport, for Ethernet you can change this in the Network system preference pane by manually configuring it.

There's also a page at Apple that describes how to set this MTU value on reboot.
posted by vlotty at 7:19 PM on June 5, 2007


One thing I forgot to add...

Does anyone know how to do the iptables thing on the Mac?
posted by vlotty at 7:49 PM on June 5, 2007


« Older Where can I find interconnected bud vases to hang...   |   Are two monitors better than one? Newer »
This thread is closed to new comments.