The repair connection was NOT completed, liarpants. :(
April 18, 2007 4:16 PM   Subscribe

Why can't I maintain a stable internet connection, and what can I do to fix it?

I'm living in a home using whatever RoadRunner's residential ISP service is, with my parents using AOL in conjunction (though that shouldn't have anything to do with it.)

For the past month or so, I've had trouble maintaining a stable connection- it'll go out and not come back up for minutes at a time, and go back down randomly, as frequently as once every three minutes.

What you should know:

-we have a linksys wireless router.

-we have RoadRunner through Time Warner Cable. This occurs when the cable is still on.

-the program is on both computers, a compaq desktop using a linksys wireless adapter via usb and an HP Pavilion laptop using the built in wireless card, so I don't think the problem is with the computers.

-both computers are used almost exclusively in the living room, about ten feet from the router, so I don't think it's a distance issue.

-sometimes windows tells me I have a connection, and I'm sending packets, but not recieving.

-often windows will tell me there are multiple wireless networks to connect to, but when I go to look, there's only one network (ours) or none. It won't just automatically conenct to the home network, and even if I select to connect to ours, the "multiple wireless networks available" message comes back up.

-the cable guy came and checked it out, ran all new wiring, and said everything checked out on his diagnostic tests,

-all the lights that are supposed to flash on the router and cable box do- all the ones that aren't, don't.

-I have the latest firmware for the router.

-I've tried, to no avail to fix it by resetting the router (via the reset button on the back, as their help line reccomended to me).


So, oh, hive mind, what can I do to surf the web in stable, high-speed peace?
posted by Glitter Ninja to Computers & Internet (11 answers total) 1 user marked this as a favorite
 
Hmm...I don't know if you changed the SSID from the default "linksys" but I would first change the SSID into something unique and maybe change the wireless channel to 1 or 11. If your computer thinks it sees multiple wireless networks, then it might be that your neighbors are also using a linksys product and you're both on the default wireless settings.
posted by Cog at 4:44 PM on April 18, 2007


Alternatively, your neighbors might have turned off SSID broadcasting, but still be running on the same channel as you.

First thing to do is change your router's SSID; if that doesn't instantly fix your problem, change the channel.
posted by flabdablet at 4:59 PM on April 18, 2007


Are both computers connected wirelessly? And if so, when your PC loses connectivity, does the other one as well?

If so, it's probably a bad router, or the router and the modem are losing sync. (you can test for this latter instance by checking to see if when you lose connectivity to the internet, if you can still see the other computer.)

Other things to look for; if both computers are using wireless, and it's only yours that loses connection, it's something in your PC. Either the software or the wireless adapter you are using.

Is there any other 2.4ghz devices nearby? A cordless phone or a microwave? Both of those can produce enough 'noise' in the same frequency as Wifi to screw up a signal and drop your connection.
posted by quin at 5:01 PM on April 18, 2007


Oh, and if your router is losing sync with the modem there is a very easy fix: unplug the power to both the router and the modem. Plug the modem back in first and wait till the 'cable' light is on solid (I may be able to be more specific if you can tell me what kind of modem it is...) anyhow, once it's solid, plug the router back in and wait for about 10 seconds.

It might be necessary to re-choose your wireless network here, but that will get you back online.

Why does this happen? Modems take about 40 seconds to boot all the way up. Routers take about 10. If the router is on long enough, it could time-out and stop attempting to get a DHCP connection from the modem. Both devices are on and look like they are working but in reality, they aren't talking anymore.

I see this all the time after storms knock out people's electricity.
posted by quin at 5:05 PM on April 18, 2007


Check out the RoadRunner forums at Broadbandhelp.com. Other people in your area might be having similar connection problems and may be able to offer solutions. I was having a problem very similar to yours and the site was amazingly helpful (as compared to RoadRunner technical support).
posted by Otis at 5:32 PM on April 18, 2007


I've changed the SSID and the channel, and we'll see how that goes... is there any particular reasoning for selecting channel 1 or 11?

Update: after changing that, it's been the same all evening, and continuing to worsen.

There is a microwave nearby (it's a large open living room/kitchen type area) but would that still be the culprit if the microwave isn't currently being used?

I also synced the router and the modem- I have a connection for now, but I'm not sure how long that will last. I was checking your answers from my blackberry before I could get it back up.
posted by Glitter Ninja at 5:58 PM on April 18, 2007


The default channel is often 6, and channels 1 and 11 are as far away from that as you can get.
posted by flabdablet at 6:51 PM on April 18, 2007


The microwave would only interfere when in use.
posted by flabdablet at 6:52 PM on April 18, 2007


If you are using Windows XP, I had the same problem and fixed it this way. You might give it a try if you've tried almost everything else....

1. Go To Control Panel>System>Hardware
2. Click to go to Device Manager
3. Find Network Adapters in the list
4. Highlight the network card and right click
5. Go to Properties
6. If there is a tab on the far right named Power Management - click on it.
7. If you see a box that says, "Allow the computer to turn off this device to save power" UNCHECK IT.

This "power saving" of the network card is ridiculous and sometimes causes you to lose connection with your modem to the point of having to recycle, etc.

Good luck!
posted by Gerard Sorme at 7:24 PM on April 18, 2007


Just as a further thought; channels 1 and 11 are also common choices (although not quite as common as 6, because that's Linksys' and Netgear's default). It might help to take one of your laptops and try to look at nearby wireless networks and see what your neighbors are using, then choose the channel furthest from theirs.

The "channels" used in 802.11b/g networks really aren't separate channels, as you might think; they actually overlap quite a lot. (If you use ch. 3 and I use ch. 4, we're probably going to interfere with each other.) So there's a big advantage in choosing some wireless real estate that's as far from everyone else as you can.

In order to find networks that aren't broadcasting a SSID, it might help to use a "promiscuous mode" packet sniffer like NetStumbler.
posted by Kadin2048 at 11:38 PM on April 18, 2007


Uh. In new news, my laptop's wireless card seems to have kicked the bucket. I can barely detect networks, and if I can, I can only send, not recieve, packets. :/
posted by Glitter Ninja at 4:38 PM on April 19, 2007


« Older Make my Nano and the internet play nice!   |   Help me find a good beginner's mandolin? Newer »
This thread is closed to new comments.