Apache limiting my transfer speed?
March 22, 2007 2:59 PM   Subscribe

Apache Filter: Why are my downloads so slow from my web server running Apache?

I am currently running Apache 2.2.4 for directory browsing purposes only. Apache is running in Windows Vista Business with a 10 mbit up/down internet connection. When I download any files off this Apache server my speed maxes out at 150 KB/sec. If I use IIS instead of Apache then I can completely utilize my 10 mbit connection.

Is the default configuration in Apache limiting my speeds? If so, how do I fix this. Thanks much.
posted by mjger to Computers & Internet (9 answers total)
 
It sounds to me like an issue with the default value of SendBufferSize. Try setting it explicitly.
posted by vacapinta at 3:32 PM on March 22, 2007


Thanks for the thought, but it did not work. The SendBufferSize directive was not initially in the httpd.conf file, I had to add it. I then tried a few different values but there was no change in the transfer speed.
posted by mjger at 4:08 PM on March 22, 2007


I wonder if the limiting factor is your server's ability to do directory operations. It's not uncommon for the limiting rate on that to be HD seek speed.

Even though you don't use it that way normally, try putting a multimegabyte binary file (e.g. a big zipfile) on on your server and downloading it with HTTP to see how fast it comes down. That requires minimum processing on the part of the server and relatively few HD seeks, so if something really is capping your transfer rate it'll be obvious. Then do it a second time, so that it's coming out of the server's cache memory.
posted by Steven C. Den Beste at 4:30 PM on March 22, 2007


Do you have any QoS policies set on this machine?

Go to start-> run and type "gpedit.msc" ,then go to "Computer Configuration" -> "windows settings", "Policy-based QoS" (and also User Configuration -> Windows Settings -> Policy-based QoS) and see if there are any policies there which might affect Apache.

Also, is the machine on a domain? If so, there might be some domain-wide QoS rule which is affecting the transfer rate.
posted by helios at 4:35 PM on March 22, 2007


I don't know if the limiting rate is the HD seek speed. I have a Filezilla FTP server also running on that machine and I can max out my 10 mbit connecting using the FTP protocol. I will try a big zip file, though.

Helios, thanks for the tip. The machine is not on a domain. I personally have not set any QoS policies on the machine, but I will check anyway to see if there are any QoS policies affecting Apache.
posted by mjger at 5:13 PM on March 22, 2007


Downloading the same zip file changed nothing, still caps out at 150 KB/s

There are no QoS policies on my computer.
posted by mjger at 5:37 PM on March 22, 2007


That pretty much proves that your HTTP is being throttled, but I don't have any idea where such a setting would be. Sorry.
posted by Steven C. Den Beste at 6:43 PM on March 22, 2007


As a third option to try, just for testing purposes, have you tried installing an extremely light-weight server like TinyWeb to see what sort of performance you can get from that?
posted by Jimbob at 7:19 PM on March 22, 2007


I installed TinyWeb, and other light-weight web servers, and all of the are not throttling my connection.

Maybe I will try and earlier build of Apache server where the SendBufferSize is in the httpd.conf file.
posted by mjger at 9:28 AM on March 23, 2007


« Older How to stop displaying gmail headers?   |   Apartment Security: How can I make my particular... Newer »
This thread is closed to new comments.