How can I get Comcast Cable Internet access to work with a Linksys Wireless B Router?
March 15, 2004 11:10 AM   Subscribe

I have Comcast Cable Internet access and a Linksys Wireless B Router. How can I get the two to work together properly? Previously, I had Verizon DSL and the router worked like a charm. But now, when I connect the cable modem through the router to the computer, nothing works. I run OSX 10.2.8 on an iMac. Thanks in advance.
posted by BlueTrain to Computers & Internet (22 answers total)
 
have you just had the cable modem working with the computer directly? in my experience it takes some time (like maybe 12 hours) for the cable modem to work correctly with a new MAC address (ie a new piece of hardware). i think this is just the cable company being a jerk.

anyway, i would turn off the modem and try starting again tomorrow.

(but i've never fully udnerstood this, so hopefully someone who knows more than me will confirm/deny)
posted by andrew cooke at 11:19 AM on March 15, 2004


DSL may have had PPOE enabled. Cable modems typically don't require that (although you'll want to check with your provider to be sure)

Also, typically the modems are provissioned to only work with a limited number of MAC addresses. A MAC address is like hardwired address for ethernet cards. You may need to call up their support people and make sure that the MAC address of your router is in their system.
posted by willnot at 11:25 AM on March 15, 2004


Hmm, your router should work woth both Cable and DSL. Things to look at.
Login to the units web admin interface. Check with Comcast to see how you acquire your IP. You may have the router set to work the way your DSL provider needed it configured. Usually for Cable, you set it to take an address provided (DHCP) no static entries.

As Andrew asked, does your Mac get internet access with the router out of the loop? If so, I would definately look at the router config to make sure it isn't set to PPP or some static entry.

You might call Comcast and find out if they still bind to MAC address's too. If they do, then you need to give them the MAC address of the router.

Another thing you might try is a hard reset of the router. That would flash it back to factory settings. Power down the modem, hook the router to it, power the modem, then the router.

Good luck with it.
a3
posted by a3matrix at 11:29 AM on March 15, 2004


The Linksys wireless router can spoof the MAC address of another ethernet card. Log into the Admin interface and set the MAC address to the MAC address your computer uses.

I had to do this same thing with my girlfriend's router, while mine works perfectly out of the box, and we're on the same service and live within a 5 minute walk of each other.
posted by bshort at 11:33 AM on March 15, 2004


Unfortunately, I can't access the router's Admin page anymore. The cable modem works perfectly when connected directly to the computer, but once I take it through the router, nothing works at all. I've powered down and reset both devices several times. I'm just not sure what's left.
posted by BlueTrain at 11:51 AM on March 15, 2004


And apparently I'm been struck with so much anxiety that I'm repeating myself without realizing. Sorry.
posted by BlueTrain at 12:01 PM on March 15, 2004


When you have the cable modem attached to the router, you should be able to access the Admin page even if you don't have working internet access. Do you have the Mac set to use ethernet & DHCP in the Network System Preferences? I often tell people to make a fresh Location setting in there, just to make sure they haven't clicked some teensy checkbox on or off that would affect everything else. Making a new Location will give you fresh settings that should at least get the connection between the Mac and the router working.
posted by bcwinters at 12:11 PM on March 15, 2004


I setup a fresh location and it self-assigned an IP address but wouldn't access the Admin page.
posted by BlueTrain at 12:22 PM on March 15, 2004


What IP address is it assigning you? Typically when you reset these things it will make the IP address of the router
192.168.1.1

You need to be getting an IP that puts you on the same subnet as the router.

Does the unit have a reset button on it? Have you reset it? Not reboot, but an actual reset. There should be a little button. You may have to use a pen to press it.
posted by a3matrix at 12:35 PM on March 15, 2004


After resetting it, plug your computer in via an actual cable to one of the router ports (not the WAN port) and browse to 192.168.1.1.

The password is "admin" and the username should be left blank.

You should get an admin interface. MAC spoofing is under the "advanced" tab.

Also, don't give yourself an IP address, let your computer get one from the router via DHCP.
posted by bshort at 12:39 PM on March 15, 2004


bshort, I've followed every one of your options and it still won't let me connect to the router. Could it be a hardware failure, or is there some detail I'm forgetting?
posted by BlueTrain at 6:13 PM on March 15, 2004


What are your network settings? In particular what are the values for: Network > TCP/IP Tab > Configure:

Also, what values do you have for:
IP Address:
Subnet Mask:
Router:
DHCP Client ID:
DNS Servers:
Search Domains:

If you go to the Application Network Utility and Ping 192.168.1.1 what happens?
posted by willnot at 6:56 PM on March 15, 2004


The Config is "Built in Ethernet" and "Using DHCP"

The IP Address, which is self-assigned, is 169.254.29.61
The subnet mask is 255.255.0.0
No router
No DHCP Client ID
No DNS Servers
No Search Domains

The Network Utility results are as follows:

Ping has started ...

ping: sendto: Host is down
ping: sendto: Host is down
ping: sendto: Host is down
ping: sendto: Host is down
PING 192.168.1.1 (192.168.1.1): 56 data bytes
ping: wrote 192.168.1.1 64 chars, ret=-1
ping: wrote 192.168.1.1 64 chars, ret=-1
ping: wrote 192.168.1.1 64 chars, ret=-1
ping: wrote 192.168.1.1 64 chars, ret=-1

--- 192.168.1.1 ping statistics ---
10 packets transmitted, 0 packets received, 100% packet loss

posted by BlueTrain at 7:05 PM on March 15, 2004


Sorry, that's when the Router is connected by itself, without the modem at all.
posted by BlueTrain at 7:05 PM on March 15, 2004


Same results with the modem connected with the router. As you can already tell, I'm very new to the world of wireless.
posted by BlueTrain at 7:08 PM on March 15, 2004


there is a little reset button that requires a paperclip to actually push. it's on the front of the unit near the flashing lights. try that and then power it down by unplugging. after you plug the router back in you should be able to access admin at the 192.168.1.1 address. then follow all the instructions as above. ie, make sure your set to obtain an ip address automatically. you might want to check with comcast as to which subnet to use, if they have an odd #.
posted by damnitkage at 7:09 PM on March 15, 2004


This is my router. No front reset that I can see. One rear reset that I've pressed for quite some time.
posted by BlueTrain at 7:24 PM on March 15, 2004


Your Mac isn't seeing your router. Either your ethernet card in the mac is broken, the ethernet cable you're using to connect to the router is broken, the ethernet cable is not plugged into the proper port on the mac/router or the routher itself is broken.

I don't think you ever mentioned ... are you able to connect directly to the cable modem without the router in the middle using the wire you are using to connect to the router with? That would eliminate the Mac and the Cable as the source of the problem.

As damnitkage suggests, if it is the router, doing a hard reset with a paperclip may fix it. If it doesn't though, you may want to think about getting a new router.
posted by willnot at 7:29 PM on March 15, 2004


One other thing to look into... I assume you have a wireless router because you have something with a WiFi card. Can you see/log in to the routher over the wireless connection?
posted by willnot at 7:38 PM on March 15, 2004


Also, you might try manually setting your IP address on the Mac to 192.168.1.2 with a subnet mask of 255.255.255.0 and a router address of 192.168.1.1. Then try to ping the router at 192.168.1.1 and see if you can see it now. It might just be that the DHCP server in the router is down even though the connection is good. This would manually put you in the same network space.
posted by willnot at 7:48 PM on March 15, 2004


I called Linksys, who offered the exact advice as you, willnot, and unfortunately, after using two different computers, he came to the conclusion that the ports on the router are probably broken. So now I must go an additional 3 weeks without my wireless network and wait for the repair to be complete. Thanks everyone for your time and patience. This was certainly enlightening, to say the least.
posted by BlueTrain at 8:24 PM on March 15, 2004


BlueTrain, when you press the reset button on the back, what happens? Do the lights on the front go through a little test sequence? Do all the lights light up at one time or another?

When you have the computer attached to the router via a cable do one of the rows of lights go on?
posted by bshort at 9:53 AM on March 16, 2004


« Older Mysterious Condo Noises   |   AIM Security Newer »
This thread is closed to new comments.