What could be the problem with sharing an external drive?
March 11, 2007 6:48 PM   Subscribe

OSXFileSharingFilter: I have a friend who's trying to make himself a great file server off an old iBook - and has hit a snag involving a MyBook external hard drive. The problem makes no sense to me, and my Google-fu as failed me once again.

My friend's iBook (G3 800MHZ, 10.3 w/ every available update) is sharing two other external hard drives with no issue. However, when trying to remotely mount the MyBook (Formatted FAT32, Firewire connection) from his MacBook, no joy. The volume mounts to the desktop no problem, and is accessible from the host iBook - just no network support.

This is his largest drive, so its actually the most important to get working. While I like to think that my networking skillz are awesome, this one has got me baffled. So, what might be causing my friend this problem?

(If you have questions that need to be answered before you can give a diagnosis, ask and I'll get him to tell me.)
posted by plaidrabbit to Computers & Internet (7 answers total)
It's been a while since I tried it, but I think you need to use Windows File Sharing with drives that are formatted FAT32. So your friend has two choices - either use Disk Utility to erase the external hard drive and install the Mac OS Extended File System and then share it with Personal File Sharing, or leave the drive formatted as a FAT32 drive and then share it with Windows Sharing. He'll get better performance with the first option.
posted by RichardP at 7:08 PM on March 11, 2007

RichardP: really? that seems strange to me.

plaidrabbit: have you tried making a symlink to the big drive from some place that is accessible?
posted by rbs at 7:38 PM on March 11, 2007

Response by poster: RichardP: No dice. Thanks for the try, though.

rbs: No, but that's a good idea.

We've come up upon another oddity that may or may not be related - my friend can read/write from the host iBook, but can only read from the MacBook.

Thanks for the answers so far!
posted by plaidrabbit at 8:10 PM on March 11, 2007

it kinda sounds like a permissions problem to me. are the accounts they're trying to connect with administrator accounts? if not, you may need to give them permission to do stuff on the drive. (right click, Get Info, Ownership & Permissions) you can't set permissions on FAT32 drives, though - FAT32 itself doesn't support them - so you may find it worthwhile to reformat it using Disk Utility. reformatting it as MacOS Extended would improve performance anyway (I usually use the case-sensitive, journaling version - case sensitivity isn't that important but journaling is nice if the drive gets turned off/disconnected accidentially).
posted by mrg at 9:13 PM on March 11, 2007

The FAT32 filesystem has no notion of permissions, but you can (and possibly have) set permissions that apply to the whole drive via mount options. I'm a Linux guy, not a Mac guy, so I can't tell you specifically what to look for or where; just poking my head in to say that it could still be a permissions issue.
posted by flabdablet at 10:15 PM on March 11, 2007

I don't think that Windows File Sharing (which is really Samba) is limited just to FAT32. In fact I'm sure it's not. There might be issues with permissions because of how various filesystems store it, but I've definitely used Samba sharing on HFS+ volumes.

I'd say that using disk utility to repair permissions would be the first thing to try. After that, I'd start using Terminal and poking around to see what the actual permissions on files were, and seeing if doing a chmod ugo+rwx on a directory would suddenly make it writable over Samba on a Windows machine.
posted by Kadin2048 at 11:55 PM on March 11, 2007

Select the drive. Command-I. Ignore permissions on this volume or set so all users can read/write. Check "apply to enclosed items" at the bottom. Say yes when asked "Are you sure?"

Or erase and reformat the drive as HFS+?
posted by fourcheesemac at 5:01 AM on March 12, 2007

« Older Stop Dreamweavers Contributions to Contribute   |   Can I increase the time gmail shows me as being... Newer »
This thread is closed to new comments.