IE javascript error
February 21, 2007 6:18 AM   Subscribe

Hi I have IE ver 6 SP 1 and Win 2000 SP4 Operating system. In IE, I always get a javascript error icon in the the status bar while browsing websites. When I click the icon, it shows "Object doesn't support this property or method" or 'undefined is undefined', etc But the same websites open properly when I visit them from some other machine from internet browsing center. What settings do I need to check in my browser ? Javascript is enabled in my browser. Are there any IE updates or hotfixes for this problem ?
posted by inquisitive to Computers & Internet (15 answers total)
I have admin rights. I am myself the administrator.
The sites load on my machine, but with javascript errors.
posted by inquisitive at 6:39 AM on February 21, 2007

Even this metafilter site shows a js error "Unexpected quantifier".
posted by inquisitive at 6:40 AM on February 21, 2007

Just untick the "display javascript errors" box in the Internet Options panel.
posted by Rhomboid at 6:46 AM on February 21, 2007

Here's a problem resolution page from Microsoft that seems to address what you're seeing. Looks like you've already tried the first thing they suggest under Resolution ("Test a Web page from another user account, another browser, and another computer").
posted by hangashore at 6:47 AM on February 21, 2007

Oh, and BTW JS errors are totally benign. You can pull up the Javascript console in Firefox and see hundreds of them. It's just a sign of how sloppy/lazy a lot of webmasters are. If you actually surf with the "display JS errors" thing enabled you'll go crazy.
posted by Rhomboid at 6:48 AM on February 21, 2007

Or upgrade your version of Windows. You're shooting yourself in the foot when it comes to service packs and updates by using 2000.
posted by ReiToei at 6:48 AM on February 21, 2007

Do you have some sort of popup-blocking script? "Unexpected quantifier" is an error that typically comes from regular expressions, which are a common means of filtering out content. Alternately, it could be spyware, looking for specific content to use for whatever nefarious end. Have you downloaded AdAware?

All things aside, though, use Firefox. It's just better.
posted by mkultra at 6:50 AM on February 21, 2007

>> Just untick the "display javascript errors" box in the Internet Options panel.

It is already unticked. Status bar shows a yellow error icon, on clicking which I can see the javascript error messages one by one.

I dont want to use Firefox. Pls. suggest a fix for IE .

The websites load on my computer, but then some links dont work sometimes, coz of js error I guess.
posted by inquisitive at 6:51 AM on February 21, 2007

>> Do you have some sort of popup-blocking script?.

posted by inquisitive at 6:52 AM on February 21, 2007

I presume you've tried reinstalling the service pack?
posted by ReiToei at 6:53 AM on February 21, 2007

And have done a spyware/virus scan?
posted by ReiToei at 6:54 AM on February 21, 2007

yes. I have done spyware, anti-virus scan. and I have re-installed SP4 also.
posted by inquisitive at 6:58 AM on February 21, 2007

It sounds like you've got spyware, or an add-on that's misbehaving, or something that's modifying page content (I think some security packages insert their own JavaScript and remove bits they think are dubious).

As with any weird behaviour in Windows, you have to be wary of malware and scan the machine thoroughly.
posted by malevolent at 7:01 AM on February 21, 2007

(Have you tried doing View Source on a simple page and comparing the results with another PC? That'll tell you if something's messing with the page source and might narrow it down)
posted by malevolent at 7:02 AM on February 21, 2007

Guys, the problem is now resolved thanks to hangashore's post. I followed the link and the instructions there, downloaded the Microsoft Script Engine, installed it, restarted comp, and now the IE problem has vanished.

Thanks a lot, hangashore.
posted by inquisitive at 7:10 AM on February 21, 2007

« Older Help me spend my loonies wisely.   |   how to restore the warning in itunes for playlist... Newer »
This thread is closed to new comments.