What's this directshow software doing?
February 2, 2007 12:44 PM   Subscribe

I recently noticed that some video downloads were failing because the video files were `in use'. Then I noticed that for very brief moments, an icon which turned out to be `Ogg Direct show filter' was flashing on and off in my toolbar. How can I stop it?

It seems to be accessing files for no reason, I don't have the directory open, don't have any media players going.

This program shows up in such short bursts that I am unable to see it as a process and stop it. I can only imagine it was part of a codec pack I downloaded a while back, but why it is running so often I don't understand.

This is on a windows XP machine.
posted by tomble to Computers & Internet (4 answers total)
You likely have some sort of file indexing software going (Microsoft Desktop Search or Google Desktop Search, for example).

Open its configuration and see if you can exclude your media directory.
posted by owenkun at 12:58 PM on February 2, 2007

It's a codec for Windows Media player which will allow you to play FLAC files. To uninstall, close media player, go to control panel/add remove programs, then remove oggcodecs.
posted by caddis at 1:16 PM on February 2, 2007

Owenkun, I think that did it! I installed google desktop a little while ago, and forgot that it continually accesses new files. Thanks!

Caddis, I'll give that a go if I can't stop Google desktop, FLAC files are a rarity for me.
posted by tomble at 1:33 PM on February 2, 2007

Is this happening while you browse files in explorer? Like for 1.5secs after you click on an item? I think this a shell exentension overstaying its welcome.

In my experience the "AVI Properties Handler" shell extension makes manipulating video files much more difficult (extra slowdown on my 5yr old thinkpad). I think this is an extension that came with one of the codec packs, it queries extra metadata (dimensions, codec, length, etc) and also creates thumbnails.

A tool you might find useful is: NirSoft ShellExView. This allows you to disable certain shell extensions. When I disabled this shell extension I no longer would bang my head into the wall about files in-use.

Two additional suggestions:
#1 Wait 2-3secs after selecting before manipulating files (delete, rename, drag-n-drop) for the extension to release the file locks
#2 If you want to see the file locking in action, open a folder full of videos, switch to detail or thumbnail view and watch it fill in the details and create the thumbnails, one file at a time.
posted by notpeter at 7:46 AM on February 3, 2007

« Older PHP/MagpieRSS troubleshooting   |   So I went the white boy way of slinging... Newer »
This thread is closed to new comments.