Excel mindless list jumping
January 29, 2007 12:53 PM   Subscribe

Stop Excel from jumping to end of column when double clicking on cell border

Man this is driving me crazy....is there any way of stopping Excel from jumping around when you accidently double click on a cell border, e.g. jumping to end of list when hitting the bottom border, to the top of a list when double-clicking on the top border.

This 'enhancement' is a pain in the ass when you are working on edits to a large list and one wrong double-click brings you to the end of the list whereby you have to find where you were working again.

In the absence of stopping - is there an event handler associated to it that can be macrozied, etc., or a go back to where I was shortcut...thanks!
posted by clarkie666 to Computers & Internet (10 answers total) 2 users marked this as a favorite
 
I haven't tried this because I don't have ready access to Excel at present, but have you tried hitting ctrl-Z (undo) and then ctrl-Y (redo) immediately after this has happened to you?
posted by flabdablet at 1:39 PM on January 29, 2007


Thanks but no, there is no state change in excel, so nothing to undo
posted by clarkie666 at 1:48 PM on January 29, 2007


My thinking was that if you undid and redid whatever the last change was, you might well end up with the focus on the cell where the last change happened - which would count as a "go back to where I was" shortcut.
posted by flabdablet at 2:10 PM on January 29, 2007


Google-fu found me this utility

Here

GoBack.zip (8 February 2005, Downloaded: 2227 times) Version 1.0 build 003.

Sometimes one has to edit a large workbook, with many worksheets. This tiny utility keeps a record of the ranges you have visited and gives you the opportunity to return to previous selections using two hot keys: control-alt-p to go to a previous selection and control-alt-n to go to the next. It also creates a toolbar with a dropdown to select a previous selection and to disable/enable the utility.
posted by Andrew Brinton at 2:17 PM on January 29, 2007


I don't know, but the best Excel forum that I've found is at www.mrexcel.com. Click on Message Board on the left. You'll have to create a free account before you can ask a question. I have asked these guys some of the toughest questions imaginable and they normally come through, often with brilliant solutions.

I messed around for about 15 minutes in Excel, and I can't find a way to turn off or disable the "feature" that you're referring to. Maybe it's impossible, but the Mr Excel guys will know.
posted by crapples at 8:01 PM on January 29, 2007


OH MAN I hate this. I do not, however, have an answer for you, But I eagerly await one.
posted by rhapsodie at 12:20 AM on January 30, 2007


Rather than double clicking on a cell in order to edit the text, you can press the F2 key. You won't have to double click on any cells ever, so your problem won't occur.

Might be more trouble than its worth to switch change the way you work, but would make the problem go away.
posted by Touchstone at 12:45 AM on January 30, 2007


thanks for the comments folks, I will give it a shot at the excel forum and update if I get anything. AB - that looks like a way back to where you were even if there is no way of turning it off....this is just a really crappy 'feature'.
posted by clarkie666 at 1:10 PM on January 30, 2007


Emailed to me by Lurky McLurker, and it totally works! Yay!

(Because it has annoyed me for a long time, and I just found the answer.)
If you don't use Cell Drag and Drop, then your annoyance can be turned off.
Go to Tools > Options > Edit (tab) and uncheck the box for "Allow cell drag and drop".
Turning Off Cell Border Double-Click, microsoft.public.excel.misc, Aug 20 2003
posted by rhapsodie at 1:57 PM on January 30, 2007 [1 favorite]


rhapsodie, Lurky McLurker and Laura Cook of Appleton, WI for the win. Thanks a million rhapsodie for posting. Note to Microsoft - get rid of this, it sucks...
posted by clarkie666 at 2:13 PM on February 5, 2007


« Older Help! I lost my spice!   |   Living in a Van Newer »
This thread is closed to new comments.