How to deal with two routers: one wireless, one wired?
January 24, 2007 1:41 PM   Subscribe

How do I get my wired router network to see my wireless router network? Are they the same thing?

(I generally like to ask questions which other people may benefit from, but I'm afraid this one may be too user-specific.)

I have a modem/ethernet router. This is then plugged in to a simple wireless hub (La Fonera) which then means that my lan is broadcast around the house. I have now plugged my FreeNAS box into the (wired) ethernet router. How can I get it to see my wireless lan?

For reference:
ethernet router: 10.0.0.2
wireless router's ip address according to router: 10.0.0.9
wireless router's ip address according to computers on the wireless network: 192.168.10.1
my computer's ip address (on wireless network): 192.168.10.1.

If it makes a difference, all subnet masks are 255.255.255.0

All the different numbers are confusing me, can someone help?

Thanks for your time!
posted by edbyford to Computers & Internet (15 answers total)
 
Ugh, that's (sorry) an ugly network. A quick googling seems to indicate that it's a locked-down distributed free wifi thing, which means that's pretty much a black box as far as configuring anything goes unless you want to try to hack it (you don't).

What's happening is that your wired router is doing something called NAT to give you a tiny private internet all of your own, 10.0.0.0/24 in the speak and acting as the intermediary between that private network and the real internet. The La Fonera is doing the same thing, just using a different private network 192.168.10.0/24. Since the wireless is inside the wired router's network, it should be possible to access wired devices from wireless devices. It is almost certainly not possible to go in the reverse direction.

Depending on the La Fonera's configuration, you should be able to, from a wireless or wired device, contact the FreeNAS box by its IP address (10.0.0.? you'll have to find this out from your FreeNAS).

It looks like FreeNAS has some kind of web interface, try putting it's IP address into a web browser on a wireless machine and see if it works.

You will most likely not be able to have the FreeNAS initiate any contact, as it has no idea how to get to 192.168.10.0 addresses. Clear as mud, huh?

Honestly, I'd be impressed if this setup worked even remotely well. I'd recommend just popping down to a computer store and picking up Linksys' cheapest wifi router unless you have a compelling need for the La Fonera. Black box routing devices are bad mojo.
posted by Skorgu at 2:15 PM on January 24, 2007


Also, you probably have a typo on your computer's wireless IP address, or your network is profoundly broken. 192.168.10.1 should be the La Fonera device, and your computer should not be sharing that IP. Maybe your computer is 192.168.10.100?
posted by Skorgu at 2:16 PM on January 24, 2007


So your setup goes
line-modem/router-wifi hub-wireless computers
                 -other wired computers 
                 -NAS
The problem, in short, is that the wireless hub is creating a second network, and the two aren't set up to talk to each other.

Most wifi hubs do include downstream Ethernet connectors. The simplest thing to do is to plug everything into those connectors (your NAS box, your wired computers); if there aren't enough ports, an Ethernet switch will give you the additional ports you need and will pose no routing problems (this is my home setup).

There probably is a way to get the two networks to see each other—that's a little beyond my expertise—but letting your wifi hub handle all the NAT duties (both wired and wireless) is more elegant, IMO.
posted by adamrice at 2:23 PM on January 24, 2007


On postview, skorgu's right. This node won't support downstream ethernet connections, so pick up a cheap wifi hub that does.
posted by adamrice at 2:28 PM on January 24, 2007


If you got your Fonera router from FON, it's probably configured out of the box NOT to allow your wireless network to talk to your wired network. This is a good thing, since any FON user can get on your wireless.

The Fonera is supposed to be able to support two SSIDs, one for FON users and one for your private network, so I'd recommend checking the FON message boards to see how to activate and use the private wireless network.

The FON concept is kinda cool and I tried one of their older LinkSys routers, but it didn't support dual SSIDs and broke my home network in the same way, making it useless.
posted by ldenneau at 2:42 PM on January 24, 2007


I see that some people have had success flashing La Fonera with some kind of OpenWRT software. Any suggestions on that? And also, yeah, that is a typo: my computer's IP is 192.168.10.224
posted by edbyford at 2:58 PM on January 24, 2007


I got in with Fon when they started offering WAPs, and I got a Linksys WRT54G, version 4 which is fully flashable to OpenWRT. Well, it's not running the FON software anymore, and I got the router for $5. Can't complain there.
posted by ganzhimself at 3:13 PM on January 24, 2007


For the La Fonera, you might look into DD-WRT software as well. My impression is that it might be more feature-rich and user-friendly than OpenWRT. There is a massive thread on the DD-WRT forum on the Fonera.
posted by exogenous at 3:18 PM on January 24, 2007 [1 favorite]


I haven't got any experience with FreeNAS, but the "double-NAT" problem is a common one for many people that start with a wired network and then upgrade to wireless. There is absoloutely no need for both boxes to be doing NAT and it just makes the network needlessly complicated (and might actually be slowing you down a bit!).

My solution to the problem is to select one device to handle the connection to the Internet and the handing out of IP addresses and use the other as a glorified modem/access point. In your case, I'd do the following:

1. Log into your wireless router via the web interface (go to 192.168.10.1 in a browser on a wireless machine)
2. Find the setting for DHCP and turn it off. At the same time, change the address of your wireless router to something on the 10.0.0.x network, like 10.0.0.200 .
3. Change the plugs on the back of the wireless router so that an ethernet cable goes from a port on the wired router to one of the LAN ports on the wireless router. The WAN port on the wireless router should be left blank.
4. Turn off all the computers and both routers and turn it all back on again.

VOILA!

What should happen is that your wireless router is now configured as a simple wireless access point. Your wired router is the only device that hands out IP addresses and does NAT, so all devices on your network should get a new address in the range 10.0.0.x, including the FreeNAS box (I assume this is how it works?). You can (and should) still set WPA on the wireless router to stop people accessing your network.

This should solve your problem and also give you a much nicer network setup going forward, that is less complicated, faster and easier to manage!
posted by ranglin at 3:22 PM on January 24, 2007 [1 favorite]


Ok, reading a little more closely, my post assumes that you can log in and change the settings on the wireless "Fon" thingo... But maybe you can't? If you can't change the wireless router settings, you need to make the wired router into a simple modem rather than a NAT device. This process varies a lot with the wired router you are using, but if you tell us which one, we might be able to help...

Or, you can try and do what adamrice suggests, but it will still double-NAT, you are just putting all computers on the one network segment!
posted by ranglin at 3:28 PM on January 24, 2007


A FON is a free router with the condition that you share your internet usage with other FON people. Advising him how to hack it and defraud this company is really pushing it, even for askmefi.

I suggest purchasing a legitimate wifi device link a linksys or a belkin. You can get wifi access points which are not routers or ones that you can put into gateway mode so you dont route. (you already have a router)
posted by damn dirty ape at 4:07 PM on January 24, 2007


@ranglin
That sounds like a great idea! Thanks for the tip. You are right, I can access the web GUI and change settings, including DHCP. Unfortunately, on La Fonera, there is only one ethernet port (simply for plugging in your existing router). Is this a problem, looking at step 3 in your plan?

I have to go to work now :( but will try everyone's suggestions when I get back, and post replies when I can.

If anyone else has any input, please keep posting and I'll check it out when I get back and try it at the same time.

Thanks again for your time! Much appreciated.
posted by edbyford at 11:44 PM on January 24, 2007


Please help! Tried above advice of disabling DHCP on the router, and getting it to work as wireless access point.

This has now had the effect that I couldn't access the wired router through wireless! Strange - also it seems that I can't get on to La Fonera's GUI to change it back. Any advice on this?

For troubleshooting, I wired up my computer to the ethernet router and took La Fonera out of the loop. I only just got the FreeNAS box to connect to wired router and even then, pinging it is very slow (6000ms, compared to less than 1ms on my other computer). Also, it's not actually showing up to any of the other computers!

Any help? Don't fail me in my hour of need, o mighty hive mind!
posted by edbyford at 5:00 PM on January 25, 2007


Not sure how the lack of a LAN port on the wireless router has affected you here.

You should probably check the IP address on different devices (especially a computer connected wireless-ly). I'm wondering whether you've still got two networks going on here (10.0.0.x and 192.168.x.x), which would explain why the wireless machine can't access the wired network. If that's the case, you might not be able to do what I suggest because of the way the wireless router works.

Otherwise, if everything is on the same subnet, then I agree that it's all a bit strange. Maybe some other MeFi's can help with more information about the Fon device?
posted by ranglin at 10:43 PM on January 25, 2007


Would this WAP serve my needs or would I need a wireless _router_?

Still trying to get the Fonera working though!
posted by edbyford at 12:04 AM on January 26, 2007


« Older Health insurance and taxes   |   Is there a name for the stains left on sidewalks... Newer »
This thread is closed to new comments.