What happened to my Application Data folder?
January 15, 2007 6:34 AM   Subscribe

Windows XP - My "Application Data" folder is still hidden even with the correct folder settings...

Ok, I've done the normal things -- Tools > Folder Options > View > Show hidden files/folders, unchecked "hide extensions for known file types," and "hide protected OS files" -- and my Application Data and Local folders are still hidden. I can access them by typing the full path in the Explorer address bar, but they don't show up in the folder tree. (I have administrator privileges.)

I've tried resetting the folders to default values and then changing back, but still no luck. I've Googled, checked Google Groups and have come up empty-handed.

Anyone out there in MeFi land have any idea why I can't see these folders even with the right Explorer settings?
posted by ssmug to Computers & Internet (12 answers total)
 
Have you checked the ACL on the parent folder? If I remember correctly, traverse checking is not enabled on Windows by default, so you can still access the contents of subdirectories even if you don't have the Read or List Contents permissions on the parent (or any parent up the chain.)
posted by Rhomboid at 6:47 AM on January 15, 2007


Response by poster: Hmm...I'm listed as having full control, and have changed my account to owner, but the folder is still hidden.
posted by ssmug at 7:40 AM on January 15, 2007


So what are its attributes? From the command prompt in the parent directory type:

attrib "Application Data"

What does it say? Can you see it when you type 'dir' at the command prompt?
posted by Boobus Tuber at 9:44 AM on January 15, 2007


Response by poster: Boobus:

When I do the attrib, I get HR C:\Documents and Settings\(User)\Applicatin Data

I cannot see the folder when I type dir at command prompt.
posted by ssmug at 10:01 AM on January 15, 2007


Well, it shouldnt display from a dir command if it's hidden. It doesn't really answer your question, more just works around it, but you could make it not hidden. Then it should display in explorer.
posted by Boobus Tuber at 10:21 AM on January 15, 2007


DIR/A displays all the Folders/Files for me.
posted by Ferrari328 at 12:01 PM on January 15, 2007


If you do dir /a:h do you see it?
posted by blue_wardrobe at 12:03 PM on January 15, 2007


Response by poster: Ferrari & blue_wardrobe:

Both dirs display the folder. Any idea why it's still hidden in Explorer?
posted by ssmug at 12:44 PM on January 15, 2007


Things I would try:

1) Have you restarted Explorer from scratch since changing the settings?

2) Some hint that desktop.ini settings in the containing folder can cause odd behavior in Explorer. Wanna try deleting or renaming it, and then restarting Explorer?
posted by blue_wardrobe at 1:07 PM on January 15, 2007


And then I would double-check the settings you say you've tried, just in case I tremble-clicked something.
posted by blue_wardrobe at 1:08 PM on January 15, 2007


So what happens if you unhide it?

(attrib -h "Application Data")
posted by Boobus Tuber at 1:25 PM on January 15, 2007


Response by poster: Blue_wardrobe:

I restarted Explorer, but that didn't work. I did move my "My Documents" folder to a separate drive (changed the Target location) a couple of days ago -- could that have affected things? Unfortunately, I hadn't tried to view hidden folders before, so I can't give a before/after.

Boobus:

That worked, thanks. I'm still curious why the normal things haven't worked...
posted by ssmug at 2:11 PM on January 15, 2007


« Older Is there a log of activity on OS X?   |   Converting videos with odd aspect ratios. Newer »
This thread is closed to new comments.