iPaq hates WEP WiFi
November 22, 2006 4:22 PM   Subscribe

Ok, I have an HP 4155 iPaq and a WEP-enabled Netgear WGR614v6, but they don't connect. Any other computer can connect to the WiFi, and the PDA can connect to unprotected signals.

When I attempt to connect, the iPaq asks for the passcode. This is my first problem: Do I use the generated phrase, or the base keycode? I'm not sure because while this box has no other options, in the network settings dialog there is a "key index" setting.

Anyway, I have tried both, so I don't think that's my problem.

Once I enter the passcode, the PDA attempts to connect, but just "times out" for lack of a better phrase. Am I just missing something here, or is this another feature HP forogt to implement correctly?

I believe I have installed all of the WiFi updates for the iPaq, and the reason the siginal isn't WPA is because the iPaq only supports WEP (I think). Please no network security tips on WPA vs WEP. No solution will be too hard - I'm the resident guru :)

And that bouncing Santa gif is pretty cool.
posted by niles to Computers & Internet (9 answers total)
 
Does it connect to the Netgear WGR614v6 without WEP (or any other encryption) enabled?
posted by ODiV at 5:12 PM on November 22, 2006


Yes, it connects fine without encryption. I don't have any other encrypted connections to try it on, so I can't tell you if it will work with other routers using WEP.
posted by niles at 5:17 PM on November 22, 2006


Is it feasable to disable encryption and use MAC addresses to secure your network from unauthorized use?
posted by ODiV at 6:14 PM on November 22, 2006


Is it feasable to disable encryption and use MAC addresses to secure your network from unauthorized use?

No, that's never feasible, because MAC addresses cannot be used to secure your network from unauthorized use. They are easily sniffed and spoofed.
posted by kindall at 8:55 PM on November 22, 2006


Right - I was using MAC addresses for a long time, but I want to at least pretend my network is secured.
posted by niles at 10:09 PM on November 22, 2006


On the other computers that can connect to the Wifi, what key are you using? Sounds to me like you are using the wrong key on the ipaq. Try creating a new connection, where you put in the network name,wep key etc. I have an 3115 and if you click on the wireless icon (bottom right) and then go to settings and then add new, that should do it.
posted by Ferrari328 at 7:32 AM on November 23, 2006


You probably already know this, but there is more than one type of WEP encryption.

64-bit and 128-bit.

Maybe check which the HP uses, if not both.
posted by doomtop at 10:43 AM on November 23, 2006


afaik, you should use the actual key and not the phrase you used to generate it. you may need to convert it to hexadecimal before it works (see here). also, seconding doomtop - if your router supports (and you're using) 128-bit WEP encryption and the iPaq doesn't support it (which is possible if you have an older unit - some wifi card manufacturers used to charge extra for 128-bit encryption) then it'll act like you didn't type in the key right.
posted by mrg at 11:20 AM on November 23, 2006


Ferrari: It acts like I'm entering the wrong key, but I don't know why it would.

doomtop, mrg: Well, it doesn't appear to be 64 vs 128 bit (though I didn't think to check that), but that gave me a few new Google search points. It looks like I'm not the only one with WiFi and HP iPaq trouble - and given their track record with Bluetooth, I'm not all that surprised.


Thanks for the tips. If I ever get this working, I post the answer here. And if anyone else has ideas, I'll check back every now and then.


Now, if I can find a really long network cable....
posted by niles at 10:55 AM on November 24, 2006


« Older What to do for four days in Hanoi?   |   Please recommend some podcasts Newer »
This thread is closed to new comments.